JMB VL-3 Propeller Settings does not work any more

It is not possible to set the propeller for the JMB VL 3 any longer (it stays at 100%).
This stopped working a few weeks ago.

No mods or addons used.

Hi,

same for me, doesn’t work anymore.

There is a keyboard shortcut Ctrl+F2 / Ctrl+f3

1 Like

Although the knob for RPM does not currently work, I noted that the RPM is adjustable using a prop lever on the Bravo Throttle.

Also, the VL-3 Rotax 915 mod is great. It’s my go-to touring aircraft now.

It also works on my Thrustmaster quadrant.

On Microsoft version, RELEASE 1.21.13.0

The propeller pitch adjustment system is still not functional in the cockpit, despite the various updates. Could you please fix this problem which has been going on for a while in the next patch? The fact of using the keys, removes realism.
Thanks

Did you file a Zendedk ticket? Posting here will not reach the developers.

1 Like

thanks i will do this

Neither will Zendesk. The only thing I ever got from them is a reply not at all connected to my request.

Still not connected after the Italian Malta update. Sardinia Bush Flight uses the JBM VL3.

1 Like

Still doesn’t work in SU10 Beta on Xbox Series X. Discovery Flights in this plane start with RPM flashing red, and the only way to reduce is to pull the throttle below 30%. I’ve reported this in the bug reports, but it’s been ignored so far.

Happy third birthday to this issue!

This plane got the avionics upgrade in SU15 beta, but the prop controls still don’t work.

1 Like