Joystick configuration problem PC

Hi,

After i had some problemes with my MS Sidewinder Force Feedback 2 joystick in MSFS2020 XboxGame pass PC version, i looked up posible fixes and it said to Restore/Reset the Joystick to Default in the Profiler, but instead of going back to the setting the game configured the stick with, it deleted/corrupted? them and now ive ended up with the problem that no matter what i try the game wil not configure the stick correcty.

Also tried manualy configuring the stick but thats a hell to figure out with so many functions including ones that got a similar function/discription…

I have already tried unpluging the stick, deleting the appdata/local/flightsimulator folder content, starting the game, and than plugging the stick back in and both selecting default or configure made no difrence, the stick still didnt configure it self.

Uninstalling the game, deleting the instalation folders etc. of the game, and reinstalling it also doesnt help.

Seems the game keeps downloading the “corrupted” Configuration files for the Stick from the Cloud.

Does anyone know how to get the Game to set the Joystick back to its original configuration profile?

Things i was thinking about but dont know how to where to install the game on a friends Xbox Game Pass account and plug my stick in so the game configures it and than copy the file to my PC, but maybe thats not even posible?

Hopefully someone knows the solution…

No offense, but after each profile change or modification, you must click on ‘apply and save’. Do you ?
EDIT- If you can get configured properly on your friend’s computer, simply write down those settings. Create a new profile with those settings on your system and Apply and Save. Delete all the corrupt files first. Again, you must Apply and Save each time. You can’t install your copy of MSFS on your friend’s account.

Hi, Thanks for your reply.

Like i said, i had a problem with the sticks configuration/settings and found somewhere that the solution was to reset the stick settings to default in the controle profile manager, so yeah, naturaly i clicked on aply thinking it would reset the sticks settings to the settings the game aplied for the stick the first time i installed it, but instead of resetting it seems to have deleted everything and saved that to the cloud.

Sadly my friend doesnt have a Xbox Game Pass subscribtion anymore, so once again i am uninstalling and reinstalling the game again, but this time i am trying to prevent the game from syncronizing from the cloud, seems Xbox has an hidden option to delete the cloud saves, but on the PC that option is not available.

Yes it is. At the bottom of Controls Options ‘Open Preset Manager’ has the Trash can. Select the profile you want to delete and click on the trash can. You can do this with all but the Default.

Trouble is the Default is Empty, and i didnt click the trashcan but circle arrow to reset/restore its setting, instead it deleted all the settings.

Figured out how to Delete the Cloud Saves, but that didnt help, it wont auto configure the joystick… did restore/change the settings for my Xbox controller LB and RB functions (throttle up and throttle down) to A and B buttons.
Starting to think that way back wen the game was stil in Alpha/Beta i may have took the time to configure the Sidewinder Force Feedback 2 stick, and maybe back than there where less functions to pick from, and it was a bit simpler.

To delete the Cloud Saves all you have to (with game closed) do is open Comand Promt as Adminestrator and type in: start shell:appsFolder\Microsoft.FlightSimulator_8wekyb3d8bbwe!App -DeleteCloudSaves
The game wil than start and wil open with the settings screens with all setings restored to default.

I, also, don’t remember what I did years ago to configure my MS Sidewinder FFB2.

But I don’t remember doing much. And I had a Profile for it that seems
to have been automatic from the cloud.

Is your FFB2 listed in Windows as a game controller?

Didn’t know about that Command Prompt entry for deleting cloud saves. I filed that, thanks. I use the VKB Gladiator and that has no default settings either, but MSFS did accept and keep all my settings for different aircraft.

It might be, that old a device needs to be calibrated and configured in Windows First. It’s been a long time since I used it, but it is in W10 (W11?). Just search on windows JS calibration and see what pops up. Once you use that one, it should then transfer to MSFS for the default profile to pick up and then you can start from scratch and get it working. Curious, is it USB or the old Game Port hookup on that one. I had one, and it was maybe the best joystick I ever had up to my virpil stuff now. I have not seen one in a long time; never got sloppy unlike other brands I have owned.

And the first generation of it was a game port connection. The second-generation device used USB, I thought about getting it, but then believe it was over 100 dollars, so passed as my original one was working fine. We moved, and quit flying for a while, then Century of Flight came out, new hardware in PCs and made mistake of giving away my unit, and got Logitech 3D Pro, it was not as good a device. And did not run well on Vista or Windows 8. Now 10 works fine in, but wow, old, so got all new virpil stuff 18 months ago and happy with those things.

I don’t remember setting it up at all, I think i would have remembered if it was so much work as it is now, Just remember i was anoyed there was no Force Feedback.

And yes Windows lists it as a Game Controller, I also calibrated it in Windows.

1 Like

It is Calibrated in the Game Controller screen, you can not configure it in there, just test all the buttons and axis and calibrate the stick.

Sidewinder Force Feedback 2 is as far as i know always USB.

You can find them second hand online pretty easly, just use regular second hand advertisment sites, not the once that are related to a flight simmer community, because they usualy ask to much on there.

I only payed €2,50 in mint condition for mine in a thriftshop :smile: and had it for years now.

I am currently configuring the Joystick manualy but still keep running into the same problem, so i start an other topic as its unrelated to this problem and still hope someone knows more about this one.