Joystick to SimConnect Mapping Utility - Honeycomb Bravo Throttle Mappings Included

OK re-assigned the flap lever in FS and that now works. The only minor glitch is the AP annunciator on the PFD. Now I can switch it off with the mouse and I get the chime and the AP will go from green to white and then yellow. Although I get the AP disengage chime using the Bravo panel switch and the panel switch light will go out, the AP on the PFD remains green.

Oh and landing gear worked when I switched to another plane to test that. :slight_smile:

All in all a great little app that gets rid of that blasted heading bug.

So thanks very much, it should be advertised on the main community thread to let more people know.

Pity I don’t have any .NET experience or I might be of some help with debugging the alpha and bravo combo.

I’d be interested to know if the Alpha only profile works. If you have the time it would be useful to test two ways, one with both the Alpha and Bravo plugged in and two with just the Alpha plugged in and the Bravo completely disconnected. Each test should be done with the “Alpha Yoke - Stand Alone” profile selected in FS_Tool.

Curious to see what happens when Honeycomb releases its driver software for the Bravo,

are they going to?
The Alpha has been out for ages and they don’t have a driver package for that yet & it suffers from the same problem!

Was going to do just that. Just having lunch and will give it a go after.

I guess they are waiting on Asobo to get off their butts and fix it once and for all. Which is downright lazy on HC’s part, as they now have two products for sale that they know doesn’t work properly for MSFS. Funny, they don’t mention that on the box.

I mean if you guys can whip up a solution that works for now, so can they.

I agree because Honeycomb are “partners”

But to be honest while honeycomb could work out a simconnect driver/app solution, that would only solve the problem for Honeycomb device users; not for anyone else using a different controller with rocker switches

OK just jumped into FS and as both Alpha and Bravo were still plugged in I did that test first, after having selected Alpha Yoke- Standalone and confirming simconnect was running.

On the Alpha I got nothing, no always on switches or mags.

Nothing except sliders worked on the Bravo, including flaps, though funnily enough in external view the indicator moved, but not the flaps.
Unplugged the bravo and tried again, nada from the Alpha yoke, no change.

Closed MSFS and restarted the sim with only the Alpha yoke plugged in. Again, from cold and dark no panel switches or mags on the C172.

So it seems for me, the Alpha on it’s own is not working. Did it work for @Ziesel1106, when he tried it? I may have done something wrong.

Does this support mapping to an axis? E.G. Mapping 1:1 Deflection % to joystick range?

Few other posts have mentioned that this dramatically improves the twitchy feeling the planes have.

I don’t think so - I wasn’t sure if he had tried the Alpha only which is why I asked you.

It’s pretty conclusive that there is something that my code is doing or not doing that is specific to the Alpha - and possibly other controllers that do whatever the Alpha is doing - no way to find out what it is without being able to dig into the raw data coming from the Alpha…

Not at the moment although I can’t think of any reason why it couldn’t be done - I’m pretty sure that SimConnect offers full control over the various axes.

I’ll have a look at how much work it would be t add - no promises but we’ll see. Anyway I would have thought that the new MSFS sensitivity settings provide pretty much all the control over the axes that is needed - is this not the case?

I’m curious as there are other posts on avsim about using simvar to map control inputs to improve control and remove / reduce device to device variability.

Problem, no , not really. Curiosity more than anything.

Hi all.

Just got up and did some further testing.
I had the idea that the entries regarding the SIMVAR= variable might cause this.
So I went ahead and deleted all entries with SIMVAR= entries within the XML Alpha profile.

I then tested the Alpha yoke within the sim: Now the buttons and all switches work, but the switches only turn on momentarily. So for example, if I switch on the Battery it flips on and then flips right away back to off.

I am off to trying around a little more with it. Maybe some SIMVAR= variant is wrong or whatever and causes this.

Right now I think maybe the code of [E1ephant42]s app is ok or just needs some minor adjustments around the SIMVAR= variable? I am no programmer at all and I just do try and error and read a bit about Simconnect variables.
Maybe we should also use other SIMVAR= variants and see if they work.

I maybe try to add one SIMVAR= variant back after each other and see if it may only be one of those SIMVAR= variants causing this. Lets see :slight_smile:

Thanks, everyone.

Bye

Jan

Light switches like nav or beacon can be moves on the dash with the mouse and will stick for a moment and then go back to off if you have a switch bind on the Alpha yoke, or Bravo throttle that is countermanding it via simconnect. Saw that happen today. With both the Alpha and Bravo still sharing some switches in default that may cause issues.

There’s nothing fundamentally different in the two HC products switch wise, so I hope it is just something minor that is causing the problem on the Alpha.

Alla best and thanks all for working on this.

Hi all.

I did some more modifying of the Joystickmappings.xml file and got the following working:

  • Master ALT and BAT (two red switches on the left)
  • BCN, LAND, TAXI, NAV, STROBE - These toggle switches need to be in the correct position when launching the flight, as the events that are right now are all “toggle commands” I suggest them all to be in the down position when starting on a parking space and not on the runway. Otherwise the position of the switches might not match.
  • Magnetos and starter moves but may needs a delay to be added for the start position of the rotary switch.

What is NOT working:

BIGGEST PROBLEM:
When moving the condition or mixture leavers the sim CTD…

I think the FS_Tool app is great and maybe working fine. But for now it seems injecting Simconnect commands may cause a problem with the Flightsim.

I am not really very much more motivated to continue as it seems that there are core bugs that for an average user are impossible to overome. Even for programmers its hard.

Bye

Jan

If someone wants to try my modified Joystickmappings.xml file you can download it here.
You have to overwrite the stock FS_Tool Joysticmappings.xml file in the main folder of FS_TOOL.
Make sure you BACKUP the original file so you can revert back.
For me at this moment the sim always crashes when using prop and mixture leavers. I think it might be some conflict or something.
Maybe I will try out FSUIPC for assigning the Alpha buttongs and continue to use the FS_TOOL for the Bravo functions.

Here is the link:

Bye

Jan

Update: The sim also crashes without having FS_TOOL running…
Its some kind of bug or problem with the Alpha and Bravo that other users have reported aswell.
It might be due to the AFC bridge thing. I will install it again and see if it cures this CTD. I uninstalled it to be sure that I can test PURE FS Tool without this AFC bridge. Complicated and hard to 100% exactly track what is causing what…

UPDATE: Also with the AFC Bridge/LED Driver installed the sim crashes when moving the throttle/mixture/prop handles. It’s a know problem others have reported aswell.

It’s a nightmare trying to debug addon software when you can never be sure if it’s your code or the core engine that’s at fault :confused:

I 100% agree. Simconnect still very buggy.

I now have it working with paid FSUIPC and LUA scripts for the toggle buttons.
It’s all over in the FSUIPC forums if anyone wants to try, or can source some additional info there.
Many bugs still with Simconnect variables, for example Avionics Master etc.

FS_Tool is still very nice and good and once the Simconnect issues are worked out by Asobo, it might very well be a great and free alternative to FSUIPC… So BIG thanks for making this app.

Bye

Jan

Well, I flew the C Caravan and The Daher TBM for hours last night with both FS Tool and the Bridge/LED Driver installed and had no crashes.

What I would like though is a different assignment of the switches, as when the Alpha gets fixed all the nav lights, beacon etc are on that panel by default. I saw one YouTube vid o the Bravo throttle, where the guy had his set to anti ice, anti windscreen ice, pitot heat, cabin light, flashlight, yaw damper and parking brake, which I thought a more useful selection for a simple layout.