Just cannot connect online


Hi I am seriously considering deleting and uninstalling this game. It is absolute rubbish. NO MATTER WHAT this game just doesnt connect to online multiplayers servers, live weather or the marketplace. I also get low bandwith messages EVERY time I log in despite me having more than enough. Ive tried uninstalling and reinstalling, ive tried signing out and back in, ive tried port forwarding, ive tried using a VPN, ive tried resetting the modem, ive tried 45 to 50 different solutions on various forums. NOTHING works.

Has anybody got any ideas what else to try please? If not I will be deleting forever and going back to Xplane.

It’s a significant current issue affecting many users including me. There are a handful of related threads in the Bug Reports section. There are 2 things you can do:

  1. Vote for the threads / bug reports that are similar so they get attention.

  2. You can also try to start MSFS with the network disconnected, then connect the network and try again. otherwise, you just have to wait for Microsoft / Asobo to recognize the issue and fix it.

Rest assured it is most likely not your connection, but a broken logic in MSFS that I believe will be acknowledged and fixed. But I’ve been reporting the issues since last fall, so, you’ll need patience.

Also you can log out of your xbox/steam account and log back in before you start the game

Call Microsoft support! They will walk you through a solution!

I’ve been having the same issue as well…keeps disconnecting and saying I have a problem with my connection although there is no issue on my end. I was able to get to the store… I’ve only had the issue for the last 3 or 4 days though. Frustrating to say the least.

Issue started for me today. Can’t connect to the servers. Always nice when it happens on your weekend and destroys any flight time.

Same for me. Marketplace is forever greyed out and my avatar top right says I am offline. I have signed out, rebooted, signed back in with no issues and still it says I am offline.

I have also reset my Data options and toggled Online services on and off to no avail.

Very frustrating!


today i’m also affected. Happened never before. Did all the mentioned tricks, logging out, switching server, changing settings … last option would be a complete reinstall but with ~170GB i’m hesitant …

There seems to be a huge Xbox services outage this morning.

Actual the same for me. Simulator hangs repeated due to Loadup. in spare cases i can load the simulator, but then Server connection is directly lost.
Anyhow, don’t hesitate, better enjoy something else in your life for today and try again tomorrow. Should then work well again.
(Not the first time, that all this happens the day after a Service update…).

Hello makai.
I’ve had the same issue! I ended up going to Microsoft.com! Ask fo a phone call from Tech Support!

That worked. Got me up and running.