Just crashing on launch now

So I had some time to try out MSFS again, and it is just crashing on load now. See the “spinner” in the lower right then back to desktop no message. I haven’t changed anything since last launch. Tried rebooting, cleaning the few addons I have, etc. Any ideas?

This app is so disappointing sometimes…

Log Name: Application
Source: Application Error
Date: 3/5/2021 1:01:55 PM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic

Faulting application name: FlightSimulator.exe, version:, time stamp: 0x6038c351
Faulting module name: FlightSimulator.exe, version:, time stamp: 0x6038c351
Exception code: 0xc0000005
Fault offset: 0x0000000001b57ab0
Faulting process id: 0x366c
Faulting application start time: 0x01d711e9855ab6b6
Faulting application path: C:\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Faulting module path: C:\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Report Id: 04ea22f4-7736-436b-ae1f-76a41c7f0e02
Faulting package full name:
Faulting package-relative application ID:

Circular reference unfortunately, the worst kind since it points to nothing in particular.

Removed Mods
Restarted PC?
Log out of MS-Store and XBox Live Accounts, and Log Back In?
Checked for Windows OS Updates?
Checked for App Updates in MS-Store?
Have you overclocked any hardware recently, esp. CPU or Vid Card?

It’s a varied laundry list, but you’ll find there’s been a lot of things people have tried to resolve CTDs - we have dozens of threads on this.

Yeah, I did a lot of that with the various other CTDs… There is no way to get a detailed debug log I guess?

  • Removed all mods (not that I have many, try not to add them with the stability issues)
  • Restarted
  • Turn off all overclocking (did that a while back to rule that out)
  • etc.

I use this PC daily for work and run multiple VMs and it’s fine with that. Guess I can upgrade drivers next… I’ll try logging out of xbox I guess. MSFS2020 is either great or a disaster. Just don’t understand how something can work one day and the very next day just crash on launch.

It’s Software-as-a-Service even though you have a local client. Everything else has to be working on the local PC, your 'Net connection, the ISP, the pipe to XBox Live & Azure, your login authentications to MS-Store (for authorization of the app) and Xbox (to receive gaming services).

It’s not a self-contained program like FSX was.

sounds like this issue

Thanks for the tip. Sorry dumb question, how do I log out of xbox if I can’t fire up the flight app? I don’t have many xbox titles, mostly steam so not as familiar with it.

think within the XBox Co… App => Profile Page => ‘more’ => Logout

( I also logged in only one time in my life :joy: )

Thanks, no luck. Just crashes after the screen goes black. Should I try to do a repair for the install with Steam? I’m pretty much dead in the water, can it make it any worse?

If you have checked the other points from @CasualClick , in special check for updates in MS-Store, then only idea at this moment is the anti-virus protection. Which one you own ? and tried disabling ?

This is the MSFS support document.
Look in this and see if there may be something you haven’t tried.


but please not un-install the windows audio service :joy:


You should report that to Zendesk.
Not good to have misinformation out there!

1 Like

Thanks for the tips… If I remove -fastlaunch I can the intro videos but then a black screen and crash.

I did have some progress with the suggestion below, and do get the xbox login page in the game… I deleted all xbl_ticket entries. Game starts, i get the music, and xbox login window.
Unfortunately after clicking “Let’s Play” on the xbox login it crashes. I’m starting to think this is an online issue, just surprised it’s just me. Don’t know…


  • In the Windows Search Bar, type Credential Manager
  • Click Open
  • Select Windows Credentials
  • Search for Xbl_ticket
  • Click on the most recent ticket(s) to expand the menu
  • Select Remove

You will be asked to sign-in to Xbox Live the next time you launch the sim.

yes… they mentioned basicly all Audio Drivers for un-installing , and funniest the windows audio service as Third party. But I know what they mean… there are some issues with it, but of course “un-install” is not the solution.
Worst is, that the realy important applications which can realy cause trouble , are lost in that list.

1 Like

this is also kind of useless hint… in FAQ :wink:

this is now another issue as former… If you own 16GIG RAM I would say increase virtual memory, but you own 32GIG, or ?..

Have you already removed the CACHE ? ( RollingCache… CCC )

I’am not sure about this Credentials hint.

EDIT: and I forgot… in case of crash you should have an entry within the Event Log.
And don’t forget to make a test with disabled AV-protection… which one you have ? ESET makes much trouble .

Hey I fixed it! thanks for the help all! Just kicking myself now for doing the “verify” in Steam, as it’s downloading the whole thing again. Oh well.

Unfortunately, I started doing a shotgun approach and not sure what actually fixed it. But if it helps anyone else… I’m leaning toward the theory my rolling cache got corrupted on a previous CTD.

  • Installed the latest cumulative update for Windows 20H2
  • Deleted rolling cache file @MichaMMA suggestion
  • Updated Nvidia drivers to the latest
1 Like

yep… there is a information in changelog of 1.13… that the cache should be removed.

I just had the same probem too !
- System

|||- Provider

[ Name] Application Error

|||- EventID 1000

[ Qualifiers] 0

Version 0

Level 2

Task 100

Opcode 0

Keywords 0x80000000000000

|||- TimeCreated

[ SystemTime] 2021-03-06T10:57:58.7342387Z

EventRecordID 22787


|||- Execution

[ ProcessID] 0

[ ThreadID] 0

Channel Application



- EventData










C:\Program Files (x86)\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe



I was approaching to my destination airport, and all my FPS dropped until it crashed and sent me to desktop

1 Like

Hum…so, good news: now they show the error. Bad news: it means nothing :rofl:

I was facing a lot of CTD at load page when OC my GPU. Without OC, it runned perfect