KADW - Andrews - CTD Analysis by Community contributions

The CTD center seems to be between those two landmarks.

Its frustration that one cannot easily look to see zoomed in, what is at the center, because as soon as you look at it, you CTD.

I suspect Asobo can look in a debug mode, so there is hope.

Its a little like Schrödinger’s cat !!

1 Like

I tried looking in Google Maps satellite view. I don’t see anything of consequence.

Maybe it’s not drawn scenery in the strictest sense. Maybe some data doesn’t parse properly?

Yes this is just guesswork.

1 Like

Thanks –

I get EXACTLY the same as you when I CTD with this Andrews Area issue,

MODULE_NAME: ucrtbase

IMAGE_NAME:  ucrtbase.dll

STACK_COMMAND:  ~18s ; .ecxr ; kb


But I do not fully understand the implications of this analysis., even after watching this

It could be anything, really. Must not necessarily be a scenery object, it can be everything i guess. If we are lucky, they can fix it server-side and we dont have to wait for a update.

The CTDs occur when OFFLINE, so its not bad data coming from the servers.
Its something in the actual downloaded Update to SU6 ??

Here is a link from last November to a bug at a specific specific location causing a CTD. Nov 2020 - Specific Location CTD.

It is difficult to state that this is identical to the problem at Andrews. The thread may provide some helpful things to look at or to try.

It looks like there may be a Community Mod temporary solution, by making a scenery exclude Mod. ?

WE know the area that needs to be excluded now :sunglasses:

Anyone Scenery savvy devs up to the challenge, ?

Not seen @Laurinius about on the forum for some time

MSFS handle errors ? what a news !
if i have time this week (no promise), i will do a scenery exclusion for this area.

1 Like

Thank you @Nirgal2776 - I am sure a lot of us who fly in this area will appreciate that.

Out of interest, to anyone that does Scenery, can a Scenery Mod BGL file stay in it’s XML format, and still function, or does it have to be converted to a BGL. ?

For it to have any value in the sim it would need to be compiled into a bgl.

FWIW, I spent some time today trying to create a scenery fix that excludes everythng, including OSM autogenerated buildings, based off your findings for the likely location for the problematic scenery.

Every attempt I made (and I used both an exclusion rectangle and also a rectangle that excludes OSM buildings) failed to rectify the issue. That being said, others may have more success than I did.

This would have been the first time I would have created scenery that wasn’t solely an airport mod. After a couple of hours I decided it might be better to leave it to someone who may have more experience and is more likely to get it to work. Of course, if the issue cannot be solved by this method then all such attempts will fail in any event. Impossible for me to know which is more likely at this stage.

i don’t have much experience, just done one airport scenery ! so i don’t think to be succesfull as my plan was to do the exact thing you have done. did you try to flatten the area also ? (perhaps a very bad elevation point with a value at the limits can cause the crash (as it can be anything) ?
Or create an airport at the place of the ctd ?

Thats what i already suspect, it might not be something that is visually causing the bug, it could be something server-sided or deeper in the code, it could be anything, really.

1 Like

Hello there…
My settings are default. I have not touched any config settings. I have 2 market place items, the Junker and Asobo taildragger. Everything else is stock. I used a Cessna 172 for this flight.
I tried spawning at Andrews 3 times yesterday and experienced ctd’s in normal mode and safe mode. I then spawned at Reagan and flew over Andrews and did manage to land but suffered a ctd when leaving the runway. I did notice that the server ‘eastusa’ was not loaded.

I do not think the issue is “server side”, as it occurs in exactly the same manner, when MSFS is in OFFLINE mode. (and to make sure, the Network cable disconnected)

1 Like

That’s a little disappointing to hear .

Did you try “Exclude all” ?

and did you name the Mod to load late, ie name it like ZZ-KDAW-CTD-FIX, so the ZZ puts it late to load ?




What does that mean ?

Can confirm I was approaching Washington National ILS 01 from the north which loops around Washington over Andrew’s AFB. As soon as crossing the river it CTD’d. Airbus A20n.

At the time of the CTD I was at 5000’ descending to 2500’ to begin my final approach to ILS01 at Reagan.

No mods, no scenery, no add ons, default aircraft and livery.


Actually There’s a couple zones around the Great Lakes area like where a lot of ships and planes went missing Creating many Bermuda Triangle areas in the Lakes


There is supposed to be a hospital in this area. Perhaps create a building with a helipad on top and call it a day?