Kodiak Autopilot Issue

I’m having a serious issue with the autopilot. No matter what mode I’m in (attitude hold, climb, nav, descend, etc) whenever I enable the AP it immediately flips the plane 90 degrees to the right resulting in a super steep turn followed by a stall then death.

Here is exactly what happens: https://streamable.com/jm6qx9

All trims are centered and starting from straight and level. I notice after the AP banks the plane 90 degrees the plane also rotates the elevator trim tab fully down (pitch up).

Has this happened to anyone else? I tried it half a dozen time with the same result each time.

1 Like

Read this post

I’ve not had that happen to me as yet. ALT, VS, NAV, HDG, FLC have all worked for me so far.

in a prop plane you need to move the red knobs when climbing to 15,000 otherwise you will stall and crash

As you can tell, there are a few posts on similar issues.
Do you have an pilot assists on?
If so turn them off and try.

The Kodiak is a turboprop. From takeoff roll till landing the condition lever stays full forward. There is no need to lean the mixture at altitude.

1 Like
  1. this is a turbopop, the red knob stays full forward
  2. i was way below 15,000’
  3. thanks for trying to help though

everything on 100% real settings. I’m a pilot IRL and have a dozen other addon planes in my hangar that fly as expected. It’s just this Kodiak that does it (sometimes). Very odd indeed!

1 Like

Could it be a conflict with another addon?

possibly. though i use Addons Linker to keep things to a minimum and flight-specific.

That’s not it if it isn’t linked.
Spurious command from the controller?
That would override the A/P.

I had this happen with Carenado’s Seminole, repeatedly. It got to the point I quit flying it. It was very frustrating.

I ended up uninstalling all of the Carenado aircraft I have - four in all - after SU5. One by one, over the course of months, I’ve added them back as updates showed up in Content Manager.

Perhaps completely uninstalling and running a registry cleaner, then reinstalling from a “clean” download off the website might help? In my case with the Seminole I haven’t had the “right turn of death” since the reinstallation some weeks ago.

Maybe the same protocol will help you with the Kodiak. It’s worth a try; the Kodiak is a really great model. Good luck, and keep the blue side up! :slight_smile:


thanks. good to hear a story from another person that had what sounds like the exact same issue. ill try doing a full reinstall of the addon

1 Like

Same issue here but roll to the left :confused: