Kodiak CTD 9 out of 10 times


what are your Kodiak performance results using your own in-house Xbox?

I’m thinking of purchasing the Kodiak next week,

but I don’t want CTDs on my XSX…

1 Like

I really think you should get an Xbox!


I cleared my cache and it does not work. Still CTDs, 80%craches on my XSX. Not the very best moment to purchase:)

Can you let me know when the crash occurs (loading, clicking something in the cockpit), if it happens with or without the NXi and at which airport?

Also, if you load the plane in the hangar first, does it load Ok after?

I’m on a XBox Series X.

It was suggested mentioning something I’d posted in another thread here regarding the CTD issues. I’ve only had the Kodiak a day but here’s what I asked another user who was reporting crashing the majority of the time in the other thread:

“I’m curious if you’re running the stock G1000 or the beta G1000 NXi? I was not having any issues with the Kodiak until I decided to install the NXi this afternoon then I had a number of CTD when trying to load a flightplan with the Kodiak. I uninstalled the NXi and the Kodiak seems to be working again.”

I will also mention my other observation. Compared to all the other aircraft, stock and third party, flight plans with the Kodiak takes a very long time to load. The screen often goes black and almost appears to freeze but then eventually gets going again. None of the other aircraft I have cause the screen to go black when the flight plan starts to load and overall the loading is noticeably much faster.

I appreciate this second observation could simply be due to the higher level of complexity of the model with all the things that can be clicked and adjusted - the Kodiak has much more functionality in that regard than anything else I have. I also don’t consider it an issue as long as it doesn’t crash during the load and only mention it in case it’s not expected behaviour.


Thanks for posting that. Based on the data I have so far, it seems the Xbox X+NXi+Kodiak is the combination leading to crashes more often. That is odd because the NXi is actually a better performer than the default G1000 across the board.

We still can’t figure out if the problem is the Kodiak, NXi, Xbox or a combination of them, but it is starting to paint a picture and have communicated that to the people that need to know about it.


I know there’s some material you can gather in the thread titled “Xbox has a plane…the Kodiak”. I wish I could provide some feedback myself but after hearing about problems people have been having I haven’t bought it yet. I can at least do what I can though to help you out so we can get this sorted out.

1 Like

I had previously some CTD with other aircraft when having the NXi installed (A320 for example) and only since the recent updates did I reinstall and try it again. Once again having random CTD.

Will uninstall and test a bit this weekend.

At this point I don’t think the Kodak is the problem. Whatever that update was, really messed things up. I CTD regularly, no matter what I try to fly or where. The only issues I’ve found in the Kodak is the cabin temp doesn’t seem to change no matter what the ac is set at. Also the manual override engine inlet bypass switch does not function.

I had a chance to test the Kodiak on my Series S today and can confirm I was having CTD problems with the Kodiak when the NXi is installed on the S as well.

I payed better attention to the steps which got me to the CTD state on the S and it hindsight I firmly believe this applies to my experience with the XBX yesterday.

I initially tested the Kodiak on the S with the default G1000 to confirm it was working.

Similar to the X, I had not previously installed the G1000 NXi package on the S. After installing the NXi, I immediately created a flight plan with the Kodiak and flew it: i.e. no game/Xbox restart in between. Everything appeared to be working and I did a few more short flights this way.

I quit MSFS (I rarely use Quick Resume). When I loaded MSFS again, the Kodiak would CTD each time I tried to load a flight plan. I could create the plan, adjust the payload, etc, but after clicking Fly it would CTD when the loading bar along the bottom was about 80% across the screen.

Both airports in the flight plan were stock scenery (KBVS → KPAE). I was using Live time but preset weather of a “Few clouds”. The model I was flying was the standard 100 with Factory B7, cargo interior. I was setting the payload to 60% with the cargo shelf at 0 lbs, the pilot at 210 lbs, the co-pilot at 190 lbs and all the other weights evenly at 132 lbs.

If I recall correctly I was having CTD with other Kodiak models (tundra tires) and payloads yesterday on the X.

I removed the G1000 NXi and the Kodiak was working again with the same flight and loading. There was no quit/restart MSFS cycle prior to re-testing. It just worked again as soon as the NXi was removed.

My experience on the S today reflects my experience on the X yesterday. After doing these steps today, I’m sure I quit MSFS after installing the NXi and starting to have CTD issues on the X yesterday as well. On both consoles, removing the NXi restored the Kodiak to working condition in the sim.

I don’t know why quitting MSFS and then running it again would make a difference nor why it seems to affect the Kodiak but not other aircraft.


For what it’s worth Working Title has confirmed a CTD issue with the nxi that they said won’t be resolved until SU9; it’s not always, but can happen often to some people and certain combinations of hardware and aircraft setups (won’t necessarily be every G1000nxi plane and won’t necessarily happen every time nor to the same people) - it could be perhaps that just the combination here is affected, and apparently particularly pressing the flight plan button during flight is a particular problem with it at the moment.

I personally haven’t had it happen but it was reported in the MSFS Discord, and then WT did acknowledge it on their own Discord and that they know the issue, it just won’t be fixed until SU9 as it’s sim-related.

Again I’m not necessarily saying that’s what the issue is here, but worth noting I think.



The Kodiak works great on my PC apart from a couple of bugs:

  1. When taking off, the plane can want to veer sharply to the left and you really have to be on the ball to actually climb out on a runway heading (or you can look around and say “I meant that!” :blush:)

  2. While cruising at 15,000 feet, and exploring the fantastic cabin, I clicked on the little catflap window, which is about large enough to throw a beer bottle through. After about 1 second, the plane crashed “You have overstressed the airframe”. Bullcr&p. If you have a parachutist door in back that can be opened in flight, opening that catflap isn’t going to do anything. It’s not a pressurized aircraft.

#2 is a known issue of core MSFS. Asobo have said it is going to get fixed.

#1: This was adjusted with feedback from RL Kodiak pilots. There is some fine-tuning owed once you’re airborne, but we have been told we are very close.

Regarding the NXi bug, I had that information as well but did not want to share as I didn’t know if it was public. Still, I am gathering information about it as we still don’t know exactly the cause.


I haven’t bought your airplane, yet, but I want to know how impressed I’ve been with your handling of the situation. You’ve had to deal with a pretty difficult set of circumstances outside of your control and you’ve handled them with grace and patience, and that impresses me.

I know this has got to be an exceptionally frustrating place to be in as a developer — to not have access to the toolset you actually require to do your job the way you would want to be able to do it.

Hang in there and thank you.


So far when I delete the NXi I have not had any CTD with the Kodiak. With the NXi installed it’s hit and miss as to when I will get a CTD, seems to be one in every 3-4 starts. It’s either as the flight is loading or shortly after spawning.
The NXi seems to be conflicting with the original glass cockpit as it loads up.
I do prefer the look of the NXi, so hopefully the can sort it out.

1 Like

Interesting that more and more it seems like a conflict with the Nxi, doesn’t it. Hopefully it’ll be addressed, as the Nxi is a great mod and WT have done a great job of improving the functionality of the default G1000.


It seems that the Kodiak+NXi combo is explosive on Xbox, for many. I am getting increasing reports that the plane works fine without the NXi -which is a shame to lose.

If you fly without the NXi and experience CTDs, please let me know via PM or on our Discord server.


I can also confirm that is my experience on my Xbox X. With the Nxi mod now uninstalled, I haven’t had any CTDs today.

Whatever the problem is, it is quite strange to me. For the first day I had the Kodiak, I must have been lucky because I had several longish flights without issue (with the Nxi mod installed). Then a CTD that seemed resolved by restarting the console and changing the selected plane before switching back to the Kodiak. However…today was a complete nightmare with nothing but constant CTDs, mostly after hitting the ‘fly’ button and the rest not long after getting into the plane.

Hopefully the bug(s) can be found, because the Nxi mod is much superior and feature rich to the Asobo stock G1000.
Thanks for persevering.

Also, I would add that with the Nxi mod uninstalled, the sim does still stall a bit and and take longer to load flights with the Kodiak, notably temporarily freezing after hitting the ‘fly’ button. That’s not something I’ve seen with other planes.

What a pain in the backside. But, thankfully, to uninstall Nxi and say reinstall when wanting to fly something else isn’t particularly problematic given it’s a small download. It’s just an almighty faff. Hopefully it can be sorted soon.

1 Like

I also had a great flight today with NXi removed.

1 Like