Landmarks shifting up and down + Half of them not loading correctly (still not fixed in

same here! Terrain Detail set to 350, object lod 200 via the .cfg at a certain distance added objects that are not photogrammetry tend to bounce upward.

When I exit out of the flight, enter new one, do kinda short flight towards some objects like Devil’s Tower and Half Dome, they just refuse to load untilI get extremely close.

Increasing LOD of Terrain/Objects does not help with objects not loading after loading into flight.


I’m wondering if they know this happens and release anyway. Don’t know it happens and are just as surprised as us. Or ?? Lots of weird bugs in this release

List of bugged places so far that I’ve tested repeatedly:

Half Dome (doesn’t load until you get very close after you first load into flight)
Devil’s Tower (doesn’t load until you get very close after you first load into flight)
Chimney Rock (Shifts up and Down)
El Capitan (Shifts up and down)
Mount Rushmore (shifts up and down in the distance, barely noticable but it’s there, ok at close distance)

Bumping topic. Turns out setting lod <200 makes it progressively worse. The lower it is, the worse the issue.

1 Like

second that. Same here. Terrain detail 150.

1 Like

Shouldn’t this update have added Devil’s Tower? It is missing in my sim. Can someone else confirm?

Have you gone to the market place and purchased and installed the free World Update II: USA?

1 Like

Yes, I have.

Okay, make sure you clear your rolling and static caches just incase that is causing issues. If you still struggle to get anywhere file a bug report on Zendesk.

I have the Mount Rushmore sculpture, but not Devil’s Tower.

1 Like

This is actually sim issue. I have same problem. Unless I get very close to devil’s tower and half dome in yosemite, they don’t appear.

After I get close, they load in and stay there.


Awesome, thanks for the clarification. Please submit a bug report to Zendesk using the link above.

I did.

Also this:

This is just unacceptable.

1 Like

Ta, make sure you provide all of that info as well. Even if you simply add the above link to your existing BR.

I provided links and I’ve spent entire night doing testing on this, making detailed zendesk report.

I can reproduce this issue 100% of the times. Game is installed on HDD, but that should not cause this as this was not a problem, even with mods installed. Yes, I’ve tested clean game, no mods, deleted and refreshed rolling cache, etc.

This needs to be looked into ASAP.

Perfect thanks for filing the BRs, I will keep an eye on that thread tomorrow and I’ll pass it on if I see others reporting it.

I am doing testing once again to confirm it.

This is not the issue with my PC because again, game worked fine before this USA update.


and finally loaded when I was this close:

This also happens to Half Dome, Yosemite

1 Like

I have exactly the same issue, pops up only when flying right over it!

Ditto… I just ran the same test, and had the same result. Had a hole in the ground until I passed over the spot where the tower was supposed to be, and just as I went by, I suddenly saw a perfect Devil’s Tower.