Large FOV on Pimax casues occasional glitchy frames

I have this problem using the PimaxXR runtime but not the SteamVR runtime. AMD 5950X, RTX 4090, Windows 10.

1 Like

I will retry with SteamVR tonight. If confirmed I will pass it on to the PimaxXR developer. Thanks!

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

When using my Pimax 4K and have the large FOV the background will disapear. Only after switching to a medium or smal FOV I have a fluent screen again without glitches.
In Oktober the large FOV was still working fine, and due to work I could not update it until this Christmas. Which triggerd this response. It took me half a day to analyse the issue and switch to medium FOV.

If relevant, provide additional screenshots/video:

I don’t know how many times I will write this again…

I don’t use steamVR.
It is running by pimaxXR.
As you can see from the past videos, it was an environment that was operating without any problems before SU10.
And, up to now, there have been no troubles in other games.

If necessary, please use my video.

I’ve reconfirmed it occurs on both PimaxXR and SteamVR.

4 Likes

Do you have the same issue if you follow the OP’s steps to reproduce it?

Same problem here. 3090 /Pimax 8KX / Ryzen 5950

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

1 Like

I did quite a bit more testing. The intermittent nature of it makes it difficult to track, so I’m not 100% confident, but I did spend 2 hours simply testing for this glitch.

A few things became evident:

1). Performance did affect the likelihood of the glitched frames. Occurring much more frequently when frame rates were lower, but even with high FPS (higher than I would simply achieve in lower FOV or lower resolution).

2). It occurred in PimaxXR and SteamVR.

3?) The menus are also distorted with large FOV, such that buttons on the bottom become off screen as the FOV is changed. The state of the FOV upon start of game determines the menus.

4). I have been unable to ever see this occuring with Normal FOV.

2 Likes

I also confirmed that there is no improvement in the latest state.
In addition, along with load, it seems to be affected by altitude as well.
At high altitudes, it subsides somewhat, flashing about once every 20 seconds, and at altitudes below 300ft, it reaches a level that may be harmful to health.
Incredibly, no change at all.
It is very disturbing that there is still no announcement.
When will the next chance come?

This is not likely to be fixed as a hotfix, but rather as a part of a more comprehensive update, which is usually long-preceded by acknowledgement.

Best-case scenario: Asobo notes the problem before SU12 beta goes public, —> we will see an improvement in SU12 - either the beta or the release.

It’s not a fundamental change (like support for canted displays was). There’s likely an overflow error somewhere where they literally never expected to have such an FOV in use.

Real problem: Does Asobo have a Pimax HMD to test with?
That’s why they need so much information brought to the correct developers -otherwise they’ll assume all is well or that the report is a one-off event. They need to hear that this is affecting all user in all situations.

Large FOV functionality will be especially important when the Pimax 12K is available.

It also helps when they see how important this is to users, so encourage fellow Pimax users to vote up the post.

I’ll try to test this week, where I will only change the FOV setting and try to grab some video of the occurrence of the flickering.

1 Like

Thanks! I’ve tried to use my phone to catch the glitches but I seem to have terrible luck catching it when I’m recording on my phone vs. screen- the HMD runs at 37.5 or 45 FPS, while my display is 60hz, so the misposed frames get skipped or something when I try to record. I see them in the HMD but not in the recording (or it’s possibly due to compression or the recording speed - not sure)