Last update doesn't work - looping

I will try.
thanks
ciao

Windows computers bought at stores like Best Buy or whatever generally have Windows stashed on a hidden partition so you can burn your own install media should you ever need to reinstall. If you build from parts, folks can buy a new copy of Windows in a box that comes with a CD or USB drive. Unfortunately in both if those cases, the install media carries whatever version of Windows 10 was current at the time the USB drive or CD or hidden partition was created.

There’s been about 12 versions of install media and they don’t seem to build out into identical versions of Windows even with all the updates. In my case, I had 4-5 year old install media and was having problems updating my Nvidia drivers past 457.30 due to stuttering/snapshotting. I had to rebuild Windows after rolling back a 46x.xx Nvidia driver broke Windows but I did it with my original media and still was not able to update without stutters. I pulled down a fresh .iso and rebuilt and that fixed everything. The only difference I can point to is that I used the new media instead of my old. The other clue to differences was that the security and privacy menus in Windows had many more options and much more detail that I had not seen in the previous build. But I’m outside looking in. This was just my experience. I don’t know this would fix your issues but a few have said rebuilds or repairs using new media fixed their issues.

From your post, though, you are also running a fairly old version of Windows. Over the years, as programs get installed and removed, junk builds up in the registry, in temp files, etc. If Windows itself is fine, it’s possible something else is causing the problems. And it could even just be defective RAM. One person was having update looping turned out to be a bad DIMM. Your motherboard may have a built-in memory tester or you may need to download one. I know Linux live CDs generally have a memory tester included but that may also be an advanced topic. You may be able to find other clues or error messages in the Windows logs.

So a number of ways to explore this but it doesn’t sound like you are up to this level of troubleshooting and unfortunately all anyone can do is offer suggestions which may or may not have anything to do with your issue. Not really sure what to tell you on how to get past this. Your best bet may be to file a ticket and let MS/Asobo help work you through the process. It will take longer, but they could be your best resource for now.

Also turn off AV software (antivirus)

Well, I filled a ticket some months ago about a problem but I never received an answer. So to be honest I don’t trust Asobo very much. I know my pc is old and I’m sure you’re right about everything but I think I will uninstall MSFS for now and maybe a day I’ll try to install it again. Thanks. ciao

nothing changed. thanks anyway. I will uninstall MSFS and I’ll install it again a day in next future. ciao

I have seen so many threads with this problem. I had this problem a few times and I was always able to solve it with a simple solution. I do not know why it is still not known.

Just delete the file that keeps looping, do not delete any folders, just the specific looping file. Next time you run the install, it is likely that it will not loop and that the looping file will be installed without any issues. Even if you have to do that a few times (I had like 6 files that looped), each time the installer will quickly go through the files that have been installed already and it will start from the looping one. So you do not waste much time and also you do not have to download the same files over and over again, only the looping (corrupted) file. This solution is simple and it worked for me and a few other users that had this issue.

hi, thank you for your support, in the folder MSFSPackages/Official/OneStore I found the file pc-fs-base-bigfiles-0.1.145.fspatch.001 size 1Kb. The file fspatch.002 no because it’s the file is trying to download. I deleted this file fspatch.001 and restarted the update but without success. In this situation I think the best is to uninstall MSFS, hoping it would be the solution of the problem, otherwise I don’t know, maybe I’ll wait when I’ll be able to buy the new pc (if the graphic cards will be available again sooner or later). thanks. ciao

Download or decompress? In my case, looping happened always when the sim tried to decompress a file in which case it was already downloaded.

That is maybe the way to get a graphics card - by buying a system. It’s now a thing - buy a system, take the card, sell the other parts. Only almost a year since the new series hit.

in this moment the graphic card is the last of my thoughts. I uninstalled MSFS and installing it again (I have the physical version luckily) but I have to update the game now, 1 of 154 files about 81GB, the first file ok, the second is looping again. It means Microsoft is kindly saying me I cannot fly anymore.

Well, this was my fix. I selected all my content in Content Manager and clicked Delete. I restarted MSFS, and my non-default (purchased) aircraft showed as installed. I re-downloaded everything, and it ran smooth to completion. However, I notice one plane (M20R) showed up as installed, but it was unavailable in my hangar. I selected and deleted just that one in Content Manager, and reinstalled it. Everything is working again. Remember to restart MSFS after making Content Manager changes.

I have seen it multiple times now that installing from media and updating may add problems. Even with FS2020, when it first released, many found after a few updates that a fresh full download fixed various issues - one being the looping download. With a media install, you may have a very old starting version that includes the bugs that could lead to a looping download. Your call, but I’d instead go for the full download. They are using better compression now so at least it won’t take as long.

But there was a looping download issue early on. It may be built into the media you are installing from.

I submitted a request to support. We’ll see…

Go to
system settings > update & security > delivery optimization > advanced options
select the Absolute bandwidth and reboot PC.

also try > Download stuck on packages / Install loop & Decompressing issues

Would love to know how you solved this problem or what the support says… i got the exact same one…
“funny” that its even the same file… im also stuck at 4,27gb and nothing of the suggested solutions wants to work…

Hi,
I haven’t solved the problem yet, but I found I have problems downloading other files as well. Sometime it works, sometimes not. So I contacted my internet provider, it seems there’s something wrong but they don’t know yet, I’m waiting for an answer. ciao

No need to change these settings because I have absolute bandwith and I tried disabling IPV6 but I have the same problems. When I’ll have the chance I’ll try to connect my pc to internet with a different internet provider. I think it will be my last but one try because I have no other hints. The last try will be to format the pc but I can’t do that now (smart working, I need the pc)

SOLVED.
Today I’m updating the sim, I just downloaded 7,75 GB and it seems everything ok.
It wasn’t my problem, my pc is ok, my router is ok, my os is ok, my browser is ok, it was my internet provider problem, because after days they were working on this problem today it seems everything ok. I don’t know what it was wrong but the good news is I will fly again… I don’t know when because I have more than 70GB to download :smile: but sooner or later … do you think uninstalling the sim I lost all the over 200 of flights in my logbook or MSFS save them on the cloud or somewhere else? ciao

You might try logging out of xbox and back in. That has helped some I think.

Also traceroute types of network diagnostic commands might be something to check into. You can frequently locate network issues on your own even before ISP folks get to work. If you explore those commands while the network is fine you get a background to know when it isn’t.

Glad you got it going. Seems network issues can cause a number of problems with 2020. It might be worth MS/Asobo’s time to include some basic diagnostics that tell users what the heck is going on instead of leaving people hanging wondering why the sim don’t run.

The day I downloaded more than 20 GB was a good day :smile: because I thought everything would be ok and that’s why I wrote SOLVED, but the following day same problems of looping. “My” internet provider answered me everything is ok also if it isn’t. That’s life, I’ll choose a new internet provider soon. ciao :smile: