Light showing through Blender models

Hello,
Still very new to this and I have been having trouble with light going through my custom Blender models.
I have attached screenshots for reference. Also, I will quickly outline how I apply textures before I export. I presume I am doing this bit wrong:

  1. After model is done I click new material.
  2. Under Surface I click Base Color and select Image_Texture.
  3. I select the png I have made custom in Photoshop
  4. I usually turn Roughness up to 1.0
  5. Join all models together and export with Blender2MSFS
    In options for export I put “…/texture” in the Textures field.
    I click Generate/Append XML file
    Then I name the XML the same file name
    Then I click Generate GUID and that’s it. I do not select any other options.

I have never used the MSFS Material Params as the tutorials I had watched never really messed with them. I also have changed the shadow graphics in game and it does not fix the issue either.
Appreciate the help.



Hi

Is your model “watertight”?

Seems like lights bleeds through edges…

Also, please use msfs standard material in Blender, very easy to do and allow using PBR, your model Will benefit a lot from that

Some tutorial about pbr

Thanks for the information! It ended up that the normals were reversed. Someone in another forum mentioned it and it fixed my issues. Basically some of the models were inside out.

1 Like