Limited CPU/Main thread, what should I adjust or look for

I have a fairly good system
Z590 motherboard
I9-11900k cpu
64gb DDR4 3600 memory
EVGA RTX 3080 gpu
2TB 4.0 m.2 drive Samsung 980
2 other 2TB m.2 drives, Samsung 970.
For my setting I have some stuff at Ultra, others at high and other stuff off and if I check the FPS i get between 35-60fps but it is always showing that it is capped by the main thread. What settings can I change to reduce this cap?
Any help would be great.

This may or may not help you… But this method has helped me get out of “Limited by Main Thread”.

Is by going to my motherboard bios, and disable Hardware Virtualization Technology and/or VT-d. As soon as I disabled this in my BIOS (it was enabled by default) as well as disabled Hyper-V in Windows 10, I stopped getting Limited by Main Thread and it’s a lot more stable and I’m getting higher FPS at higher graphics settings.

Neo, What’s your CPU? Not all CPU has Virtualization feature.

1 Like
  1. Reduce the two detail sliders in the graphics settings (reduces CPU load by drawing less stuff)
  2. Try to avoid high-density areas like huge cities and airports
  3. Try to avoid planes with a ton of glass screens as steam gauges use way less CPU

Unless you play at 4K or above you’re probably going to be CPU limited still, however. Even at 4K you may well end up CPU limited, especially in airliners.

1 Like

I’m not sure you’ll get more FPS than you are getting, but you should be able to bump up the graphics settings to bring your GPU and CPU more into balance. So dial up your graphics settings until you start to become GPU limited, then ease back a little. That way you are maximising the available capacity of your GPU within what your CPU can support and vice versa. I’ve found that getting this balance provides the optimal outcome. YMMV of course.

My system is very similar (essentially the same other than i9 10900K instead of your 11900K). Nice rig by the way, This post has all my settings and some suggestions as to particularly CPU hungry options (e.g. AI traffic, generic aircraft models and multiplayer). I get between 35 and 55 FPS mostly but cap the FPS at 40 in nVidia Control Panel - I find this makes for a very smooth experience.

What resolution are you using?

Here it is:

1 Like

Guys I had this problem where my CPU load was not maxing out. I hit reset to default in Graphics settings and boom, afterwards max performance. There is/was a bug in those settings which clears when you reset. Downside is you have to tweak them all over again.

1 Like

The FPS counter shows the framerate time in the GPU (eg 12ms) and in the mainthread (CPU), and this is very useful. Watch the frame times as you adjust settings; it’s easier to see improvements than the color bars.

I discovered that Vsync makes my mainthread work very hard, so I turn that off. I turn down Object level of detail and Terrain level of detail to the LOWEST setting. Mainthread starvation is because the sim is trying to handing too many objects with too much detail. GPU starvation is because the card has too much to draw. I also turn shadows off for Contact and Terrain (GPU issue). Everything else is on Ultra and my FPS are 40-50 consistently. I have the 1080Ti with 32GB of RAM.

Also, I have a 4k monitor, and although I can run the sim in 4k with acceptable FPS, I set my resolution to 1080P (half my native resolution). My mainthread gave a huge sigh of relief when I did this. :slight_smile:

I hope this helps.

1 Like

I will try these different items listed.
I think I will start with the reset and start adjusting items to see how it goes.
I forgot monitor info.
I have a 3440x1440 144hz monitor.

The settings in the traffic section affects the CPU so turn those down.

The 3080 is for 4k. Are you running at 4k?

If not you have a problem with MSFS. You can try up the rendering scale (and all settings but the LODs) to put more load on the GPU or cap the framerate to 30.

The 11900k + 3080 with Ultra settings at 4k should give a good balance.