Link to latest SDK

Downloads the full 1.7GB here without problems.

Gets to 3% every time and then dies. Ah well.

I have checked the version on my second maschine and it’s definately not working on both maschines no matter what. Even the marketplace in the main menu is inactive and with or without dev mode it’s getting CDTs. It directly updates in the background and starts up with the new version. The is a huge bug, maybe because of my German windows version. Did it as for updates on your side?

The sdk update worked fine.

Through the in game sdk download I just get 10 again - through the link above gets to 0.1gb then fails every time…

Do you have the link in the help menu of MSFS or did you use this one?
https://pf-cdn-content-prod.azureedge.net/pf-content-live/2fb7c/etc/Sdk/MSFS_SDK_Installer_0.11.0.0.msi?sv=2019-02-02&sr=b&sig=77cs1mPY5tnCwahY6gNldgxrDdU2F%2B9oJors5Vu1Ogw%3D&se=2021-03-16T15%3A14%3A58Z&sp=r

When I clicked the link in my sim, this was the address that was opened in my browser.
Started the download, and copied the address in here. So this is the official link.

Yes but what VigtetunD21 is saying sounds like he is using the old link to version 10 so he used the old help download link in msfs.

When you startet MSFS at the moment of your update, did you also just get the new version shown in the left top window corner and no messages like in the version updates before?

Yes, new version number.

I used the link marked 11 above AND the link in devmode screen AFTER updating the game…
The 11 link dies after a few seconds
The in game link downloaded 10.

image

The link above worked for me but I don’t have a link in the help menu in msfs any more. I did’t saw the normal update information when I started MSFS this morning. It just showed suddenly the version 1.14…no message no nothing and after that nothing worked as before. After ready to fly CDT during the following load procedure. it looks like I don’t have a real update on my machine. I did already reinstall it but no change so far. Now I’m restoring my OneStore folder of my latest backup. After that I hope I’ll get something different out of it.

Now it’s showing 0.10.0.0 for me too… :frowning:

I can provide a Dropbox link if you want the latest version?

At least I was able to reconnect to the server (top right corner) which was displaying [automatic] with a connection circle turning all the time. I disconnected everything through the options menu (Bing, traffic, online, …)…shutdown…restart and connecting again peace by peace and when I enabled the multiplayer option, it check me into the Europe West server again and my marketplace and my help menu were back again. These two where all the time missing. No i’ts updating my backp files…so need to wait until the 28,66 GB are downloaded and installed again. That’s it for today just work no progress…

i’d be grateful! happy to receive info via PM if you prefer

many thanks

Same here, I get the SDK V10 if I download from MSFS Dev Mode.

I was able to download v11 from within the SIM when the UK& Ireland update came out, so I have that version installed. But after last weeks patch, the link takes me to V10. Its not a problem for me as I already have V11, but looks like they have stopped deploying it and reverted to the older V10?

Yes, it seems like it… I’m guessing a new version is scheduled to launch in a few days.

Version 11 seems to be back again tonight. I check this morning (UTC) and it was still 10, but checked now and 11 is back.

It is back - there was a small blip but it is now correct and 11 will download as expected