Loading a saved flight plan - A tip I did not know!

@ WeaklyJester962


can you be kind read again my post and answer to it? I understand how Garmin works, also from real life but want really answer to my question. Thank you very much…

LOL dont have real answers that just where you start. You know toward the bottom sides of the G1000 there are buttons that will bring up a screen that selects destination and all the other goodies. Its in there.

I usually fly VFR using the autopilot to change headings / speed / alt manually when needed or instructed to do by ATC. I have never used the AP and let it do landings automatically, I always land manually.

No problem,

don’t bother then. I can understand you can’t help me with issue that isn’t simply implemented, correct? :wink:

Its something that I havent really used. Ive just seen the screens are there. It should work but its gonna be up to you to figure it out. Or maybe later I’ll mess with it myself and see if I can get it to work. If I figure it out I’ll be sure to update the thread. With regards to the ATC I know you can cancel the FPL in flight, and then call back at a later part of the flight and ask to reload the FPL. I dont see any reason it wouldnt let you execute the changes you make in the G1000.

Again if I get the time I’ll play with it I’ll let you know.

You can try that easy.

Prepare flight, save FPL to file. Start flight. delete flight plan inside Garmin. Try load it from saved FPL file. Happy play…

Seems the same thing happens on Bush trips that have GPS aircraft, the flight plans don’t load after quitting and continuing on the activity.

I dont think you can load the FPL in flight from disc, I think you have to use the GPS to create a new FPL in game.

@ WeaklyJester962

eeeeehm ok,

I just only ask again if you really read about posts which we now waste time:

Correct, you can’t simply load a .pln while flying in MSFS. Afaik you could so so in FSX/P3D though. Asobo simply needs to implement that function again. :wink:

Totally OT, but you can actually load a plane while in flight. It only takes 4 or 5 more clicks than it used to in FSX/P3D but you can do it easily:

To go even more OT: you can also transport your plane to another airport/location using the appropriate option in that same dev mode menu. Again, no need to go all the way back for the menu for this!


Sorry, you are correct Sir I missed the ‘Load the FP’ part of your post my bad.


Didnt know about the load change plane thanks for that .
Havent played with the dev menu to date except to see what FPS I was getting.

LOL I just realized, this is one of the few threads where everyone isnt tearing each other apart.


I really miss not having a map that you could move your plane icon to wherever you wanted inflight, set speed, heading and altitude and spawn to that point. Was perfect for practicing landings! I also miss slew mode where you could do exactly the same thing - correct me if I am wrong but slew mode on MSFS is only a camera control or does it work - I haven’t tried it yet - had bigger issues to sort out.

Hit y in game will put you in slew mode, then you can drag your plane in the vfr map to where you want it. Then hit Y again and you’ll be back in regular flight. That one has worked the couple of times Ive used it.

1 Like

Just to be sure you know that : when you press escape, there you can load a flight plan. .pln are masked but as usual in windows, you can put a * in the filename input of the open file window and this will enable all files and there you can select a .pln file (generated from whatever source you want :wink: ). It’s useful when you landed and want to go on for the next flight straight away without getting back to main menu.

I have never tested it but as it’s a flight plan, maybe you can load it while in flight? (I’d suggest putting the AP on basic HDG mode though).
Now I don’t know how ATC and the rest will react to this but somehow it’s like playing with the FMS or GPS in my opinion…

1 Like

Actually that worked for me, but then another problem comes up: The load/save button in the ESC menu disappears, so you are not able to save the flight again later. So this solution is not really useful, if you want to save the flight again later

Strange. Not having a problem with it here…

So you mean when loading a .pln file during flight, the load/save button does not disappear in your case?

Well never really tried in flight (maybe did that once). But I made many consecutive legs (loading pln, flying landing, loading another one and off again, etc) without any issue. And when I load a flight plan, I’m still seeing the button and able to load again if needed (I did it already as I changed my FP)

1 Like

Ok, thanks. I could solve the problem now with saving the flight again while still in the esc menu after loading the .pln file. There the button is still there and also does so afterwards when continuing the flight