Loading Object from BGL Failed - Objects Not Showing [ SDK 0.12 ]

Hi All,

SDK Version 0.12
All updates applied.

My custom objects are no longer showing in the Scenery Editor, This is the first time I’ve been editing since the WU and SDK update. Previously all the projects loaded.

I’ve noticed in the console that when loading the scene in the editor, this information is displayed:

The GUID is the same as the Object that’s missing from the object list / shown as ‘unknown’

This is looking like it needs to be raised as a bug, I’ve spent most of today trying different workarounds and nothing seems to work.

I tried the SimpleScenery example just to be sure it’s not a model export problem, and the ‘Load from BGL failed’ message is also presented with the cube shown as ‘unknown’

Can others please confirm the console message?

And can anyone confirm they don’t have the same issue?

1 Like

Yes I see the same issue.

I used an empty project,. put my model in modelLib\texturebox and my texture in modelLib\texture, started the sim, went to the place and started the flight. Then I opened SDK Project Open… my project and issued Build. I checked Console, issued Build again. It sais zero errors, but the BGL load failure repeated. Then I opened Tools/Scenery editor, load assets, menu Objects did NOT show my textured cube. I DID wait… And I am sure it worked before.

It is complaining about the location, in your case 53.56, -0.02 in GB. I see that also, in my case a location corresponding exactly with the location I placed in my object in objects.xml. This latitude/longitude information is not from BGL, boundary or geometric standard items in my BGL, The only thing my BGL it contains is a textured Blender scenery cube with relative coordinates.

So I can add here: the reported location is in objects.xml and not in the BGL. Something else went wrong pasinfg the BGL and MS specifies the coordinates of the instance. Could the Blender/MSFS tool generate an invalid Json in the glTF-part ? The new update of MSFS expects new sections in the Json ? In that case the Python addon in Blender should be refurbished.

The scenery editor shows “unknown” for my object. Could there be some change in the identification method used ? The GUID in the placements (objects.xml) corresponds with the GUID that is in the XML that comes with my glTF. On Project Build, MSFS will merge the glTF, the BIN and the XML in a single BGL file. Blender generates that GUID, it will be set in objects.xml when the object is placed. What if MSFS cannot read the XML-part in the BGL file ? It cannot read our GUID’s anymore and designates all project Modellib objects as unknown ?

Hi Bro,
Thanks for your help!
I covered off the Blender Export by testing with the SimpleScenery example and following the SDK documentation for it in case a new step has been added. There were no new steps and the result was the same, the scenery objects were flagged as unknown (apart from the OEM object from Asobo) and the other asset was missing from the Scenery tab when searching. Looks like Blender is off the hook if the SDK samples don’t work either, I don’t see how custom stuff can. I did another one too with just the standard blender cube with no UV texture, same result.

I noticed too if I remove the texture, no success.

Maybe there is an update in the SDK version ? I’m downloading it now. Get a new SimpleScenery

Thanks Bro,
I encountered the issue in the scenery editor before updating the SDK to 0.12 (didn’t notice the new update flag). I thought that was why there was a problem, because I compiled with the wrong SDK. After updating I tried other projects that I didn’t try to compile after the update and got the same problem. Seems to be an issue with the asset not being added to the ‘whatever manages the objects’ bit of MSFS’ I guess.
One existing project did load correctly and re-compile, but the package was still in the community folder. When I removed it, restarted the sim, it had the BGL problem. When I put it back and re-started the sim, it still had the BGL problem.

Capture5

Did you test the barebone simplescenery project ? I’ve looked at the files, but they are all on the old date, except (all) the project files. These are dated 13-apr (yesterday)

Starting MSFS now… see what it does (don’t see any differences in project xml actually (?) or am I looking wrong…)

found SimpleScenery broken :face_with_raised_eyebrow:

MS can’t read its own Samples anymore (?)

I am doing the same steps since months ago and had no problems at all, until yesterday. My problem, is simple, the model I’m working on, PVM-22 - doesn’t appear in the objects list.
I removed the SDK 0.12 and put back O.8 and didn’t work either, so I assume, there is a change on the FS core for sure or better say, a BUG, since MS has not specified a change on the process of making models.

1 Like

Yes just the SimleScenery project bro,
I also noticed I can’t install the SDK to my D drive where my MicrosoftFlightSimulator is installed and that’s where I installed it previously. This time there was no choice, it was installed to c:/
I copied the MSFS SDK directory back to D and changed the paths and rebooted. But that too made no difference.

Yep! even the sample scenery doesn’t works… Huston…we have a problem… :innocent:

1 Like

Not here to give any solution… but I can confirm the same problems :

  • Unknown objects
  • modellibs files not visible in the library
  • sampleprojects do no work as well…
1 Like

You’re correct.
Something isn’t correct, location usually just makes a duplicate object.

And restarting the SIM after each change or placing stuff into the community folders are not acceptable solutions to me. Most of the stuff I do are exporting from blender/open/build/load.
I can’t imagine restarting the SIM each 5 mn

Well, the only way, to make my objects, scenery parts , whatever appear again, is to load the project - start a “blind” build (because after the build trying to load the bgl doesn’t show anything or some unknowns depending on project) - then quit the MSFS - copy the created package into the community folder - start MSFS - go into scenery - load project and then you could load the before build state and add more objects or whatever …
But that is crazy, to go through all those steps - before my workflow was fast - i was able to have an created object in the scene, make changes in Blender, export, copy over to the project subfolder and watch in seconds my object change and showing, if what i did worked out or not … this is crazy now and is counter-productive in any way …

Probably this new MarketplaceData stuff is having some influence …

Thanks for confirming.
Not our problem to to resolve mate. We’re all confirming we didn’t do anything wrong.
Let’s build up awesome custom assets in our 3D packages until we can add them to the sim again

Hi! I’ve encountered the same issue. SDK 0.12, MSFS is up to date.
The scenery project work fine on the first load after MSFS just have been started.

If i for example export a new model and need to reload the project this happens:
I don’t see the the file names in the scenery editor any more. All is shown as Unknown.
I can’t search for my custom files in the Object list.
I get the following error in my log:

image

Doing that all day for me. Had a new scenery release planned for Friday. Not happening now. Several coffee’s down the drain. Suggest focusing on modelling for a while whilst things get sorted.

1 Like

Bravo India November Golftrot Oscar

You found something ? I’ve scanned some things, but found no error in GUID in xml and BGL…

Looks like an old issue. I dont expect it to be fixed… Seems were have to find the solution ourself.

The linked topic looks different first but scrolling down you can see ppl had the same problems before already. :frowning: