Loadingscreen forever

First time i encounter this.
For about 10 Minutes now all i see is the loading screen when i start the game.
Did several tries. Im not going to uninstall and reinstall for sure.

All my pation for this sim is completely gone. Bugs, Bugs and more Bugs. Can’t tell how disappointed i am

Passion. Sorry you’re having such a terrible experience. I truly am.

Hello. I would send a Zendesk report at https://flightsimulator.zendesk.com/hc/en-us . In addition, there will be a patch on August 27th (or 8th) which will fix a lot of the installation issues. If a fix hasn’t arrived by then, I would recommend re-installing or searching throughout the web to see if someone has found a solution for your specific problem.

You do not mention what screen you get stuck at.
Have you looked at these KB articles to see if something fits your problem?

Hope it helps,

Yes, tried that already. Never had this problem before. First time (now for 1 HOUR of tries and fails)
I’ve reported so many things to zendesk (through my alpha time) with not salvation that i doubt zendesk is doing anything. So im not reporting anymore. Im no more tester, im a customer now and i expect a purchased software to work without any exuses.

@NoteBeule338 Which version of Windows 10 are you on?

The reason I am asking is that I am on Windows 10 1909. I have been running MSFS on this for 5 days with no issue, but today, game is stuck at the TBM screen with a whirling circle instead of the blue bar which never appears.

My troubleshooting suggests we should be running Windows 10 2004. Unfortunately I have tried for the last 3 hours to get update 2004 on my system without any joy so unable to say yet if applying update 2004 fixes the issue.

Only a guess but i almost would bet my toe that this issues comes from a problem with digital ownership.
It reminds me on my first start. Same thing. TBM all the time. Than i went to my windows store and started the digital ownership manually. And tada it worked.

But now, i can’t click on start a thousend times without a reaction. The store seems buggy. I also can’t do any updates nor start anything

You still didn’t say which version of Windows it was. After three attempts to install 2004, I found that my sim actually loads now. Since I did apply one other update ok, my suggestion to you is check your Windows updates.

1 Like

Sorry mac for this late replay, i fight my system for hours. Don’t know what my previous version was, but i did a complete update (so mine is 2004 too now)

Maybe it has to do with the version. But what i figured out, was that my windows store was broke. So i had to fix that, crashed my sytsme completely, did a couple of sytem rebulds, and now im praying. Installing the game again…5%

Version 2004 seems to do the trick. You should add a special toppic for that. THX