LOC and G/S Not working -

After version no ILS (LOC and G/S Not working) even after configuring the Flight Computer.

There would’ve been a hundred topics on this already if true. Be more specific about which plane and airport please.

1 Like

If you’re a Navigraph subscriber, use Navdata Center to remove and re-install.

1 Like

Thanks for the help, but I’m not a Navigraph subscriber and I don’t use Any 3d party software.

Any Airport, tested with the Boeing 747, with all my favorite airports. That’s why I didn’t be more specific. But now that I’m being specific, please I expect you can help.

Please modify the title of the thread to be more specific

I’m not sure if you can be any more specific on this topic, but I will try.
I’m experiencing the same problem and I’m also on v1.23.12.0.

Tuning in on any Localizer, VOR, DME, etc. won’t show up neither the Localizer path nor the glideslope in the instruments.
I’ve checked this with different airplanes using different instruments and it’s always the same.

I have also added a screenshot approaching EDDF runway 25C with a Cessna 152. NAV1 frequency is set to 111.55 which is the localizer frequency of 25C. As you can see I’m not aligned with the runway in any way and I’m way too high for the approach (4 white PAPI lights). Anyway the instrument is not responding in any way.

All community plugins are disabled and I’m on stock MSFS v1.23.12.0


Will a “more specific” title make any difference? Have you experienced the same issue? This forum is for users who want to get help by other users based in their own experience. Otherwise we were able to self helped us. Everything is about the new version, before this update no issues existed.

I can’t see how a long tittle will help to describe a single issue.

ILS(LOC and G/S Not working) In Boeing 747, all airports in Tokio, New York JFK, La Guardia, Seattle (All Airports)…

It helps people who have the same problem find this thread and any help or solutions.

Just to make sure that your fs-base-nav package from MSFS is enabled please have a look at your Content.xml file. Depending on your installation (Steam / MS Store) it is located in different locations:

MSFS Steam version → “C:\Users\USERNAME\AppData\Roaming\Microsoft Flight Simulator\Content.xml”
MSFS Microsoft Store version → “C:\Users\USERNAME\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\Content.xml”

Search the entry for the fs-base-nav package and make sure “active” is set to “true”. If that’s not the case, set it to “true” and try again.

My issue was related to disabling the fs-base-nav package because I am using the AIRAC cycles from Navigraph and forgot to re-enable the fs-base-nav after disabling all community plugins.

Although you said you are not using Navigraph or any othr 3rd party software, please make sure the fs-base-nav entry in the Content.xml file is correct.

1 Like

I have the exact same problem since the recent upgrade. I’m on Xbox and it doesn’t matter what stock aircraft I use or what stock airport I land in I’m not getting the magenta diamonds on the ILS system. Please note that the plane will land itself on the ILS, I just can’t see the diamonds.

I’ve landed 1000s of times with these aircrafts and airports and they have always worked. This isn’t just affecting one person.

Are you using the NXI mod? Did you update it?

Nope, this is on Xbox and I’m using all the standard “stock” aircraft

So I found the issue, when creating flight plans and detailing ILS and Stars etc it used to program your FMC with the ILS freq and course however since the update this is not happening. The flight plan and the legs button show the correct approach and in RadNav it shows the ILS name but no frequency.

I suspect the G1000 is the same as that ILS failed for me too when entering an approach in the PROC page. It’s like the frequencies are all incorrect for the runways. I had to grab the correct freq from the internet before the plane could land in ILS

One thing to double-check is if you are a Navigraph user, please remove and reinstall your NavData using NavCenter. Optionally, you may also want to delete Content.xml, then reinstall Navigraph, again using NavCenter utility.

Incorrect frequencies are usually an airport file/design problem related to the runway information. We see this all the time in third party airports (freeware and Payware). The FMS, whatever it may be, if autotune is enabled in assistance, is grabbing whatever frequency that approach is coded with. It may not correspond to the actual ILS antenna information. If it’s stock, please report by individual airport in a separate thread. If third party, please report to the maker.

As I said in my original thread this is an Xbox, meaning things like navigraph are not compatible. I have no addons at all, and no way to edit files like you do on a PC.

Everything is out of the box as delivered by Osobo so this new error is 100% down to them. It worked before the patch on 28th Feb.

Anyway I’ll just remember to grab the codes before I fly as a work around until they fix it.

1 Like

Thank you so much for your help, My value in: active was already in “true”. But the info you provided is gratefully appreciated.

After completely deleting the rolling cache in DATA menu fixed this in some airports, but using High Altitude Airways.

I have to remember, every time a mandatory update is applied, the first I have to do is to Update all old World Updates, and second, delete the Rolling Cache. The pink or fuxia diamonds appeared again.

Still World Map Flight planning routes are very weird.

World Map Flight Planning is still buggy as hell, but that’s a totally different story :wink:


Now, when LOC and G/S are available in some airports, G/S is weird, I couldn’t make a successful autoland, Aircraft suddenly droops to the ground. This never happened before the update.
Also I had a CTD after a crash due to the G/S imprecision.

I only hope this could be fixed soon.