Lock to Cockpit Control to prevent zoom

Don’t be a wuss…lol just kidding…here’s the solution…for zooming with the mouse, bind zoom = mouse wheel AND mouse wheel button…meaning only zoom when mouse wheel is pressed in, and turned.

2 Likes

I think that some spatial selection mechanism should help. With that I mean some way to select the instrument by navigating through the cockpit instruments with a joystick hat or gamepad d-pad, selecting an instrument and then using the same d-pad or hat to perform actions on the instrument, such as flipping a switch or adjusting external/internal knobs. Perhaps a quick select mode could be implemented where the mouse or centre of the screen could be used to highlight what is being hovered over for immediate selection and manipulation. Once the selection button is pulsed and the item is selected, focus should be retained regardless of mouse or head position until selection is toggled again. This would be more useable than positioning the mouse cursor precisely over things, and could help make many airplane systems accessible from a HOTAS or gamepad.

I second the @majorhindsight9 's idea. It works quite nicely since I always use instrument adjusting more often than zooming, especially that moderate zooming can be easily done with TrackIR.

1 Like

This is where Logitech flight panels are really good. Saves you mucking about with the mouse control when using track IR.

That would be the ideal for me… a priority purchase, if she lets me…

1 Like

Maybe this does a little help:

I would hang fire. They are hard to get hold of at the moment and although they work with the sim, there are still issues. A good purchase to start using in 6= months time I would suggest

1 Like

That’s probably the amount of time I need to justify and apply the right level of… persuasion… if you see what I mean

1 Like

Hi,

do you experience the struggle to turn the knobs or press the buttons in the cockpit while you manually fly the aircraft and the cockpit is moving in front of the mouse?

Like, you want to set a heading in the A/P but the cockpit is moving so sometimes you adjust the altitutde on the knob but sometimes you zoom in, because the cursor went off the knob and then the mouse wheel acts as zoom?

I propose something like “cursor snap”. This could be turned off/on also with sensitivity settings.

Once you hover above a knob, the cursor would stay there until you move the mouse more. Small movement of the mouse will not move the cursor.

This should work on all knobs and buttuns in the cockpit.

+1 here if you like this suggestion.

1 Like

I only have issues like this when looking through the default cockpit camera, i guess it’s a very oblique angle to the altimeter nob of the airbus in particular and because of that the “hitbox” is smaller however when i directly look at switches and nobs there is no problem. I proposed a center screen dot while in freelook mode so i can now what i can use and look at something on the spot by just moving the mouse and not having to click anything else. It didn’t click at all with the community, it just got buried.

Another idea how to solve this - assign a key/middle mouse button to “lock” the focus on the knob. This way, after I press the lock, I could turn the knob and the mouse will remain focused on the knob and would not move away until I again “unlock” the knob.

The lock would act as “hold the knob” :slightly_smiling_face:

1 Like

Just in case people aren’t aware, multiple mouse button combinations are now supported.

For zoom I use right mouse button held whilst mouse wheel is scrolled up or down.

For look around I simply use right mouse button held.

Hope it helps!

I would actually like to click and scroll on a knob. As long as my mouse button is clicked it remains altering that knob, no matter where my mouse is.

The suggestion above doesn’t help with camera shaking?

Yeah currently you can’t ‘lock’ onto a knob. It has been suggested since Alpha times though…

Solution:

  • Bind Mid-Click + Mouse Wheel Up for “Unzoom Cockipit View”.

  • Bind Mid-Click + Mouse Wheel Down for “Zoom Cockipit View”.

  • Bind Mid-Click + Mouse Wheel Down for “Toggle Cockpit View Freelook (HOLD)”

This way the 2 bindings won’t interfere with each other and you’ll still be able to move around the view.

It should look like this:

1 Like

I tried this, but the view get stuck and i can’t move it, i can only zoom.
This may be because the commands are interfering with each other.

Look at my previous post for the solution.

OMG You’re the best.

1 Like

No problem mate, this is something that Asobo should fix in the first place, The zoom should work in conjunction with Freelook Hold mode

Actually I found a solution to this quite a while ago. It never worked before but this was fixed back in around January/February.

I rebound my zoom to require my right mouse button to also be pressed whilst scrolling for zooming. Just change the keybinds…

Now I never have an accidental zoom.

Locking onto a radio control now really isn’t required. What WOULD help, is for the mouse cursor to follow bumps etc.

1 Like

And just to point out SU4 broke this and it’s been stuffed ever since…

Actually what happens is that it prevents you from panning around using the right mouse button only. ZD tickets for a few months now haven’t fixed it.