Logbook broken for people?

Not recording flights sometimes or landings.

End when I turn off engine and battery and the logbook comes up at the end great but then next time I play it is not there and hours of previous flight gone…

Was not like this on SIM 8…

1 Like

Just seems now that flying is a gamble cos when your flights are not being logged then what is the point?

These flights and hours go towards our achievements on the sim.

I saw the patch notes and nothing on there mentioned logbook fix…

It will log some flights but some they don’t…

Hey @xjay12347406. I moved your post to the #self-service:basic-gameplay-help category and added the “logbook” tag to help with searchability.

1 Like

Do you have connections to MSFS people developers of the software - this is an urgent issue…

This may seem like an obvious question, but are you fully quitting the sim and relaunching it when ending/starting new flying sessions?

You know, pressing Xbox home, selecting FS2020, pressing menu and choosing Quit, rather than using “Quick Resume”?

I’ve found the only times I’ve had issues with the logbook failing to record my flights is when I’ve used Quick Resume.

I quit the simulation fully.

Not understanding - are you saying I should be using quick resume instead?

Cos I quit fully sometimes it does save other times it doesn’t save the flight I did.

Shouldn’t be pot luck however.

Are you having issues with logbook not recording all flights?

No, not at all. However I am on PC. Since I don’t have an Xbox there is no way for me to relate to the specific steps that must be completed to record a flight.

There are quite a few posts here in the forum addressing logbook issues. Please use “search” to find what other people are saying about this.

If you believe there is a legitimate issue with your installation, first check Known Issues here. If that doesn’t help, feel free to file a bug report via Zendesk.

Good luck, my friend.

Needle in a haystack - of all the issues - they won’t listen to me :frowning:

I just think they should revamp the logbook an once you land - turn off engine and battery and logbook logo come up @ the end you are giving the option:

DO YOU WANT TO SAVE FLIGHT DATA RECORD FOR THIS FLIGHT?

Something like that - cos atm the logbook saving the hours automatically is suspect.

Definitely not.

I’m saying you should use Quit, which you’ve stated you are doing.

Since that is the case, I don’t know what else you can really do.

I just applied the SU9 patch and its wiped out all logs from the 30th April to today, todays flights logged ok though.

I have been flying every day but log book shows last flight was 20seconds 4 days ago😅

Same thing is happening to me. Nothing stays in logbook after May 5th for me. All entries made are gone next time I load the sim. I did earn an achievement yesterday that has stayed.

After this patch update - the flights are sometimes still not logging which is a problem.

Because, hours of flights not being logged means that the flight did not happen really.

I was hoping that the patch update would sort out the logbook’s incosistencies for not logging hours.

I looked at the patch update details and didn’t see anything regarding sorting out the logbook’s recording of landings etc.

Are Microsfort/Asobo aware of this?

Was not like this in SIM8…

Anyone else having a problem where their Logbook is losing all your flights? Since May 5th, 2022 after I fly a flight (or several flights) there is an entry(s) in the logbook until I quit the sim, next time I load the sim they are all gone. All entries into my logbook prior to May 5th 2022 remain in my logbook. My hours flown reset back to the May 5th time as well. Weird thing is any achievements I have earned while flying since May 5th are still there. This happens with an empty community folder as well.

1 Like

Dev Mode is set to OFF correct?

correct! it is off. i even tried switching it on and off.

1 Like

Mine has been doing this since forever. steam has me at about 2600 hours, the game says 175 or so…The only real fix Ive seen anyone talk about is to keep your logs in an outside program.

Search the forums, there are a couple of people that seem to have a way to back them up and restore them.

1 Like

Not good(!)

Same for me. After a flight, I check the log, the flight is there, but after restart the sim (Quit in the home bar on XBox s) the log entry is gone. Last flight logged is the flight right before the last SU9 patch. Did a full uninstall/install, but that dit not fixed it. Tried to sign out before quitting the sim, did not work either. Don’t know what to try more….:disappointed::worried:

2 Likes