Logbook not updating after patch

With no tower, you usually just tune to a Centre that covers that airstrip, or simply announce you are taxiing, taking off etc. You don’t get a response, you informing other pilots in the vicinity.

These are the ones that will often not transition past the taxi to runway phase, and thus no takeoff logged. I have for them to trigger before, but involved taxiing around the threshold of the runway till it detected a change in my location that would trigger then takeoff phase.

I had similar failures with either waypoints … or no waypoints. At least I could not detect a big difference there. It feels “stochastic”.

But “crashing the aircraft” after arrival so far consistently registered all flight minutes and all takeoffs and landings during the flights.

It feels to me like all the internal “logging” is OK … but the final “commit” into the Logbook only happens unter certain conditions. The most reliable condition (so far 100% for me) seems to be … crash the aircraft on the final destination (e.g. into the terminal or whatever)

1 Like

I thought I solved it. At least with bigger aircrafts. After landing tune to ground and ask taxi to gate or parking then the game will create big rectangle around your designated parking. At that spot you need to turn engine and batteries off. Some kind of menu pops up and at this moment the flight is ended and properly logged in. But I was wrong. Today I landed in Kuwait International Airport and there is no option taxi to gates or parking only taxi for take-off even though there are gates. Since turning engines and batteries off will work only if I am in the rectangle I can’t properly end the flight and it is in logbook as landing in vicinity.

Hmm … I have to correct myself. Today I lost two takeoffs during one flight … but at least the original departure location and the flight duration and two landings have been registered correctly.

So this clearly suggest that the “final crash commit” only gets my flight logged, but the takeoff-landing-count question seems to depend on yet another aspect. Hmm … tricky.

The next time you get one of those flights where you suspect it might not log, just bring up the Objectives window, and post a copy of it here. That will give you a pointer as to why a landing might not be recorded. It’s worth having it open when about to take off as well, as it will indicate whether your take off might be logged as well.

It may be that it didn’t detect your landing. It’s a towered airport, so if you were tuned to the tower, you should have heard ATC give you a couple of messages about exiting the runway at the next taxiway. Did you hear that? If not, it could be your flight was stuck at a different stage. As you taxied off the runway, you should have then been instructed to change to Ground? Did you hear that?

To me there are (at least) two key questions here:

  • How to work around this bug?
  • How to explain the cause of this bug?

The “ATC” and “Objectives” window to me fall into category one.
For the second question I observed the following today:

  • Three airports + two takeoffs + two landings … and lots of taxiing.
  • The flight was logged … the duration looked correct … and the departure and final arrival were correct.

The interesting parts are:

  • (a) I did fly … and the log has the correct departure airport … but no takeoff
  • (b) The flight duration clearly only recorded the “air time” … my excessive taxiing has correctly been “ignored”

Especially (b) suggests to me that the internal tracking of activities can clearly distinguish between “air time” and “ground time”. So the overall tracking seems to “pay attention” all the time (as expected) and the fact that there have been transitions between those state should allow counting the “takeoff-landing”. For some reason the game engine does not use that information.

(Looks like there is a pending update … so fingers crossed)

If we consider it a bug, then it might be perhaps one of two things:

  1. The player has fulfilled all the objectives to trigger a takeoff/landing, but it did not trigger for some reason. I see this a lot at untowered airstrips, where it does not detect you taxiing, then entering the runway.

  2. Sim logic for advancing through those states itself are bugged.

A workaround for 1 might be to simply credit the user with a takeoff. I’ve observed that even when it still thinks you are supposed to be taxiing to the runway entrance, even though you are currently climbing, it will eventually switch to one of the later states, such as climb to cruise height. Just consider that as a take off event.

Take off are fine. those are correct and logged every time.

I landed at kuwait airport with IFR gently, no hard landing or crash. atc asked me to leave at nearest taxiway and then contact ground. I change to ground and there are no taxi to gates or parking only taxi for take-off or ground service. Today I flew to anchorage and flight is fully logged.

Did you use the recently released Kuwait community add-on? Anecdotally, I have more issues with take-offs and landings not logging at community add-ons compared with default airports.

What we have here is a failure to communicate.

I haven’t seen or read ANYTHING from MS about what is a takeoff and what is a landing, or more precisely, what triggers a logbook entry for a takeoff and what triggers a landing entry. We cannot rely on what is obvious to most people or what other flight sims do. Personally, I think the logbook feature was poorly designed. After flying for three months, I do not understand how I can have zero takeoffs and TWO landings for a recent flight. And if I choose an incomplete flight to fly it, why is a new flight entered in the log instead of finishing the one I selected?

I just installed FS for the first time 11/17. Got new hotas controls today. No other add ons or dev mode. I did adjust a couple of the controls settings and change flight mode/difficulty settings. I did not explicitly enable flight mode. I have made successful take-offs (IMO) and a could landings. Nothing in the log book though. I thought maybe I had to manually open the navi and start/stop to record. I’ll try that. But should I have to? Seems the expectation here is that I should not have to.

What triggers a takeoff or a landing is getting a proper clearance from ATC to takeoff or to land on a specified runway at a controlled airport, not any runway, the one you requested or was assigned to you, just like in real life. Note here, in your flight plan, if you start your flight on a given runway, FS will position your aircraft on the runway, engine running, and proper takeoff clearance granted. At a controlled airport, if a full stop landing is intended let ATC know, this will trigger the sequence for you to request a parking spot, otherwise, ATC assumes you did a touch and go and will guide you to take off again. At non controlled airports you have to make your intentions known to ATC either takeoff or landing. ATC will not respond to your communication, but somehow, this acts as a clearance for a takeoff or landing. MS wants you to make your intentions known to other aircraft like in a real unmanned airport. Little trick here, let your copilot handle the ATC communications, and keep your ATC window open, this way you will know what is going on and what is expected from you. The objective window is also a great help. Again a proper takeoff or landing clearance is a must for any log entry to work properly. ATC is the boss, instructions have to be followed and all your flights, takeoffs, landings, etc, will be logged properly.

No. Right now I mostly flying to default airports. I’m finding out right now where are good airports and where to fly in this vicinity.

Just “crash the aircraft” on landing … and you will at least get your flight time logged.

The counting of Takeoff and Landings is still a mystery. You will find many good hints in this thread … but none seems to work perfectly.

Uff this is dissappointing. I’ll try to get this achievement too in the next couple of days…

I have not used that feature outside of the training flights, so you definitely don’t need to do that. But you do need to follow the objectives based progress tracking of you flight if you want them to be logged correctly.

I had hoped to post all those stages to de-mystify this process, and for me, at towered airports, if I do what the sim expects of me, it works 100% of the time. But I have to do what the sim expects. This won’t work so well for those trying to follow instructions from outside the sim.

For untowered airports, landings are fine, and I can get them to log all the time, but takeoffs are hit and miss, as it often doesn’t detect you have taxied on to the runway. There is a step at towered airports, where you hold short then request takeoff clearance. This step is absent at untowered airports, and that is the step that doesn’t advance most of the time.

I’d still like to see a video of someone going through that process to hopefully identity where it is going wrong for them. My guess is skipping over part of that process somehow.

I ran a short flight, ignored most of the objectives (some you complete just by getting airborne etc), landed, taxied to my spot, shut down as normal and it correctly registered the entire flight.

Seemingly you don’t need to follow all objectives to get it to log.

Yeah, I noticed when I did a test at an un-towered airstrip, that didn’t detect me entering the runway. After take-off, an presumably a certain altitude was reached, all the steps previous to that starting to advance, and auto-complete. I don’t remember whether that actual flight got logged correctly though, so need to test.

They definitely need to work on that logic, as 9 times out of 10 it will not detect I have taxied to the runway, then entered for take-off.

I’ve also had a few cases where, because of an issue with the take-off which did not clear, when I landed, even requesting permission from ATC to do so, after landing, the process did not advance to the next objective. However, as I taxied off the runway, it then flipped to clearing the runway, and I was able to request taxi to parking.

Their process seems to have conditional checks that are often not triggered for a variety of reasons. In some cases I have had to do a quick take-off, and landing again while staying in the circuit, to get the process back on track.

And sometimes you can follow the objectives and ATC to the letter and the log doesn’t work correctly.
It’s almost like some of the data is getting lost or failing to be recorded. When it comes to updating your log book at the end it only goes as far as the failure point.
Be interesting to see if this gets discussed in the next Q&A.
I’ve been reporting this for months.

1 Like

today i had one of the longest flights in my 2020 history.
and it didn’t log. very frustrating.

i never experienced a no-log before. or just didn’t notice?

anyway, i hope this gets fixed soon.

1 Like