Logitech MSFS Plug-in causing CTD

Dear Logitech MSFS plug-in users. Do you experience CTDs when the plug-in is installed?

It looks like my Switch Panel is causing my issue. As soon as I install the plug-in to make my Switch Panel working as designed, the sim starts to CTD. When I uninstall the plug-in, the sim works like a charm, but of course I lose all functionality. I tested my theory on different airports, but only in the C172 G1000. Oh and of course this is happening since SU5. I bought the panel in April, it was 100% fine, then SU5 happened on 27th of July.

What I experience: I always start from a parking position, cold & dark and follow the IRL C172 startup procedure. Most of the time I get a CTD around 1-2 minutes into the “flight”. I say “flight”, because with standard startup procedure you don’t even start take-off roll in 2 minutes on bigger airports, maybe on small strips. When CTD happens, Steam still displays that MSFS is running. I have to stop the LogiMicrosoftFlightSimulator.exe in task manager manually, then Steam shows that MSFS is not running anymore. My guess is that simconnect is causing the CTD (0xc0000005 in event viewer), because I could reproduce it with another add-on using simconnect (OnAir Company). When I uninstall all simconnect related add-ons, I can fly for hours without issues.

Another small detail: I connect my panel to my Logitech yoke, not directly to my PC, I will try that later today and update the thread.

As an extra question: Is there any alternative, working, no-CTD solution at the moment to use my Switch Panel? Or should I simply try with every upcoming hotfix/SU/WU or wait for Logitech to release a new version of the plug-in?

Yeah the drivers of the switch panels are a big source of CTD. The last time I checked they hadn’t been updated since last December. Its never been a consistent problem though. Mine were running fine for a long time and then all of a sudden out of nowhere started causing a CTD at the main menu screen on start up. Deleting the drivers cured the issue. I’ve since reinstalled them and its working again (touch wood)

I have 100% CTD reproduction rate with the plug in installed and 100% success rate (so far) without them. I also used the plug in from december without issues before SU5. I’m thinking about opening a ticket for Logitech support too.

1 Like

Logitech really need to update the drivers. I think a certain combination of factors have to align and then you get constant CTD. Its why some people have issues whilst others don’t.

Other people here have reported the same problem.

Hi there.
You can try the following.
1-Go to this path and delete the xml called exe

C: \ Users \ YourUser \ AppData \ Local \ Packages \ Microsoft.FlightSimulator_8wekyb3d8bbwe \ LocalCache

2-Install the logitech driver

3-Install Fsuipc (this is the first one at the top)

http://www.fsuipc.com/

4-Go to the path that we have named in step 1 and check that the xml called exe is there again.

5-In energy options.
Additional power settings.
According to the plan you are going to use.
Change plan settings.
Change advanced power settings.
USB configuration.
USB Selective Suspend Settings
Configuration: Disabled.

1 Like

Can’t honestly say I have had this issue so far and been using the sim since before release with them.
Doubt it makes a difference but are your panels plugged in a usb socket directly attached to the motherboard.(Sorry I missed the bit you said it was plugged in yoke I thought that connector was just for the throttle quad. I use a honeycomb yoke and Logitech throttle quad plugged in pc usb sockets.

Also if you go into device manager and go into human interface have you manually checked they are up to date in there and no errors.
Also check if in power plan advanced settings see if usb suspend is disabled.
(just thinking of anything that could be different between or settings.)

2 Likes

I have disabled USB suspend, that was one of the first things I tried, when I narrowed down the issue to the Switch Panel, but no luck.

I have the Steam version, so the path is different for me.
I disabled Steam cloud save for MSFS and deleted all files and the folder itself from this location: c:\Program Files (x86)\Steam\userdata\150366817\

After this, the game started as “brand new”, I had to configure all settings again from 0.

I will give a try to fsuipc, thanks for the suggestion.

@DORRAGER
My switch panel is plugged in to the yoke and the yoke is plugged in directly to the IO panel of my motherboard, no USB hubs, extension cables or anything similar is used. I tried both USB 3.0 and 2.0, no difference for me.

The Logitech yoke system uses PS/2 connection for the throttle quad, it is different than the “standalone” throttle quad. So on the yoke base you get a PS/2 socket dedicated for the “bundled” throttle and you get 3 USB slots. They are not designed for high power delivery, but should be totally fine for the switch panel and the rudder pedals. There is also a power connector on the yoke, maybe I should use my G29’s power adapter, I will look into this and will give a try, if it is safe for the yoke.

I will give it a try to plug the panel in to the MB directly first. But this was fine before SU5.

2 Likes

No issues with the driver, only issue I’ve had is power draw, and that may be your issue as well given you are driving the pannel and yoke off a single USB. That’s allot of power.

May want to try spreading the load out or getting an externally powered USB Hub and see if that does it for you.

I would totally understand this, but this was working for months with the exact same setup. I didn’t change anything, just installed SU5. Anyway, I’ll try to plug the panel directly in to the MB next time and post the update here.

Update: Same CTD with the panel connected to the MB directly.

This has been my experience too. Works absolutely fine for weeks then suddenly starts causing CTD every time I launch the game and get as far as the main menu.

The sim won’t launch again until I go to the task manager and end ‘ligiflightsimulator’ which is the logitech driver still running in the background after the crash.

Well it’s not the driver, it’s the plug in. These are 2 different things. The driver tells Windows what the hardware is, the plug in tells MSFS what the mapping for the switch panel (and other panels) buttons are. That’s why we don’t have it in the game as a separate controller.

1 Like

I installed FSUIPC7 for MSFS. It didn’t solve my issue, but at least I see now that the switch panel is flooding data. As soon as I switch on the batteries in the plane, it registers this:

236969 11912 ***  AXIS: Cntrl= 67227 (0x0001069b), Param= 11 (0x0000000b) LIGHT_POTENTIOMETER_SET
236969 11912 ***  AXIS: Cntrl= 67227 (0x0001069b), Param= 10 (0x0000000a) LIGHT_POTENTIOMETER_SET

I wouldn’t be surprised, if the 2 inputs at the same millisecond would overload something. And this goes on with a high frequency: around 26 “switches” in a second.

Of course I can’t check if it was the same before SU5, but now I think that the new cockpit mouse control is causing something. I will give it a try to switch to the modern setting instead of the legacy.

Maybe this is my issue too, I have the Logi switch panel and multi function panel and have had non stop CTD since SU5.

I run a full Saitek dash. I have a bud that is entering that part of the sim hobby. So I tested it out for him using the new Logitech drivers. OMG what a mess. CTD’s daily. This sim does not need any drivers for Saitek/Logitech flight controllers. They work right out of the box. Ino most of us already know this, this is for noobs.

The Saitek dash panels such as the Switch and Multipanel (autopilot) require a driver for the sim to talk back and forth. Logitech driver comes with it but it tends to take control of all Logitech peripherals. That gave me CTD’s. Remember you dont need a driver for Logitech/Saitek flight controls in this sim. Make sure to install only the driver for the dash displays and carefully follow the directions.

Personally I dont use Logitech drivers at all. I run SpadNext and FSUPIC7. They give me ultimate control of everything connected to my sim. The correct Logitech drivers work fine for your Dash panels in most planes. Just be aware, this sim does not always follow the standard simconnect functions. Some planes work perfect and some not so. The Logitech drivers are static and cannot be configured to work with the “no so” ones.

There are many ways to setup your sim. There are many simmers with a lot more knowledge than I. This is just what I found to work for me.

I started to write a longer “rant” why you are wrong, then I realized, that you are using SPAD.neXt.

That’s why you don’t need the plug-in. Without it, the sim doesn’t do anything, no matter what switches I use on the panel. Windows recognizes the yoke and it works perfectly fine without any additional software, you just miss the programming option from the Saitek/Logitech software for the mode selector. The rudder pedals and the throttle quadrant are also 100% fine without any other stuff. Windows also recognizes the switch panel and downloads the driver (as Saitek, not Logitech, so they didn’t change anything). Additionally you can download the panel tester from Logitech, but that just simply shows what switches you operated to what position, nothing else.

But the switch panel needs the plug-in to work ingame. As the panel is not present ingame in the control settings, the plug-in tells the sim the button mapping instead of the user. You did a workaround with SPAD.neXt, it tells MSFS what button does what, basically through FSUIPC or simconnect, but you eliminated the faulty Logitech plug in. I just downloaded SPAD, checked the log in FSUIPC and there were no spamming of LIGHT_POTENTIOMETER_SET. And of course no CTD at all. So I bought SPAD for MSFS, 25€+VAT well spent. I will do more testing to confirm it fixes my issue.

It is sad, that you buy the additional Logitech hardware and you need to pay for a software to make them work as intended.

1 Like

SPAD has been around for some time, and a dedicated team of engineers improving the software all the time. Logitech created a set of drivers that would work well on some planes, and with no scope for customisation to make them work with any plane.

That’s what you get for your money, the freedom to configure them as you see fit.

Hi! I just bought the control panel and I had the same problem right away, it caused CTDs just after installation. Now, it appears that this solved the problem, at least for now, I haven’t used it for too many hours, I just got it, as I said! Maybe you give it a try:
First, do not have the panel connected to the USB when installing the logitech application. If you installed the application while the panel was connected to the USB, uninstall the application, unplug the panel and then reinstall. Then plug it back in. Second, do not plug it into a USB 3.0, use 2.0 USB only.
Good luck!

I removed the Logi drivers and installed SPAD, CTD issues I was having is resolved.

1 Like

Just want to add my voice to this issue. I’ve been using the panels absolutely fine right until the September update and then 100% CTD. Tried reinstalling everything and no change… it’s really spoiling the sim for me right now. Anyone from MS or Asobo care to comment on what is happening ?

aw man… if you using Logitech drivers you have to unplug everything then completely un-install everything … There are utubes out there that can walk you thru it…