Logitech Quadrant Questions

Looking for something that can be used on GA Aircraft such as 172 and TBM 930 as well as Jets such as CJ4 and the 320. Already invested enough money in my pc and Honeycomb Alpha so looking for just a cheap throttle quadrant that will get me by for a few months and maybe upgrade later on. I know this isn’t ideal for the Jets and Airliners but is it possible to get by with it by mapping both engines to one lever, and maybe setting the other two for speed brakes and flaps? Also is there any detents on this? Just looking for something fairly simple that works decent. Thanks

If it’s the three lever one, there’s a detent (which can map to a button) at the bottom of each lever’s travel range. Six two way toggles at the bottom. Lever heads, corresponding to throttle, mix and prop colors/shapes are interchangeable, comes with extras so you can configure it how you like. Small footprint, USB powered. No complaints. I fly mostly GA, but have flown the Longitude with it, using the single throttle mapped to both engines.

1 Like

It should serve your purpose. Caveat: after a while the readings from the potentiometers can go a bit haywire. The solution is to introduce some denatured alcohol into them to clean any carbon residue caused by wear from the wiper on the resistive element. And, yes, there are detents that can be mapped to reverse thrust, spoilers etc., plus three assignable two-way switches as referred to above.

I’m now on my third replacement in (almost) as many weeks. All 3, out if the box, have jittering on all 3 axis.

I got the third one yesterday having had Logitech’s pretty poor customer support confirm the previous one was defective. Imagine my surprise (not) when this brand new one was exactly the same. I now have to decide whether to give up, or contact their support again to point out another new product is defective.

Their website and driver software is woeful frankly - the driver download from their website is 32-bit and won’t install on Windows 10. I was only able to find a 64-bit version by finding an entry on a forum where someone had figured out changing the URL to point to it.

There are one of 2 things happening in my eyes. Either they’re selling refurbed units as new, or they have a fundamental design / quality control problem. Perhaps even both? Having to open up a new product to do a manual & temporary fix is simply not acceptable.

Would I recommend the product? Given its price probably just about as it is a definite improvement over not having a throttle quadrant, but be aware that it’s highly likely you will see twitching & jittering on all 3 axis out of the box. That, in my eyes, is not acceptable. Given the clearly better alternative is 3 times the price and unavailable everywhere it’s this or nothing for the time being.

ps It’s nothing to do with my PC. I have a Honeycomb Alpha and PS4 controller plugged into the same Motherboard USB’s which work just fine. I’ve tried USB 2 & 3 ports with no success.

1 Like

Well that kinda sucks lol. Just ordered one. Is the jittering really bad?

1 Like

I had mine since the release of MSFS and it’s worked well, no issues. Think it’s good value for money, obviously there are better options out there but then you have to pay quite a bit more. I might upgrade it at some point but it gets the work done :slight_smile:

Mostly flying the TBM.

It’s not too bad, but it’s there. This is someone else’s video but is exactly what I see, and it translates to jittering on all 3 axis in game.

There is one more thing I discovered after posting my previous. In one final bid to solve the issue I dug deeper into my PC and found that what I thought were USB 2.0 ports are in fact USB 3 (coloured black just to confuse me). I gather it doesn’t like USB 3 (although Logitech don’t feel this is something worth telling you) which gives an indication to the age of the design.

I’ve ordered some USB 2 ports which should arrive tomorrow so I’m praying that proves the answer.

Despite my previous post I wouldn’t go back to not having it. I’m sure you won’t be disappointed, but if you have one make sure you plug it into a USB 2.0 port.

Interesting on the USB comments. I run mine off a USB3 powered hub and have no problems with that aspect. I also don’t bother with their drivers either … just plugged the da(r)n thing in and it works fine.

Now, when I say fine, it does jitter - not as bad as in the video, and not enough to be a problem. And the middle axis has never worked since new. It’s about 20 years old now, so I guess I learned to live with it. 2 axis fine for 2 engine jets; or prop and throttle on single engine GA :smile:

I kinda wish Honeycomb would make a throttle quadrant only unit. Their Bravo is a bit bulky and I could do without all the extra buttons and switches and such…

I’m pushing Logitech support on this FWIW.

Turns out I don’t have any USB 2.0 ports on my PC (who does if their PC was built in the last 2-3 years?) and the only option I have to get them is to purchase a PCIe card at a cost of £15 as my CPU cooler & WiFi card are plugged into the USB 2.0 ports on my MB.

I don’t recall anywhere on any seller documentation, support documentation or on the product itself where it says the product will only work correctly with USB 2.0. At the very least they should say that, but I believe what they should do is make the product USB 3.0 compliant. We’re half way through 2021 and USB 2 is dead in the water.

@CBRida If you wouldn’t mind could you post how you get on with it? Is there jitter and what type of USB port can you plug it in to?


I think the USB 3.0 is a red herring. Mine’s been connected to 3.0 since I built my present PC 3 1/2 years ago. The jittering that occurs from time to time is caused by grubby pots. Moreover, USB 3.0 is backward comatible with USB 2.0 devices.

1 Like

Good, comprehensive answer.

I have been using the same quadrant for 25 some years and its only now getting to the stage where a good clean isn’t going to cut it any more. Not bad though for the cheapest quad out there!

By the way AmiableGalaxy9, I have never heard of denatured alcohol. I use Isopropyl alcohol, is it the same thing?

Denatured alcohol is Denatured Ethyl Alcohol = Ethanol = grain alcohol. Smells good enough to have a shot. :wink:

1 Like

That’s just the thing though.

I’ve now had three of them, all supposedly brand new and all with the same problem out of the box.

Their tech support suggested plugging it into a USB 2.0 port so there must be something in it.

It is feasible that these potentiometers can become
soiled after extensive use and need a clean, but it isn’t acceptable on a new product. If I’d been unlucky and got 1 duff one then ok, but 3 of them with the same problem suggests it’s something else.

I’ve got a PCIe USB 2.0 card arriving today. It will be interesting to see if that fixes the problem.

I had a similar ghosting issue on my yoke, it pulled to the right when in neutral position. All that was needed was a recalibration of the inputs to centre them back to zero position.

Try this:

1 Like

Hi, thanks for the info. Unfortunately all of this has already been tried with no success.

The one aspect that does work reliably is the 0% & 100% points, it’s everything inbetween that is the dogs dinner.

ps Just to re-iterate it’s the stand-alone throttle quadrant that is the problem child. I don’t have the Logitech/Saitek yoke.

Ok, the Saitek link I sent works for the quadrant too as it’s typically packaged with the yoke. Just for info if anyone lands on this thread with a similar issue.

1 Like

Absolutely! Thanks again :grin:

I’d be interested to know how the OP is getting on with it, and whether he’s got the same problem.


Having received the PCIe USB 2.0 card the situation definitely seems better. Whilst not entirely 100% gone, I’d say it’s about 95% better than it was.

I’ll wait for Logitech support to reply and see what they have to say about it.

Just received it today. Didn’t have time to try it out before work. Will try to report back in next day or so. I did pull it out of the box and checked it out. Was kinda hoping the levers had a little more resistance when moving them they feel pretty loose. Gonna try it out later tonight hopefully.

1 Like

For certain planes that require precision (or close to it) increments (the PT-6 singles like the TBM and GotGravel Vertigo), I pinch the lever right where it emerges from the travel slot and use friction to get very small movements. I find that the closer you get to the bottom of the range, the more fine-tuned your movements have to be, to say get from 0-15 or 25-50 pct TQ. Power doesn’t tend to start coming off until the lever is about at the 75 percent range markings so you may want to adjust sensitivity to your taste.