Logitech/Saitek devices not working with FS2020

I decided to create this topic out of 100% utter frustration. I basically have a full cockpit of Logitech/Saitek devices that work wonderful with FSX. But I can only get a few to partially work with FS 2020. The devices that mostly work with FS 2020 are the yoke and throttle quadrant and the radio stacks.

My full list of devices are as follows: (6) Pro Flight Instrument Panels, (1) Pro Flight Yoke & Throttle Quadrant, (2) Pro Flight Radio Panel, (1) Pro Flight Multi Panel, (1) Pro Flight Switch Panel and (1) Pro Flight Backlit Information Panel, also I have the CH Products Pro Flight Peddles.

I’ve downloaded the latest drivers as stated in many topics I’ve read, I’ve tried to launch the Logitech FS plug-in manually once in a flight but I get a message saying it’s already running. It seems I’ve tried everything I’ve been able to find on forums and posts in various places but have had no success. I’ve tried several different registry edits and even a script to reset my USB controller at PC startup with no luck.

I even went the crazy extra mile and bought a new 1TB SSD and reinstall windows from the current download available. Only installed bare minimum GPU drivers, motherboard drivers etc., FS 2020 and the Logitech/Saitek & CH Products drivers with no luck. Since that didn’t work. I decided to purchase new from my local retailer a Pro Flight Instrument Panel. That didn’t work either.

I’ve been searching for over two weeks for a solution but have came up with nothing. I’m reaching out here to see if anyone has been through the same with positive results/solutions. I have not tried spad.next yet. If that is a solution for sure then I will do so!

Thanks in advance!

3 Likes

Sorry I can’t help but I have a similar issue to add to what you’re experiencing:

I have a Thrustmaster HOTAS Warthog stick and throttle, Virtual Fly RUDDO+ rudder pedals and TrackIR (plus USB mouse and keyboard). Initially the throttle wasn’t detected by MSFS (even though Windows 10 detected it) and using a different USB port resolved that (all my USB ports are 3.0). Since then MSFS has been working fine with all of these.

If I try to connect a Saitek Pro Flight Cessna Trim Wheel, that is sometimes detected by MSFS and sometimes not (even when still connected in Windows 10). When it is detected, it disconnects and reconnects while simming and is totally unreliable.

I bought a hard-wired XBox controller for the drone and MSFS does not detect that with the other controllers connected regardless of which USB port I use (even though it is detected by Windows 10) With other controllers disconnected, MSFS detects the XBox fine.

I don’t know if it’s related but MSFS takes a long time to load and while waiting to get past the black screen I get the USB disconnect sound a number of times, with a wait in between each time (maybe 3 to 5 times but not always the same).

It appears there is an issue with MSFS’s USB detection. Would appreciate any suggestions on how to overcome this.

A known issue trying to connect all that hardware to your flight simulator, that I fortunately solved by using a marvelous piece of software: Spad.Next. (spadnext.com). It doesn’t need any drivers and the UI is easy to use. It isn’t freeware though, but it’s worth every penny. I’ve been using it for years to configure Saitek Cessna Yoke, TPM, Thorttle Quadrants, Rudder Pedals etc.

Peter

3 Likes

Thank you for that, Peter. I’m happy to pay if it will fix this issue. Spad.next sounds good for Saitek devices. Do you know if it works with Thrustmaster, Virtual Fly and XBox devices?

According to the site these are the currently supported features/hardware:

  • PMDG 737 NGX
  • PMDG 777
  • Aerosoft Airbus
  • Wilco Airbus
  • Access to LVAR (e.g. for A2A aircraft)
  • Saitek Backlight Information Panel (BIP)
  • Saitek Radio Panel
  • Saitek Swicth Panel
  • Saitek Multi Panel
  • Saitek Flight Information Panel
  • Saitek Pro Flight/Cessna Yoke
  • Saitek Quadrant
  • Saitek Trim Wheel
  • Saitek Rudder Pedals
  • Saitek TPM
  • Saitek X.52
  • Ultimarc PACLED64/PACDRIVE (http://www.ultimarc.com/pacled64.html)
  • Pololu Servo Controller (Pololu - RC Servo Controllers) [in development]
  • Joysticks/Gamepads (including e.g. Bodnar and Arduino devices)
  • Gauge-Market
  • Aircraft Profile-Database
  • Send Keyboard-Keys to any program
  • Keyboard macros
  • Custom Expressions for BIP etc.
  • C#-Scripting

Additional plugins available:

  • X-Plane 10/11 or FSX/Prepar3D (depends on edition)
  • SCS Simulation (ETS2 / ATS)
  • iRacing
  • Virtual FIP
  • Q400 Training Edition (Will speed up Q400 pro readouts as well)

Because I’m not fimiliar to the devices you mentioned, I suggest you visit the Spad.next forum.

If you need any help to get things working with Spad.next, don’t hessitate to ask!

Peter

I did check their website but the Joysticks / Gamepads page is only shown as “Work In Progress”. I didn’t realise there is a forum though so I’ll give that a go. Thanks for that suggestion and for the offer of further help.

Apologies to AceRocks68 for hijacking your thread.

Thanks for all the input! I figure I’ll go the route of spad.next… It seems the majority of users are have good success with it vs not having it.

1 Like

SPADnext will fix your issues no problem. However make sure that your hubs are capable of supplying 500 ma to each port. Also there is a power issue using USB ports in Win 10. Win 10 turns the power off and on at the wrong time for using these instruments. There are two ways to fix this. One: ensure to plug in ALL of your instruments in USB HUBS properly powered and then plug the USB hubs into a power strip with a switch to turn off power to the hubs. Let the PC boot first, then power on the strip(s). OR, easier: Power for the ports is controlled by the registry. This can be fixed by running this program which will turn on and off power to the ports correctly therefore eliminating the need for power strips.

[uraster | USB Enhanced Power Manager Disabler]

All you do is run this program. Reboot – unplug all instruments – plug them back in. Fly with Logi drivers or Spad makes no difference as the problem was probably power to begin with.

This is the link for powering hubs through win 10.

[uraster | USB Enhanced Power Manager Disabler]

Hi, I have the same problem, is spad next working with the new fs2020 ?

I have Radio Panel, Multi Panel, 4 FIP’s and works perfect on MSFS2020 with SPAD.NeXt.
In other words, those Saitek devices do not work without SPAD.NeXt.
Also, make sure to use bus-powered USB hub for FIPs, because FIP is very power-hungry.
Also, as SPAD.NeXt says, “Do not Install any Saitek-drivers unless SPAD.NeXt asks you to do so.”

Also, Saitek Multi Panel has problems with “Windows 10 Enhanced Power Management” but SPAD.Next also takes care of that. (Otherwise you have to work on Registry Editor on your own.)

Another big reason I recommend SPAD.NeXt is that it supports FIPGAUGES.
As you see, Saitek’s original Instrument panel designs are “too plain”, because they stopped development 10 years ago.

FIP is a very expensive device (around $200!) so in order not to waste your investment, please use them with SPAD.NeXt and make it better with FIPGAUGES.

Happy Flying!

I use Saitek radio panel, multi panel and switch panel and all of them work perfectly without SpadNext. After fixing the Enhanced Power Management problem there is no need to use Spad.Next

1 Like

Hi - I tried Spad.Next but found it utterly confusing and overly complicated. Many of the link ups for certain “events” did not do what it seemed they were supposed to do, or they went backwards, etc.
It does seem that the logitech drivers are good for the panels and it works like 99% of the time. But sometimes they just randomly disconnect and stop working. The panels are still powered as they lights are on, but their mappings to the sim just disconnect. Doing the test for the panels in the logitech folder has them still working, but they seem to just disconnect from the sim. I have the switch panel plugged into the Yoke hub, and the multi panel plugged directly into the computer’s USB. Doesn’t seem to be a power problem if they are still recognized by the computer, just randomly disconnected from the sim. Any ideas?

1 Like

Initially I also had problems with the Saitek FIP (the other Saitek devices (Yoke, Radio, Switch) worked with the Saitek software). However, the FIP stayed black (or light grey).

After I installed the Saitek drivers (on the download page (Downloads - Fluginstrumententafel – Logitech Support und Downloads) I had to click on “show all downloads”, choose OS (Win 10 im my case) and then scroll down to the “Fluginstrumententafel-Treiber” (FIP driver) from 2017. After I installed the driver, the device turned on and is (or seems to be) working…

Hope this helps.

Hi, I have had simalar issues with saitek panels, firstly my multi-panel LED’ display would not light up. This is a common problem caused by windows power enhancement setting, found a very good video on Utube which walks you through how to sort it and it works a treat. My second issue… I use the TCA officer throttle quadrant with the saitek panels. When flying GA planes like the 152 or 172 the avionics would switch off 4 mins in to a flight. Easy fix turn off the engine 1 & 2 switches on the thrustmaster quadrant BEFORE selecting the aircraft in msfs menu, this will fix this issue. Currently I still have a problem with the switch panel, it is powered up but none of the switches work. It was working fine before the last msfs update. I have yet to find a solution to this. Good luck.

I have the same full panel and the same partial fail of the Logitech panels but this is only since the last update. I am making notes of all comments above and hope something will work.

how did you manage that ?

I have a strange problem that the multi panel trim wheel ONLY works in cessna 152, but NOT another other planes, even the Cessna 172. I installed the Logitech plugin for FS 2020. Anyone knows why?

Is there a place I can submit a request for native support for all Logitech panels?

Dear All I have 13 assorted Saitek Pro flight gauges plus a X55 joy stick and throtle . I’m using the latest updated MSFS 2020 28/01/21 for the flight simulator , and the latest driver from the saitek site. And every thing works fine. there are a few things to keep an eyes on , main one is the USB ports . I use 2 X 7 way powerd hubs for everything , but its very imported that these have a 4 amp power units.
And it best you use a USB-2 port on the computer , thou some PC,s will work ok if there backward compatable, also keep in mind the two drivers still need to be loaded manually before they will work when you run the game and you may need restart the game before there active. you will find that the side buttons on the FIP,s do not work , as they have not included these on the driver . also be careful what aircraft you use to run all units , for test I use the training jet on the landing challenge as this uses every thing , except the Backing Light panel that there is no driver for . its a shame as its a nice unit , but for now there not making it any more , but maydo in the future . I have not gone into any great detail on this info but by all mean feel free to ask . I run an old I7 pc with a 770 video board . Best regards Baz

The X-52 Hotas Pro works fine with jets, but with prop planes it does not work.

Is this the thread that other people have similar problems? I would love to use this $200 brand new controller in MSFS 2020 and am hoping I’m not sol.