Logitech Saitek throttle quadrant ... Jitter! Help?

I’ve tried almost everything I can think of… tried having only the throttle connected directly to the PC (I don’t use a usb hub anyway)

If anyone has any ideas… Thanks.

Not sure if it would help, but do you by chance have 2.0 and 3.0 USB plug ins? Black ones are 2.0 and blue ones are 3.0. Worth a try to hook them up to the blue ones if you have them. White ones by the way are the old 1.0

It looks like the Potentiometers. I had a similar problem but not as pronounced. I presume thease are a few years old or at least well used?

Cleaning them is pretty simple. I did both the Throttle Quadrant that came with the yoke and the additional ThQ. Taking appart is fairly simple, as is putting them back together. Just take your time.

I cleaned mine and they work brilliantly with excellent accuracy.

Link for a good vid I used here - https://youtu.be/UOw9Cu_-cEI

Having done it recently let me know if you need any advice. I’ll try to help if I can.

I should have mentioned, brand new out of the box. I’m starting to think along the lines that I’m not giving it enough power, but still does it with nothing else connected and also does it on a powered usb hub.

Maybe they do need to be cleaned though. never know what kind of dusty damp ride they have on the way over here in the shipping container. :wink:

Thanks, yep, I’ve tried every different USB port on my PC. Although I don’t have any USB 1.0 to try. :slight_smile:

Ah, yeah - I wouldn’t have dared if mine were new. They are a few years old and well out of warranty so I took the plunge and hoped for the best. As it was it was quite easy.

The don’t need much power as they only tiny potentiometers.

I would get in touch with Logitek though and see if they can help.

True, they shouldn’t need much power at all… Must be some USB thing… like they are getting polled at the wrong speed or something like that.
Cheers

Looking at the video you have probs with all three axis and also with buttons, so it cannot be a problem with potentiometers. Try on a powered hub to test the power issue.
But I think it’s more probably an electronic problem.
If the quadrant is under warranty, unfortunately no other solution than return it to Logitech.
If you dont care about warranty, a Leo Bodnar card is the solution, but it’s not cheap and requires DIY knowledge and not to have two left hands. :wink:

Hmmm. That might be an idea. I’ve built stuff like that before. (RC Aircraft transmitters etc.) It’s just a pain in the A for something that should be working fine out of the box. I can’t imagine the time it’s going to take to resolve this through warranty not to mention shipping costs.

Actually… as I type this, I realize I haven’t tried it on a different PC yet… more tinkering…

In fact, the hardest part of the job is the mechanic. Not easy to put the card inside the quadrant.
Not lot of space inside. If you keep it external it’s easy.
In the same time you can use it for pitch and roll axis, for more precise behavior.
But sure it isn’t normal to have to pay more for a brand new gear !
Hope you’ll get it work without this solution.

So, I tried it on my laptop, and the jitter is much less, but still there.
I have an Arduino sitting here from some other old projects… Didn’t want to go down that road, but if I have to I might as well start the whole VR cockpit thing. Build it so everything is in the same place as my favorite plane and just reach out and touch…

Potentiometer. Take them outside, put levers in up position, spray some wd40 in there and move them fully a few times, let dry. Repeat when it starts to act up again

1 Like

Look at the video. All three axis are jittering and also buttons.
What are the chances that three potentiometers and three buttons are defective in the same time on a new gear ?
I often use WD40 for many things, but it smells like s… for hours, and there are much better products to clean pots and electronic parts.

I agree. If it were just the jittery axes that would be one thing, but flashing buttons isn’t going be fixed by some lube!

I have that quadrant, and the buttons are at the bottom below the levers. The only way they would be flickering on, and off like that would be if the levers where physically bouncing up, and down on them! :grinning:

Every few months I do this and the quadrant becomes like new. No jittering.
Does not have to be wd40, any spray contact cleaner will do.

1 Like

Thanks, I may try that. This is happening brand new out of the box, and weirdly I think I’ve noticed that it’s worse in FS2020… when I’m looking at the jitter in the joystick control panel it does have a mild jitter, but when I start FS2020 it goes crazy. Still trouble shooting…

At the same time, I’ve hooked up some switches and pots to an Arduino and testing that.

Ok, weirder by the minute.
Sitting at the desktop with FS2020 not started, the control panel shows the 3 axis as pretty solid. Very minor jitter in a couple of places along the range of motion. What I would expect to be “normal”.

Fire up FS2020 and it does what I showed in the video, jitter like crazy. Exit FS202, back to normal. Then I noticed that when FS2020 is loading the jitter would come and go… seems to be somehow be only happening when the graphics card is being pushed harder… and almost but not quite matches up with the coil whine I get from my RTX 2060… Did the same test in Xplane, same (but lesser) result, and when I turned down all the graphics setting the jitter dropped back to almost normal. Went to an external view of the plane… no jitter.

I have not noticed anything like this with any other USB device, my TM16000 and thrust master pedals seem ok.

All the levers on my Logitech throttle quadrant jittered straight out of the box in MSFS cockpits (since replaced with a Honeycomb Bravo quadrant). I just ignored it, as I’ve seen it in so many videos on the sim. Didn’t seem to effect their use on my system. But I have never seen the buttons varying like that. Maybe a capacitor to smooth things out? Or a Faraday shield? lol

Whatever, good luck.

Had this problem myself and solved it by cleaning all the potentiometers and map all axis in FSUIPC instead of MSFS. In the former one can apply filters that reduce the jitter.

I should try mapping in FSUIPC on mine…

The bottom half of the throttle axis is not working at all. Yet it seems to work just fine in xplane 11. My prop and mixture work fine in MSFS. Ive tried swapping mappings in MSFS but the problem follows whatever axis I map the throttle to…

My bravo can’t come fast enough haha.

1 Like