Logitech X-56 H.O.T.A.S Joystick and Throttle controller

I am unable to assign actions to any of buttons/switches on either the Joystick or throttle controller. Only the axis controls work. I keep getting the error message “you are trying to assign an action to a device that is not selected”. How can this be when the axis controls work ok. All the buttons/switches and axis controls have tested out ok after typing joy.cpl in the windows search bar and going to the appropriate controller. I have been on the Peripheral Control Settings Overview and FAQ page and under the sub heading “The Control List” it specifies the following “If you press an assigned button on the selected device, the command bound to it will blink in the control list”, this is not happening apart from the axis controls. It does not even happen on the default device for the Joystick and throttle controls. The commands under the default keyboard do work correctly and the commands do blink on pressing the appropriate button. I have uninstalled and re-installed MSFS2020, I have made sure that all steam input devices are disabled. I even seen a comment that tells you to make sure all other USB devices are disconnected before starting MSFS2020 as there could be a conflict, but my mouse and keyboard are USB and I cannot disconnect them as they are required to start MSFS2020. Any help would be gratefully appreciated.


I use the same device but never experience that issue. Have you tried to download the driver from logitech’s website? I believe they have not released a driver over the last two years, the one I used and I did some of the sensitivity settings since we completely lost that page in the game after the recent patch.

Downloaded the latest driver last week, that was another suggestion I read about. I did initially have the Joystick and throttle controller plugged into the same powered USB hub but seeing some comments I placed them in to independent hubs on the back of the pc. Still no joy.

Only had mine since Saturday, mostly just using the default mappings, but i’ve added a couple of my own without any issues.

Do the default mappings blink in the controls list when the buttons/switches are pressed?

Can’t remember now, I’ll check tonight.