Looping Update and none of the other Solutions work. (2.5mbits/s Satellite Internet, shipborne)

I’m stuck working on an international Cargo Vessel and am rationed to 6hrs of 2.5mbits/s Satellite Internet each day Hotspotted through my Phone. I have now spent 5 Days of Internet Rations trying to solve this Issue. Imagine how I feel about it, as I would like to also have some Internet for other things.
I am trying to download the latest 1.9GB Update with the A310-300 1.1.5 .patch which simply loops all the time.
Steam, Super Mega Uber Premium Professional Version
I run with VPN and no Antivirus (VPN to get through the Filters of the WiFi on board)
I delete the .patch and .fscontent every time it fails to download.
I deleted all the cfgs from the Appdata Folder for clean settings
I did the Auto-Tuning thing and in Normal I get to 54MB before the Loop, with Autotune disabled I get barely 12MB.
I tried all the Solutions from the FAQs, reddit, Forum Entries etc.
I am now on my 4th Hour of Internet Ration for today and tried 5 times with different Settings.
A Re-Install is out of the Question, obviously.
I just deleted the FlightSimulator.exe and fixed it using Steam.
I don’t think it will work, so still hoping for inspiration.
My Patience is wearing thin.

Any Help is greatly Appreciated

So basically, whenever the Internet cuts out for some seconds, which it does very frequently, the Download resets.
At this rate it is absolutely impossible to download a310-300 1.1.5.fspatch of almost 1GB.

Ok, I give up. The game must have an inbuilt timer and if a download-file doesn’t make it in the alotted time it simply resets it.

Can’t really help you with your particular download issue but considering you only have acess to a 2.5Mbps connection, I can’t imagine it will run very well even if you do manage to get that issue solved.

The game streams satellite data and live weather in real time. Microsoft says you should have a 5MB/s download speed at minimum, but ideally 50MB/s.

I’d also guess that a sattelite based connection would have a fairly high latency which is never good for online games.

The Game can run offline, but right now I just want the Bugfixes, as for example the DC-3 Flight Model is completely borked and some other things. Right now it is barely playable due to the bugs that came with SU11 and I just want to update it for that.
All other things download just fine, it just takes time. Only Flight Simulator gets confused by slow Internet.
Steam has no Issue updating stuff.

Fixed it. Switching VPN from Turkey to Greece did it. Kinda strange to discriminate like that but OK.

1 Like

Oh well, glad you got it fixed. Happy flying :grinning: :+1:

MSFS just completely excrements the Bed when the Internet is even a little inconsistent.
Asobo: Waves exist and sometimes the Antenna simply loses Connection for some Seconds, why do you make Downloads loop when the Internet is below 0.25mbit/s for only a few Minutes?
Not everyone is so privilieged with a stable 100k mbit/s land-line.

My Internet looks like this:

So my Bin-Folder can look like this: (There would be more, but “Checking for Updates” always takes 20 Minutes already, my Internet is rationed so I have limited tries.)

I have Internet but as I am writing this, MSFS tells me I am offline and Connection Lost.

Ok, I have a 40GB Sim Card and shakey Bangladesh Internet. Already used up 12 GB for the 2GB Twin Otter Download accidentally after leaving the PC unattended for an hour. Whenever the Internet cuts for more than 30s the Game drops everything and starts new.