Loss of Keyboard When Changing Autopilot Heading Settings - Keyboard Buffer Issue - Heading Bug Stuck Spinning

Flying the 787 when using autopilot changing the heading bug via CTRL+ INS or CTRL + DEL and holding those keys down it causes the heading bug to start to spin rapidly, then all input is ignored for a considerable amount of time. I lose mouse, keyboard, flight stick controls, yet the mouse pointer is still working and sometimes joystick POV and buttons, but nothing else. I just can’t click and all keyboard inputs stop working.

Previously, until today, I was using the mouse to change the heading, altitude and airspeed on the dashboard of the aircraft, but I got sick of the bugginess of those knobs and started using keyboard controls to do it, and that’s when this problem started occurring.

Eventually, I crashed and my flight ended.

I could use the keyboard and mouse in other programs, ALT + TAB and ALT + CTRL + DEL worked and the mouse worked in desktop and everywhere EXCEPT in flight sim. Bummer… this is 2 flights this has happened after flying for 2.5 + hours each flight today with no problems until on the descent and approach when it just freaks out and stops taking inputs. For a short while, I could use my joystick POV and buttons to switch views and etc, but then that stopped working also.

I recall when I hold down CTRL + INS or CTRL + DEL to spin the heading bug 90 degrees or so in autopilot is when this occurs. I was able to change heading just fine until I held down the keyboard command keys for a second or more.

See the comments below for a temporary solution

I’m wondering if FS is freaking out due to the rate the of the input repeat on the keyboard? It’s a mechanical keyboard. (Yes, it was. Keyboard buffer was causing it) I was able to also start and stop a recording and get the NVIDIA Experience application to respond just fine, which is how I captured the video below.

As you can also see, hovering the mouse of the in-flight menu for ATC / Video, etc brought the menu up, but I couldn’t click anything.

Here’s a video of this problem after it occurred. As you can see, I can get back to the desktop and task manager, but I cannot control the aircraft, and no inputs work inside flight sim except the mouse cursor. When I ALT+Tab to a different window, the heading bug stops spinning, but I still have no input from Keyboard or Mouse. In this particular flight, I was able to use joystick POV and buttons, but autopilot was stuck on.

The issue starts at around 3:15 into the video. This video was cut down in length to demonstrate the issue before and after it occurred.

Anyone else having issues like this?

Steps to Reproduce:

  • Take off in 787
  • Get to Safe Altitude
  • Engage Autopilot with Heading Mode ON
  • Adjust heading bug with keyboard: CTRL+INSERT or CTRL+DELETE for by holding down the keys for a few seconds, maybe more.
  • Let go of the keys and see if it keeps spinning. If it is, you can’t stop it, or get further keyboard inputs to work.

By now your heading bug should start spinning around without the ability to control it. You may also lose keyboard inputs, mouse clicks, and the ability to control the aircraft, change views, etc.

Yes, I have crash disabled because going back to the main interface with a “You have crashed” message is lame. I’d rather hit slew and try again than waiting 5 minutes to load up again…

Yes, I can verify that it happened to me. Had the exact same thing happen to me one time. Probably only happened once because I only used the VFR map once during that session.

And I was definitely swinging the heading bug around 180 degrees. I was just trying out some features and getting used to the camera controls so I had it on AP… decided to turn back to see what the airport looked like as I approached it. I went to an external view and then used CNTRL-INSERT to spin the heading bug around. My keyboard repeat rate was such that after the sim ramped-up the rate of movement for the heading bug, I actually overshot 180 degrees a little bit. Then the fast spinning started and it didn’t ever catch up or stop spinning.

I thought the same thing about the keyboard buffer. In fact, I didn’t get the correlation to the VFR map being open so I started giving it 5 key strokes at a time and then waiting a bit for it to catch up. Trying not to harass it with a barrage of keystrokes. I’ve actually been doing that for a couple day (until I just now saw your post).

Thank you for putting together a great bug report!!! Just to be sure, you did submit it via Zendesk, correct? If you feel it’s a good move, I’ll submit one via Zendesk as well.

Thanks again. Greatly appreciated.

Michael

Awesome, thank you for replying and confirming you had the issue also. At first I didn’t know what was causing it, so I decided to try and reproduce it. I was able to spin the heading bug as much as I wanted until the VFR map was open, and then it started once I had my mouse focused inside the VFR Map.

I just uploaded a new video showing it actually happen and I updated my post with the new video. Hope that helps others as well and this gets fixed. I ruined 2 long flights over 2.5 hours each today without being able to land. So now we know how to reproduce, and maybe avoid it until it gets fixed!

1 Like

Would be nice to make a zendesk post with all your details. Just posting in the forum by itself doesnt fix anything.

1 Like

I submitted a Zendesk request…

2 Likes

After messing around with this more today, it had nothing to do with the VFR map, but everything to do with keyboard buffer, or the function that reads the heading input from the keyboard.

Temporary fix: I went to Control Panel > Keyboard and reduced my keyboard’s repeat rate. Then, I took off, did a bunch of heading changes with keyboard and wasn’t able to get it to reproduce the error. I held down CTRL + INS and CTRL + DEL for a few seconds at a time, no problems. I was able to spin the heading bug 360 degrees several times and when I let off the keyboard, it stopped spinning. That works as advertised.

So, I wanted to push it, and try to break it again. I held down. CTRL + INS for 10 seconds (counted in my head) and let off, then the problem occurred again. The heading bug kept spinning and spinning and wouldn’t stop. I hit CTRL + ALT + DEL and then went back into flight simulator, and the heading bug stopped spinning. This time, I had mouse control still. Once I used CTRL + INS or CTRL + DEL it started spinning again and wouldn’t stop.

So, this is apparently a keyboard buffer issue in the simulator… I’ll update my Zendesk report, but for now, if you go to Keyboard settings in Windows Control Panel and reduce the keyboard repeat rate from full speed to about 25 or 30% it should help reduce the frequency that this problem occurs.

They gotta fix this… pretty crazy bug to be having in 2020.

4 Likes

I just ran into the same issue after changing to using more hotkeys. In particular, heading bug and VSpeed hotkeys. I’ve been able to reproduce it every single flight with the hotkeys.

I will give your repeat rate workaround a try.

I had the same thing happen in the Cessna 172 while flying the bush trip in the Balkans.

I flew the legs using the heading and altitude bugs. I controlled them using keyboard commands. Any time a large heading change was required the heading bug would start spinning. The only fix was to crash or use task manager to end the program.

I’m using a Logitech G510 gaming keyboard. I’ll try the keyboard buffer work around, but this bug really needs repair.

Thanks for your work on the issue! This is a time consuming issue.

The problem keeps happening to me on the B787 so I switched to the airbus which doesn’t have this problem.

The B747’s autopilot is a hot mess for other reasons like inability to lock into an altitude (constantly climbs and descends +/- 3.000 feet.

They really f**d the pooch on the Boeing autopilots.

I sent a zendesk request in as mentioned and did not receive any response yet. Who knows if they’ll fix it.

I’ve done a few flights now with the keyboard repeat rate set very low (20%) and I haven’t seen the issue since.

Ah, thank you, I’ll try that. Been having the same problem myself.

Got the same problem in the Caravan. Only pressing the keys two or three times to change the heading bug induced the spin.

Same Problem in 787 & Airbus A320

I raised Zendesk ticket and provided video evidence in form of Youtube video showing the problem. That way they can’t dismiss it and can see it happening for real.

i use a midi controller to bind knobs (with midikey2key) and I also have issue with NO KEYBOARD and NO MOUSE left during the flight… only joysticks are still working.
I confirm it happens when i change heading with my controller.

I change keyboard shortcuts for heading +/- in FS Controls menu and I never experienced this issue then.

Same here in the DA62.

This issue still happens, even with reduced key repeat rate. The fact that we have to mess around wilth global PC settings to ‘fix’ it does not absolve MS of responsibility to fix the actual bug in the code!

I have raise issues in Zendesk with video evidence each time, and MS have the gall to mark each one as “Solved” when they’ve done nothing of the sort! Lack of customer support here is disgraceful.

Tell me about it. I was on the phone with MS over 5 hours yesterday. Half that time they don’t understand and I can’t understand them. Getting disconnected so many times. Finally, the woman that answered the phone told me I have been talking to the wrong tech support. (Why didn’t that tech know that) She told me I had to talk to X box games support. I got put through and the guy had the problem figured out right away.
So if you are calling for tech support, ask for X box games tech support. That is really odd since they told me that this game isn’t even available for the X box yet.

1 Like

Same here, and after last patch in 2020november same problem happen, if i try set airspeed with keyboard, hold keys, not pushing repeatly, i lost mouse and key control in game already. Only close the game and rerun solve this peroblem. I buying the premium pack and because of this unsolved keybuffer problem i not playing with game anymore. High price and unplayable game. I try set keyboard settings in this post, but problem stay and happen again.

I get this same problem when using the mouse too.

Say I’m manually adjusting settings like heading, Alt, barometric, VS etc with the mouse (clicks not wheel) it will frequently run away with itself. Not ideal when you are doing a VS decent and you click to increase slightly and it runs away with itself and essentially puts you in a vertical dive.

It’s then a farce to get AP back on because of the settings but I think that is just me not having enough experience.

Keyboard repeats want seem to fix this but if using the keyboard I think it masks the problem because the lower repeat rate gives it less chances to go wrong.

1 Like