Loss of peripherals controls at mid-flight

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
Are you using Developer Mode or made changes in it?
Brief description of the issue:
After updating the simulator to I am experiencing the lose of control by all connected peripherals during mid-flight. The simulator is responsive at the start of the flight but after take off and sometime later it becomes non responsive. The command keys stops working in all peripherals. I have checked in control setting of the simulator and it shows all the connected peripherals and responsive but when flying there is absolute no response. You can’t even change the view. You can only use the mouse to click on buttons and options (e.g. ATC, Weather) but nothing else. I have checked that AI is switched off but the issue still exist.

This issue has happened every time since the new update.
Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:

  1. Choose 787 as the aircraft
  2. Take off at any airport using joystick or other peripherals
  3. After 10,000ft put the autopilot on and climb to cruise level
  4. Once autopilot is set do not use the peripherals for at least 1 hour.
  5. You will see your peripherals will stop working

PC specs for those who want to assist (if not entered in your profile)

Did you submit this to Zendesk? If so, what is your ticket #?


Cursor must be on main screen (full screen) if using multiple monitors.

Check also that cursor is not active within a pop-out box (ATC etc)

Both of these will inhibit all your control inputs.

Thanks somethingbrite,

The cursor was on the actual simulator. I can click on the cockpit and navigate the menu which appear at the top (ATC, Weather, Views etc.) using the cursor only. I can also access the setting menu using ESC button on the keyboard, but the simulator does not register any commands from any connected peripherals. I have check the active window is the the flight simulator.

The peripherals appear to be connected when in the simulator setting and they do respond.

I don’t know what’s going on.

I also lost 200 hours of flight time from my log due to this update.

Just bouncing some ideas around…

Do you have multiple monitors?
If so you could run a copy of DIView on another monitor just to confirm that the input control peripherals are still active when the issue occurs.*

When the issue occurs and you hit ESC is the simulator unable to actually read inputs if you view these in the Control menu?
(For example if you check your joystick axes, do they register in the Control menu or is that not functional also?)

If not working in control menu after 1 hour and DIView also confirms not operating maybe it’s worth checking the power saving behaviour of the USB at Windows level? If left untouched for an hour maybe it’s windows putting them to sleep? Once they go into sleep mode it’s possible the sim might not register inputs from them again until it’s restarted?

I am getting same, In approx 20 min into flight keyboard and HOTAS controls stops working. Only ESC and menus react. Nothing else. I checked pedals and HOTAS in controls sensitivity and all axes worked fine there. Just plane controls was completly locked. Only clickable cockpit with mouse worked.

Are you flying the 787 also or do you see this also in other aircraft?

Yep I flew 787, tried twice same flight with simulator restart, same result. HOTAS was working ok in windows and even in sim options. Locking apears roughly in 20 - 30 into flight.

Right. That seems to rule out hardware and operating system as the issue.

Open a Zendesk ticket to flag the bug to them.

I only have a single monitor and my hardware has been working fine since the release of flight simulator. I do not think it’s a hardware issue. It is for sure a simulator issue. I have already raised a request with on Zendesk. Thanks All.

Seems yesterday Windows Store installed something when I run MSFS and I am not able to reproduce issue again. Seems it works now fine. No loss of controlls anymore.

Same for me. I did a long haul flight and I had controls. Let’s hope this issue doesn’t occur again.

Hehe yeah, It was scary first time as I though my whole HOTAS and rudder pedals gone into silicon heaven till I realized devices works fine :slight_smile:

I don’t know if this is the same issue but I noticed similar behavior recently (after the update to, but it might have started before then). I discovered the problem was with pop out windows. If I opened the NAVLOG window, for example, and popped it out to its own window, and if my cursor hovered over the pop out window or make it active, my yoke and throttle quadrant stop working.

This does not happen when other third party windows are activated. Other than keyboard entries, the yoke and throttle quadrant continue to send input to the simulator then.

MSFS hasn’t always behaved this way, so it must be something introduced in a recent update.

I have the exact thing happening to me. Still to date. Especially with the 787. No other airline seems to have the issue but then I think I haven’t opened the map with the other aircraft last thinking that’s what makes my controls unresponsive. Any resolutions here?

I had it happen today in the pmdg 737 as soon as i started descent i had no mouse keyboard or flight controls anymore, sim was still running but i had no way to control aircraft i had to close the sim