Lost Rudder Control

I tried to use MSFS after a long period of non-use and one update and found that I have no rudder control on any aircraft. Checking the controls in the options menu results in everything working perfectly, but in the sim the rudder just jitters instead of moving. This is true with rudder pedals and the same with a rudder key assignment. Is this an issue with a solution?

Check under the assist options that non have been turned on, that was an issue for some people during sim updates.

No assist options are on. I tried setting auto-rudder on, but still got no rudder control. I notice that I am also getting some jittering of switches when I control them with hot keys. They do not always change position. Aileron and elevator control works smoothly as does throttle, prop and mixture controls.

Got rudder control back by making a new profile for the rudder pedals in the sim.


Oh yeah! I remember that one now that you mention the fix!

Moved to #self-service:peripherals and closed as Topic Author indicates solution found.