Mandatory update simulator crashes going into VR

I tried to play MSFS tonight and it had a mandatory update. I rebooted the computer after the update and now when I go into VR MSFS crashes. I tried 4 times and it crashed every time. I have been playing with no problems up to tonight. I am using a Quest 2 with link cable. It’s just so frustrating.

1 Like

Yeah, I’m getting crashes as well. Also having overexposed and over saturated colors.

Does it crash without VR?

Using a Quest2 with update and not having any problems.

Maybe a driver version issue? Which version are each of you running?

1 Like

Unfortunately this is also now happening for me since the update.

I don’t think it’s the oculus software or the quest 2

I removed the community folder of all contents and just flew without any mods.

Try that for me and see if you have the same problem or fixed.

Failing that, just try an aircraft that U have no mods on, especially working title Garmin mods.

Nots saying it’s this, but go though process of elimination.

1 Like

After another 3 failed tries I finally got to fly. I done it through Navida GeForce Experience but I gave up a lot of higher settings. Granted I don’t have a very powerful computer but I was able to fly with higher settings and better video before this update.

Sorry, are you saying you could fly in VR by reducing your graphics settings?

Yes. The Navidia GeForce Experince had lower settings than what I was using before. It turned a lot of the settings off, went from TAA to DLAA and the two renderings from a little over a hundred down to only 25. Like I said my computer is not powerful but I was at least able to play with a decent video. Someday I want to upgrade but that’s in the future.

Sorry if I’m flooding the forums with this

I’m happy to report that I have found a cause and a workaround.
This stems from almost 2 weeks worth of troubleshooting / support / forums / etc. I hope it can help a few others too.

-New load of windows 10
-new nvidia drivers
-new oculus drivers
-new steam drivers
-new msfs2020 install

still had the same issues

here’s what I had to do in addition:
install steam vr
make steam vr the openxr app
enroll the the steamvr beta
unchecked the steamoverlays, etc., anything that would evoke steamvr i unchecked.
regedit the khronos\1 registry key back to the oculus_openxr_64.json
closed all apps
opened oculus
device green
opened msfs 2020 from desktop shortcut
got into the cockpit

no screens, no atc, no nothing selected, however THE ICON SHOWED that one / some where selected (but none were, the main icon was white). I selected all the options in the ones that said there was something, then went back and de-selected all.

checked the toolbar again, all icons not white
enabled VR mode
reset my position – expected the loop
and all of a sudden i’m sitting in the cockpit. after a few seconds, the vr map , atc and objects popped up in the vr. I was able to fly again (without STEAMVR, the framerate was horrible and choppy) smooth as expected.
before exiting, I made sure to close out all menu items in the vr. then disable the mode.
made sure all was closed out in cockpit before ending / exiting to desktop.

I now check the menus before enabling VR – until it’s fixed.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.