Manual Cache not working after deletion of the ManualCache folder

Hello
After the Wolrd 3 update, I was not able to start FS2020 - Windows said “I can not find the application”
I removed the Addons from my Community Folder

  • Start was still not possible.
    Then I read that the Manual Cache data should be removed
    I did it in removing the Entire ManualCache Folder and (unfortunatly) not only the ManucalCache.ccc file.
    Then, FS2020 started (hopefuly)
    But now , I can not add “DATA” in via the ManualCache GUI.
    The behavior is strange : I set an number of GB for the cache, go to SEE and I have a message saying that Data is filling" the cache … but I do not know what are these data.
    I have a map (a picture) of an area … but I do not have the place to fill the GPS data and so on.
    I think that removing the folder and not only the file is the cause of this behavior .
    So my question is - as I have kpt a copy of the ManualCache folder, where should I replace it ?
    This folder has a sub-folder named “Component” which contains files that micght be useful

Thank you for your adivces and help

Alain Maneville

well i have a slightly similar problem. I removed everything from community folder, and deleted my manual cached areas. before update and then UK and ireland. no problems with installation. but when I try to set up a new manual cache FS2020 crashes. not a big deal, but just noting it here for others

1 Like

Here’s what worked for me (after having no heat or electricity for 2.5 days of power outage in S. Texas where a number of poor people froze to death for lack of same due to a highly unusual southern dip of the Artic vortex, sending temps to ~9 deg F < -13 deg C>).

Read about deleting old manual cache but the world update announcement instructions gave no particular required order and I had already downloaded the MS Store stub updating the SIM package before I read about deleting the manual cache. Once MS 2020 is fired up and the 23.xx Gb update found, there is no way (that I know of) to access Options, , General, Data and delete the manual cache before installing the update, so I did install the update with old manual cache still present.

Then going Options, General, Data, View Manual Cache, I got a Please Wait (do not shut down computer or exit MSFS) and since I had previously set aside 100 Gb of manual cache and downloaded ~300 sq. mi. of NYC region at high resolution, it took the sim ~45 min to an hour to recognize the 45 Gb of previous download that I wanted to delete and once the scanning finished, deleting the NYC download was a snap.

But in the View Cache dialog still said that I had a 100 Gb manual cache and putting in 0, 1, 8 Gb and hitting TAB or ENTER did nothing. It remained 100 Gb. So I exited MSFS found the presumably empty 100 Gb manual cache on my dedicated non-system NVMe drive at G:\WpSystem\S-1-xxxxxxxxxxxxxxxxxxx\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyxxxxxxxx\LocalCache and deleted MANUALCACHE.CCC (or whatever it’s called). After relaunching the SIM, in View Manual Cache, it now says that I have 0 Gb of manual cache.

The sim developers should put in more thought how such things can be smoothly taken care of and issue better procedural instructions rather than leave users to flounder around, which seems to be SOP with what otherwise is a great sim.

1 Like

Hello and sorry about what is happening in Texas … I live in the southwest of France … and the temperature is 20C … which is really too high .
To come back to out manual cache story could you give me the exact full path where the manualcache.ccc file is located? I think that my problem is that I have deleted the whole FOLDER named ManualCache - but this FOLDER does not only contain the manualcache.ccc file but other files which are used in the GUI to define areas to be cached.
Thank you in advance!!!

AFAIK, there is no MANUAL CACHE folder. When you create a manual cache, all regions cached are cached with the manual cache file with the .CCC extension. Since I’ve installed the sim on a non-system drive, my location is a bit different than if one just installed the MS Store version on one’s system C: drive. If you installed to your system drive, you should find any rolling cache or manual cache files with the .CCC extension at C:\Users(your user name)\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache. And if you did install to a non-system drive, you’ll still find a token stub placeholder at this location on the C: drive but the true copy will be as I indicated on the non-system drive for a non-system install of the sim: Rolling Cache and Manual Cache Move Back to System Drive AppData or Just Token stubs?

If you have the Steam version of MSFS, one user describes where to find the cache files for Steam (note the last “translation” reference of %AppData%): System is crashing - #13 by MichaMMA

An experimental way to find where your system would put the manual cache if you still have trouble finding it is, if you haven’t done it already, to create a small rolling cache file(1 Gb?, 8 Gb?). It will be name “ROLLINGCACHE.CCC” Wherever on your system you find that file, you should also find the manual cache file, if you have one currently.

I too deleted the manual cache as instructed and now when I try and cache a scenery area MSFS crashes. So manual cache is now once again broken.

Hello Jim and thank you for your reply - But my question is NOT to find where is the MANUALMCACHE.CCC file is located but to find where is located the FOLDER named ManualCache which contained (before I deleted it) not only the ManualCache.ccc but a Subfolder called Component and this Subfolder was containing 3 files related to components. Hopefully I have saved these folders and files … but I do not know where to “relocate” them. I have found the files suffixed by .CCC. My issue is that I CAN NOT defined an area to be cached because I do not have the graphic interface where I can set the GPS data and so on - I just have a area displayed without any thing to fill . Afain I think that having deleted the whole folder named ManualCache was not the best thing I did. I had to do it because FS2020 was not starting after World III update - My FS2020 is running very well but I just have this ManualCache issue - Thank you for your help !

OK. I searched my non-system drive where MSFS is installed and I found a folder named ManualCache at the following location on my system. It exists in spite of the the fact that I deleted and did not recreate a Manual Cache .CCC file and the View option in Options, General, Data for the manual cache says that I have 0 Gb dedicated to the manual cache currently, i.e., none. Since I have the latest world update, I guess my ManualCache folder location may depend on that:

G:\WpSystem\S-1-(My User ID)\AppData\Local\Packages\Official\OneStore\fs-base-ui-pages\html_ui\Pages

Hope this helps. I apologize. You’re dealing with a pretty ignorant newbie here (me!).

Hello again Jim and once again thank you for your help:!!!
So, if I do understand well - the location of the ManualCache folder in G:\WpSystem\S-1-(My User ID)\AppData\Local\Packages\Official\OneStore\fs-base-ui-pages\html_ui\Pages*ManualCache* - Note that I have added ManualCache to the entire path you provided to me

I will try that very soon - I am not at home at that time nut in the Pyrénées (french mountain at the border of France and Spain).

ManualCache folder contents:

Components folder contents:

Hope this helps! Yes, the ManualCache folder is one of many subfolders in the Pages folder at the path that I have given you for my non-system drive location.

Hi Jim - This is exactly what I wanted to know : the ManualCache folder contains other information than the manually cached data! And on my side, as I have deleted the whole FOLDER I miss these data under the Component Subfolder ! But I have saved them and now, that was my problem, I do know where to restore them! Thank you again It helped !! Have a nice day and I hope the weather is going to be better in Texas !

2 Likes

I have the same exact problem…it is driving me nuts, as I had my local flight paths cached.

I tried deleting the cache file. No joy. I eventually tried the nuclear option of uninstall / reinstall. No joy.

Since this UK update, when I try to manually cache a location, MSFS crashes. I give up. This is clearly some kind of s/w problem.

:exploding_head:

Just because I didn’t see it mentioned here. It’s a known issue

We are aware of crashes when using Manual Cache and we are investigating it. Until then, the use of manual cache is strongly discouraged.

https://flightsimulator.zendesk.com/hc/en-us/articles/360016027399-KNOWN-ISSUES-Last-modified-Feb-16-2021-

Hello ALL
Just to let you know that I DID NOT EXPERIENCE a CTD - just that I was not able to define an area to be cached because I have deleted the entire ManualCache folder - I will repair that next week 'I am no home currenlty) as I have kept the folder before deleting it I have asked where this folder was located - someone gave me the entire path and I think this will repair my issue. But again, FS202O is running fine after the World 3 update!

Oh sorry I wasn’t really paying attention to be honest. But be aware that trying to cache anything into the manual cache results in a crash to desktop. So nothing I would put too much work into until this bug is fixed.

No Problem ! good luck

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.