Manual Cache setup disabled

That worked, kind of.
So I could finally cache a new region (big progress), but I still cannot change location nor size (other than using rolling cage method to make a new one and then paste into manual cache location). The biggest issue is that I cannot change location.


Clicking “Modify Cache” changes nothing (nothing happens).

Having this same issue also. I tried the above but I couldn’t find any LocalCache folder in either the place mentioned, or anywhere near it, so I’m unable to actually check if it works :frowning:

Also, on the manual cache page, the cache location is grey out (unmodifiable), and crops at \appdata\roaming\micro… so I don’t know where it is, nor can I change it.

Anyone else found a another workaround? I’ve tried deleting/recreating my rolling cache, using various sizes, several times, and restarting, etc. No joy.

In my case it was:
C:\Users\MYUSERNAME\AppData\Roaming\Microsoft Flight Simulator

(I am talking about Manual Cache location, Rolling Cache location will be where you set it up in Data options)

Same problem here. MANUAL Cache greyed out.
can´t change folder or cache size
C:\Users\MYUSERNAME\AppData\Roaming\Microsoft Flight Simulator
So annoying with each update some of old errors gone and new errors occure.

Sounds like this is a (now) known bug that has been reported:

Subject: cannot-change-the-manual-cache-location/558130/2 (sorry, I’m not allowed to post links).

Happening to me too.

1 Like

Hi,
Same issue here. No way to change size, location, delete/moving/recreate the file !!

Had this on Xbox after signing up for SU9 had to fully delete and reinstall full sim to fix

Do you have the same issue if you follow the OP’s steps to reproduce it?

yes

Provide extra information to complete the original description of the issue:

I reinstalled msfs on a new computer which no longer had the same drive i used for manualcache before. Now it’s stuck and i’m unable to change locations for the cache to an existing drive. I also cannot just change drive letters of my drive without actually breaking windows or the new msfs installation to mock the existence of the old “missing” drive.

If relevant, provide additional screenshots/video:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

Yes, after a bootsector failure and fresh install, cache grayed out. Cannot cache any location.
No mods. Stock install. Have been told a patch will follow. Any ideas anyone?

Nothing useful except to say it seems there’s several of us in the same boat. My cache was on a drive that no longer exists, and a full reinstall (uninstall on Steam, delete path on disk, delete AppData/Roaming folder, reinstall) persists the non-existent path that I’m not allowed to change. Evidently, this config is stored on our sync’d profile which seems… suspect for something that’s going to be unique to each install on each machine.

I was told a patch would fix Thats not out yet. Wonderful.

2 Likes

Same to me…

Due to the slowness of MS servers for South America, rarely exceeding 10-15Mbps, Manual Cache is ESSENTIAL for flying with photogrammetry.

I had my favorite cities completely downloaded to the local disk, but I can’t even see them through the old menu anymore.

I’ve read that it is a known MSFS bug that users can no longer change the location of the manual cache. If needed, a work around to the change the size of the manual cache is to use ‘fsutil file create’ to create a new cache file of the desired size. Note that this file must reside the manual cache directory and be named MANUALCACHE.CCC. Also, this creates an empty file thus any existing manual cache regions will be lost.

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

Same issue, but triggered by removing the non-default location drive (D:) before changing setting to a new valid location.

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

2023-01-08 18_18_34-Microsoft Flight Simulator - 1.30.9.0

Manual cache is a joke.
We should be able to select a mass area and then decide whether to download that selection in low-med-hi res.
Not the other way around.

Same problem, somebody have a fix?

I had limited success by renaming an empty rolling cache and uploading to it however it created a memory leak and once I left the area a CTD quickly followed.

I expect that the MC is deliberately disabled while they work on a fix, understandable but IMO there should be a pinned notice explaining this.

1 Like

Okay, I followed the instructions from Raptor4400, on creating a manualcache.ccc file by copying the rollingcache.ccc file. Here’s my report on how it went.

The procedure does work, but there are some limitations:
a) you can only “create” a new ManualCache.ccc file in the primary MSFS Package directory [C:\Users\YOUR_NAME\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\MANUALCACHE.CCC]. If you create it in any other folder, on any other drive or partition, MSFS won’t be able to access it.
b) You can’t increase the size like you can the rollingcache.ccc file, at least not within MSFS, so you better create it as big as you will ever need. It may be possible to add extra blocks of empty data to the end of the file with a hex editor, but I haven’t tried that yet, and doing it that way might cause MSFS to simply reject the file as “corrupt” or something.
c) The scenery at the edges of the area you define to cache don’t necessarily merge smoothly into the AI (default) scenery. Especially if there is water (the ocean, a bay, or a lake) beyond the edge of your cached area, there will be places where the cached scenery tiles are visible in the water as squares of a different color and elevation. I’m not sure what would happen if you were in a float plane or amphibian and hit one of these edges on a landing or takeoff roll, but if the elevation difference is big enough to see from hundreds of meters away, it might be big enough to crash the aircraft? When landing or taking off from glaciers in a ski-equipped plane, I have sometimes hit abrupt changes in elevation and crashed, so maybe the same thing can happen where the edges of cached scenery tiles exist in water?

As for visual quality: I downloaded at High Quality, all of the area of San Francisco south to just below the KSFO airport. From 1000’ AGL or higher, it looks really nice. But from lower down, 100’~500’ AGL, in a slow plane like the Cub Crafter NX or the Zlin Savage or Shock Ultra, the merging of the photogrammetry with the AI model isn’t so attractive. The colors and patterns of bare ground and vegetation (soil, grass, parkland, trees etc) is greatly improved, but in urban areas, it’s not so good. In San Francisco, downloading and caching the photogrammetry does get you a bunch of landmark buildings that aren’t in the AI scenery, like Coit Tower, the Transamerica pyramid, the Twin Peaks TV tower, and the Palace of Fine Arts, but there are downsides:

The facades of practically all of the buildings look terrible at distances closer than 300 feet, as if they had been painted with mud. Window frames are crooked or twisted, and the modelling of structures on steep hillsides is bad, really bad - buildings on Telegraph Hill, including the base of Coit Tower, look nothing like buildings, but more like Salvador Dali painted them while on a bad acid trip.

Fly close enough, and it can be plainly seen that trees are sprouting right out of the roofs of buildings. The algorithm obviously isn’t smart enough to realize that tree trunks are rooted in yards, or out on the sidewalks and in the road medians, not in the middle of the buildings.

Objects that the algorithm can’t interpret, because they were maybe unclear in the aerial photogrammetry, are sometimes depicted as weird geometrical shapes like pyramids, that look completely unnatuaral and out-of-place.

Along the land-edge of my download, in a strip about 3 miles wide between San Carlos and the KSFO airport, running the whole width of the peninsula from SF Bay to the ocean, the photogrammetry is low quality, and looks worse, WAY worse, than the AI scenery. I don’t know what to do about this, if there’s even anything that can be done.

My download, covering San Francisco and the north portion of San Mateo County down to just below KSFO, took 11.5 gB of data. Obviously, caching large areas, like all of Death Valley National Park for example (2.8 million acres), would probably be impractical except at Low quality; if you tried to cache an area that large even at Medium quality, you might need a cache file of several terabytes. I’ll try to quantify just how much data it takes to map, say, 10 square miles of non-urban land at Low, Medium, and High, and post the numbers later.

1 Like