Marketplace Greyed Out

When I had this problem and spent a week looking for answers I finally gave up and reloaded the sim. No problems since and this was in late 2020. I blamed it on Covid and moved on.

I believe everyone’s situation with Marketplace greyed out is different - and different “fixes” do not always worked for everyone the same. Here’s the issues I had and how I finally solved it.

  1. Marketplace greyed out
  2. Aircraft that I used to have in the hanger no longer available
  3. Warnings about fs-base-propdefs being the wrong version
  4. Advisories that Newer Game Version required
  5. under my Account (top right of MSFS screen) the server was continually looping on “automatic” and never locking onto a site
  6. the sim was no longer Checking for Updates on startup

Heaps of advice on a variety of websites on how to resolve this and none of them worked for me. And as it transpired when I finally did resolve it - NOTHING was missing from my files, everything was current version - it was simply a communication issue somewhere/somehow. Can’t explain further how it was the issue because I am not computer/internet savvy. But here is my eventual solution (for the Store purchased version):

  1. Log out of MSFS (top right under your profile) and don’t let it Login again, just Close it.
  2. Goto Settings/Apps and scroll down to Microsoft Flight Simulator, clicked Advanced options and under Reset, hit Reset. Big warning comes up, but I don’t believe this actually deleted any data at all.
  3. Log out of Xbox and then delete that App from your PC
  4. Reboot
  5. download and reinstall Xbox App. Log-in - and I think this is important - goto your account settings and even if you don’t change anything there Hit the Submit button at the bottom.
  6. Boot Flightsim from within Xbox App.
  7. Mine checked for updates and suddenly it looked like it was about to download 126GB of data, but when I redirected the path to my F:\MSFS drive it refreshed and decided 0 GB would be sufficient. It then got delayed quite a while after I hit Continue, but booted up just fine and I have absolutely everything back as it should be (except for the Honeycomb lights driver)

Good luck out there fellow Pilots - I know this is ■■■■ frustrating. Hope my experience helps some of you.

I have the same problem, the market option is not available and is grayed out, I have completely reinstalled the Simulator, and unfortunately the market option is still oily and is not enabled. I have checked connection, xbox app user although all the market option does not work for me please ask for help. Thank you.

Hi guys, just an update here …

I submitted a ticket via zendesk and had the issue resolved. Here is what was causing my issue. Hope it helps someone.

Buy & Download button is grayed out – Microsoft Flight Simulator Support (zendesk.com)

Nothing Helped until I choose to make everything online in the Data Settings in Microsoft Flight simulator!

I am not able to buy anything via marketplace since a couple of month. It is also not possible to get the free world updates since update UK, because i cannot click the blue buttons, they are all inactive. In the meanwhile i logged out and in from microsoft x box, and steam in different ways, closed and opened the sim several times, but nothing helps. I also checked credit card and following tipps as reported in this forum. Nothing helps. All other things are going very well, all i need is active buttons in my marketplace.

You mention Steam - you have popups enabled in Steam’s settings? That’s how FS2020 and Steam communicate to use Steam Wallet to pay for stuff in the Marketplace.

you need the steam overlay on for that to work, is that on?

Note: On 8 July 2021 this was posted:

While this maintenance is happening the Marketplace appears greyed out in game.
This will be the case until the maintenance period has ended and a post is made confirming the same.

Update:

2 Likes

MODERATOR EDIT: This post merged into this topic.

Whenever I go to the market place to try an buy an aircraft or anything else the BUY AND DWNLOAD and BUY buttons are greyed out.
I am using Steam and have the in game overlay activated in but, no matter what I do just can’t get this issue solved.
I have consulted Mr. Google and even my wife (who seems t know everything) but, neither have been able to help me.
Maybe one of you most knowledgeable folk in the sim world has an answer.
Any help appreciated.
Thanks
Phil

Hi @GreenMink461037,
I’ve moved your post into a master topic on this. You might want to look at this topic to see if anything can help you. :slight_smile:

thankyou very much

1 Like

Hop this fixes my issue as I have not been able to access the market place since the first update.

MODERATOR EDIT: This post merged into this topic.

Hello everyone,

I have a weird problem in the marketplace where I can’t download the world update V.
The buy and download button is greyed out.

Anybody had the same problem ?

Have you added it before? If so, try going to Profile > Content Manager and install it there instead.

I never had it so it’s not in the content manager.

Here is the menu in the store :
Capture d’écran 2021-07-12 140858|690x90

Hope this is some help to simmers it helped me.

hank you for contacting Microsoft Flight Simulator Support.

A transaction didn’t go through which is why the “Buy and Download” button was not available anymore.
See: Buy & Download button is grayed out

We have manually canceled the transaction. Please try again, the “Buy and Download” button should be restored now.

It was and I’m up and running

Is the in-game marketplace down?
Cant get into the marketplace, the button is greyed out but i have a internet connection and also multiplayer seems to work…

I’m having a similar issue. The marketplace icon at the top of the menus just has a spinning circle over it and when I try to go into it I just get a bunch of loading icons. Content manager acts the same way for me as well.

Hi everyone,

I noted that for the last few days my Marketplace is been disabled. Does anyone know
about this problem ?