Marketplace purchases failing

I’ve looked through all of the posts here related to this topic and it seams the most recent issue was from 10 days ago. I havent logged into MSFS in since the update, which seemed to work fine. I have gone through all the steps in the various posts to make sure the credit card/purchase options are correct, I’ve made sure I’m properly logged into all areas, still no luck.
Everytime I attempt to purchase 3U2 Johnson Creek, I get purchase failed.
Any insight or suggestions greatly appreciated.

Make sure your Xbox app is logged in on the same account as your simulator account
I had the same problem so I know how annoying it is
I will do all can to help

Thanks! I do believe I’m logged into all apps correctly, at least the same icon is on each one. I’m going to try logging out of all apps and logging back in. Cant hurt.

1 Like

I would get the failed to purchase messages to when I upgraded to premium deluxe
Logging out of all my accounts then logging back in fixed it for me

good to know! thanks

1 Like

I also get the same error when purchasing via MSF2020. He says I have to buy credits on flightsim. My version is Windows store

1 Like

Log out if the simulator Xbox app and Microsoft store then log back in using the account you purchased the add on with


Mine said it kept failing even though I got an email saying it succeeded. Restarting the game showed that it had indeed succeeded. So the store saying it failed doesn’t mean it did fail.

There is obviously a bug there. I guess that isn’t a shock eh.

Did you get it figured all out or is it still not working

Check your content manager

No need. Like I said, restarting the game fixed it for me.


nothing solved here. I keep getting the same error when I make any purchase through the FS2020 markplace. I’ve done all the suggested procedures and no solution. Which sector of the xbox should I send a ticket to, thanks for the information.

1 Like

Make sure UAC is enabled.

Mine was disabled because that is how I prefer it. But the Marketplace wouldn’t allow a purchase with it turned off… grrrr

I’ll try, thanks.

When I try to purchase ,payment info has me locked into australia address, and I live in canada. Cant change it even though microsoft acct has correct info. not happy with msfs2020,

1 Like

Still having issues with purchases for some reason. I removed all credit cards and re-added the information.

1 Like

I am having the same purchase problem.
The MS address for purchases is wrong even though my MS Account address is correct - and there does not seem to be any way to fix it.

All I want to do is purchase some items from the Marketplace - it should not be this difficult.


I solved my problem - hopefully this can help others.
I found a link from Microsoft which I followed all directions carefully and it worked.
For me it seems that I had two issues - 1. My UAC was off and 2. My PC Region was listed as United States which is wrong for me as I am in Canada.

Here is the link…

1 Like

The is how I fixed mine as well, my PC region was wrong so had to go into control panel and find then change it. I also had to ensure that all microsoft accounts had the same sign in.

I am encountering the same issue. Trying to buy and download the piper Seminole, I have literally spent hours googleing and trying different suggestions with no success. Did all the step by steps added a whole new payment method in the microsoft store everything I could think of but still I get the purchase failed msg… can anyone help?