Massive CPU mistake?

firstly my specs

i9 10900x 4.7ghz (water-cooled)
Asus x299 tuf mark 2 (3105 bios)
Asus RTX 2080 ti OC (water-cooled)
32gb hyperx 3200
970 Evo m.2 1tb (games)
970 Evo plus m.2 512gb (windows)
running display of 3840x1080

my problem is limited by main thread with fps of 5 to 30 depending on plane and locations. I have HT off, i get no FPS change from low preset to ultra, even turning all the options i can AI aircraft, bloom, DOF, etc i see 2-3 FPS.

i am starting to think my choice of CPU has been a bad one…

whats everyones view ???

cheers
Gman

Cpu should be fine. Try to OC it a bit and get to stable with low avx offset. There’s a single core that will be hit a lot with msfs and it will run AVX instructions (at least some) so your offset is important as it will determine actual clock.

Terrain and object scaling as well as traffic will impact cpu a lot so consider turning those down?

I don’t think you made the wrong choice, the game is quite CPU heavy. However, it does make me feel good about my 3600x I bought for less than $200.

1 Like

No, I don’t think you’ve made the wrong choice. I have an i9 9900k, out of the box, not overclocked and I’m more than happy with my performance.

There are performance issues with the 2080ti - do a quick search on the forums.

@gman20003 Try a “reset to default” (bottom of page) on graphic display settings page. I had the same issue, magically I got 25fps back. I think there is a bug with one of the sliders. Still haven’t figured out which one it is.

unfortunately no change

i currently have all traffic off and details down to low still only 25ish FPS from jfk or heathrow, trying to find the reported problem with 2080ti but not found anything yet

@ gman20003
Welcome to the forums.

I had a similar problem when I started the Alpha. (Was getting 1-3 FPS with 1 second spikes to 40)
My problem and I believe Yours is not hardware related.

I tried everything I could:
Chkdsk on all drives, mem tests, proc and mem stress tests, EVGA precision OC scanner.
SFC /Scennow.
Latest Nvidia drivers. (clean install)
Ran DXDiag, etc.

Lastly after 7 days with no answer, I tried Windows 10 Update (even though it said up to date),
I clicked on the Check for updates button at least 4-5 times. It finally downloaded an Intel Graphics Driver update and that solved my problem. (Don’t know what that did since I use an RTX2070S card)

Give it a try.
Hope that helps.

I also have a 2080RTX TI with a i7700K at 4.5GHz board assus Maximus and 16 ram 4000.
Normally I am about 60FPS because I am limiting at 60 at medium settings, I don’t like ultra because don’t have the needed performance for a smooth flight which is what I like, so for me is better this way, than 30/40 at ultra.

@gman20003, On other thing you can try, in Windows type Graphics Settings, then at bottom you can add Flight Sim from the drop down. If you bought it from Microsoft Store, choose the “Microsoft store”, then Flight Sim. Then once its added, choose options, then High Perfomance. I guess this changes the program to run faster and gives it priority.

What monitor refresh are you running?

I saw something about enabling hyperthreading for this issue on higher end pc. I have no practical experience to share however.

currently 144hz but tried 60hz too

HT on or off makes no difference :frowning:

Have you checked that you actually use the output from the GTX2080 and not the build-in GPU of your CPU?

It is two different connectors - the build in one is typically located close to a lot of USB ports - the GTX2080 one is surrounded by HDMI and Display ports.

Sorry if stating the obvious but I have seen soooo many people using the wrong port having a nice Gefore sitting doing nothing due to user using the wrong connector :slight_smile:

BR

C

if only it was that simple… i am connected to the card and not the built in.

Unless you use your inboard graphics I would disable this in Device Manager.

Another thing in nVidia settings make sure you select Power Settings Maximum Performance.
All other settings leave it default.

Ok that is very strange - I am on an old I7-8700K@5Ghz , GTX1080, 32GB ram and have no issues - 30+ fps in New York on Ultra setting with lots of clouds.

Rest assured that your PC components and CPU are absolutely fine - the problem must be based in some sort of bug. Hope you get it sorted - i am out of ideas on what could be wrong though :frowning:

All the best.

C

  • Only use the built-in fps counter for better comparibility here.
  • Do not use 3rd party programs that use simConnet while benchmarking.
  • Turn of name plates for multiplayer aircrafts.
  • Apply the glascockpit refresh tweak for the baseinstruments.js

If nothing helps,
turn off volumetric clouds or get an AMD Ryzen APU :wink:

Very strange:

Although my pc specs are good 3900x w/32GB 3000 and 4’th gen NVME I’m only running a 1070ti and I’m getting average around 45 fps but it can go as low as 30 or as high as 60 at times usually floats between 43 and 48. It does stutter once in a while when looking around very fast with trackIR even though my frame rates still show 40+

I’m running 4k resolution with all settings on HIGH and the slider at 50 for scale down.