Massive FPS drop because of SU9

Cpu @ 20% is meaningless as at least one core will be maxed out at 100% and that is what limits your performance. All games have mainthread limitations but some are better optimised than others, particularly those with DX12 which although harder to program is more flexible when done right.

I’m back seems the stutters continue but maybe you can see whats wrong?


The initial SU10 beta build seemed to solve the problem for me as well, but with the next build I might be seeing some worse performance again (unsure). But we shall not speak of performance issues in Microsoft Flight Simulator. Just put graphics settings on potato mode and be done with it lol.

1 Like

Incredible as it sounds (maybe it’s just a placebo), turning off the VFR map from the toolbar seems to improve performance.
Just like an old forum post indicated.

I had activated it again convinced that this problem had already been solved. But it seems not yet.

Just had a strange situation at ZWSH somewhere in the nowhere.

When switching to interior camera in the cockpit I got fine 32 fps.

When switching to external camera at the same view and same direction, it drops to 16 fps.

1 Like

Ant, the problem for you is that most other people are not experiencing what you describe.
There is clearly a bottleneck somewhere in your system that isn’t present in many other peoples’ rigs. It could be:
~ your PC’s virtual memory – must be on main NVMe SSD and unconstrained in size;
~ your network connection (v important for the custom scenery to be loaded smoothly in realtime)
~ your main CPU core temperatures!
~ your rolling cache
~ your off-screen scenery caching (keep it on low or medium for fastest frame-rates)
~ your main RAM speed
… the list goes on and on…

I also had huge issues with FPS in SU9. I am fully aware of all the steps needed to try and eliminate it, tried everything but nothing worked.

SU10b actually has solved it for me. (Running in DX12 and very smooth now).

However, at no point did I call for someone to be fired because of it. :slight_smile:

2 Likes

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

I wish i could have said what i really felt. I’ve had enough of trying tips and tricks and multiple setups. I’ve just had to reinstall because im tired of messing with it.

Im not crossing my fingers over SU10 though, judging by peoples comments.

Ive been through these things over and over.

Bottom line is i shouldnt HAVE to do that every update, its ridiculous. You cant be invested in something that month to month throws at you all manner of inconsistencies.

I am really regretting the amount of money ive thrown at this now. I’ve gone from super enthusiasm to feeling like if I met Jorg on the street I’d give him a piece of my mind!

Most flights aren’t an issue. They usually last less than 3 hours. The sim typically runs fine except for a #CTD occasionally.

I’m not sure if it’s related, but the problem is noticeable when changing camera views after such a long flight. The sim recovers but then it occurs again if I change cameras once more.

I decided to fly across the US. I started on the east coast of the USA and flew to KBUR California. The problem is really bad when looking out the side of the aircraft at slow speeds (on final approach). The plane may become unrecoverable and lose control. I’ll change the camera view, the plane will begin rocking causing the camera to move even more, which causes more rocking… and so on, and so on…

It also happened a few times when doing two consecutive flights back to back, each lasting about 2+ hours.

#PC
Premium deluxe #Steam
#FBW A320
The PC is up to date.

Here’s a few minutes of my 5+ hour flight to KBUR during decent and final approach.

1 Like

Incredibly frustrating, I bet.

Did you try opening and then closing the VFR map?

hi all suddenly start weird things couple days ago , after 30 min start fast and massive fps drop from 60 to 5 even maximum lowest settings :frowning: unplayable now don’t know what to do.

1 Like

Tried changing the Offscreen terrain pre-caching setting? Setting it to low/mid solved the problems for me

Thank you :slight_smile: i will try that solution

1 Like

yup it helped me , i can fly now ty very much :slight_smile:

1 Like

I tried but no luck. I’ll try what Whackydudgerman states about pre-cach settings.

1 Like

weird again fps start dropping goes to 5 after 20-30 min flying, and i didn’t change settings, very odd, there must be memory leak or something or some kind of uncombatiple hardware who knows…

2 Likes

The sim is currently driving plenty of people crazy…

1 Like