Massive FPS drop because of SU9

:smiley: yup soon coming SU10 and i did not got SU9 settings to finished :slight_smile:

Yep, same for me for issue #2, even worse. Only way to get is smooth (running a ryzen 5950x and 3090 and 64gb ram) is to lower TLOD waaay down - anything under 70 seems to start improving the situation, but worsening the picture. RdrThread goes up to 200-300+ ms during these panning stutters. I have done everything (!) i found as suggestions, to no avail. gotta fly with LOW TLOD for now, seems to be only thing that works.
These performance issues should be top priority for Asobo to fix. :frowning:

yep, that works. But i wouldn’t call it a fix :slight_smile: you are lowering the level of detail, getting a worse picture.
While, in my case at least both CPU and GPU are heavily underutilized. very apparent this is a game optimization issue that should be fixed.

No, i have uninstalled everything, made a clean install, made sure the community folder is empty, started the game in vanilla a320 and my usual airport and noticed no change. at all.

1 Like

Only got 8 fps using 3080… Ridiculous!


Try not pushing your vram clock so high

1 Like

you can check the existing hints for “limited by mainthread”…

And : we have a user report that exactly that tool you use for “tweaking and monitoring” ( Asus GPU Tweak ) caused for him the performance issue.

check youre settings…
I run 25/30fps with this card in VR
bring either resolution or lod done.
runs like a charm here.
something is wrong on your side it seems

Thanks everyone who help for troubleshoot.
Actually, that kind of situation is happened under some of the condition.
Even I just fly the same route with same setting and configuration again, I may got around 30 fps.

If the situation happened, the fps will significantly drop from 30 to 8-10 after takeoff. Even I try to reboot the pc and re-start the same route from beginning, it did not help.
Therefore, I suspect that may related to the live weather or live traffic. Under some of condition will trigger the bug which will cause massive fps drop.

If it helps, I’ve started getting a similar issue as you @Marco2696

I can be in the sim for about 2 hours, including startup, FMC programming etc, then in the CRZ, everything is nice and smooth and then suddenly the FPS will tank right down to single digits. It can be the same place I have already flown over, which was smooth previously (same flight).

If I descend below FL290 it smooths out again, its bizarre.

HW is: Ryzen 9 5950X 64GB RAM NVMe Asus ROG Strix 3090 OC

The crazy thing is, when the FPS tanks, my GPU Clock Mhz drops by about half, during this time I can actually start up CyberPunk on max detail and it plays smooth, with MSFS tanking in the background.

Very odd.

EDIT: I am going to play around with live traffic / community plugins and see if its related in anyway. Not had this issue before.

I was getting terrible fps on pc. Everything was tanking and was limited by main thread. After a while even lowering settings to low end or medium did very little to help the situation, it’s as if the settings are corrupted. What I did was repair the program in settings, and then loaded it up in safe mode.

I then created a quick flight, set everything to medium in my settings, let that finish and moved back to the menu before quitting out of the program.

I then did the same thing but ran it in normal mode, with no addons in community. Quit back out and relaunched.

I then set everything to ultra, vsync on and 30 fps cap at a troublesome airport. And then I made slight adjustments to some of the settings. I now have a rock solid fps on mostly ultra and dev mode is showing my gpu is being limited rather than main thread.

I then added back in my addons in community.

I use addon linker on a separate drive and orbx central on a separate drive.

I’m enjoying MSFS again. The only issues I now get are usually server side and they odd bad payware.

I have uninstalled the ASUS GPU Tweak. Seem not much help.
Got 11 fps after takeoff.
Decreased to < 10 fps after reach FL380.

HW: Ryzen 9 5950X - 64GB RAM - ASUS TUF RTX3080 10G

was at least a try :slight_smile:

Because we can see in your screenshot that you are limited by mainthread, I have only the common points in mind:

  • reduce LOD to <200
  • check whether photogrammetry cause that for you ( but it’s usually a ‘on ground’ thing )

note: your topic seems merged, may be you can re-check older hints in this topic here

Is High Precision Event Timer (HPET) enabled? Is it disabled?

We have verified in the past that if HPET is enabled on Ryzen series, the FPS may be extremely worse on MSFS.
Disabling it improved the situation.

Open a command prompt as administrator
bcdedit /enum

Since it is enabled, disable it.
bcdedit /deletevalue useplatformclock
and reboot to disable

useplatformclock->No or there is no item

The LOD already set to 100 before.
I have change some graphics settings and switch back to dx11 but seem still useless.
Even I got more than 60 fps on ground, the fps will significantly drop to single number after take off.
Really not sure what happen.

Thanks for the suggestion.
I have try that before which not much help also.
Also, there are some post that mentioned disable HPET may also have more harm than good.

1 Like

I am sorry that I was not helpful.

Regarding the phenomenon of FPS fluctuations caused by HPET, is it still ongoing? I had a question about this, and that is why I dared to cause the trouble as of SU10Beta 1.27.09 (4 weeks ago).
As a result of the experiment, we were able to reproduce a 60FPS environment that became 10FPS with HPET=ON.
When I changed it to OFF, it returned to normal.

Seem I found the reason of fps drop. Currently, I got around 30 fps after takeoff. A huge different than before.
Seem the program will have some issue for non-English OS.
The solution is to enable the Unicode encode which is one of the bate function from windows.

I will also file a ticket to Asobo since that should be a compatible issue.


ah… the creation of Flightplan for none english users issue… The guess about the “why” is mentioned one post above the one you linked ( its possible more like a windows problem , but who knows ).

Beside of creation of a ticket, we have also a Bug where you can Vote:


This may seem very trivial, but if you’re an AMD Ryzen user… Make sure you have the latest chipset software installed for your platform. AMD updates this software every few months so it’s worth keeping an eye out for.

(P.S. Motherboard manufactures don’t always have the most recent version, so best to download this directly from AMD)

Uninstall old version >>> Restart PC >>> Install new version >>> Restart PC.

This should apply to Intel user’s as well…

I have this problem too ! i dont know for what and if i change the view for the cockpit view in Montpellier airport (LFMT) i have 15 FPS and if i change to external view i have 30 just ■■■… that has no sence…

I run with the photogrammetry on and all citie update (i have try to unninstal and yes i have a better performance but i lost photogrametry for Paris or other citie…) and i have a GTX 1080 Gaming X, 16 Gb of RAM, I7 7700k and i run in 1080p, if you can test in the same airport (LFMT) let me a feedback just for know if it is this just me or not (and sorry for my english in advance im french…)