Massive, game breaking stutters after some minutes of flying

Hello everyone

Since some weeks, I often (not always, but most of the time) get massive stutters after flying 15, 20 minutes.
Sometimes it happens earlier, sometimes much later.
What happens is, while flying is smooth and fine, all of a sudded, the FPS basically drops to 1.
Yes: 1 FPS.
The sim basically breaks, only updating 1 frame a second or so, I can’t even exit it anymore, the buttons to access the menue do not show up anymore. I can still more the camera (very laggy of course), but basically all I can do is brute-force exit the sim by closing it in the task manager.

Super frustrating. Especially when you fly, getting closer to an airport (just an example, it havens anywhere) prepare for landing and then… the sim breaks and stutters with 1 FPS.

I have the same system since many months, my computer is the same, so are the controls.
This problem all of a sudded started, probably with one of the two last big updates.

Any ideas? :confused:
Thanks a lot

(P.S. I mainly fly in VR)

Is this happening in VR?

Well for what it’s worth… I’ve experienced the same… for me the trick was to turn off Live Traffic…

The behavior you describe could be caused by thermal throttling if for whatever reason things are getting hot. Have you checked temperatures?

If temperatures are running hot (more than 80-90C) this could be why and it can be provoked in summer months. Causes could just be room temperature, dust in heat sinks or clogging fan filters/exhausts, failing fans, dried out heat sink compound, etc.

Yes it happens in VR…
Does that help?

(Not sure if it also happens in “non-VR” flying… I rarely do that…)

Than this should be posted in the VR bug section. I moved it.

Ok… eventhough it might not be a “VR only” issue

Can’t be sure if this is what you’re experiencing or not, but there has been a bug lurking for quite some time that will suddenly and unaccountably cut frames right down (usually to 8-10 fps) after an apparently random period of flying. This is the ‘Limited by CoherentGTDraw’ issue. It seems to have been mostly fixed, but still happens form time to time. Likely solutions to this…

(1) Close VFR map and then remove from the toolbar.

(2) If that didn’t help, close the ATC window and remove from the toolbar.

(3) If that didn’t help, remove everything else you can from the toolbar (will only leave ‘options’ and ‘active pause’).

(4) If that didn’t help … well then I’m out of ideas.

(5) If it worked but you need one of those toolbar items back … you can reinstate it, which usually works okay and if not, repeat from step 1…

I fly exclusively in VR since - well, since I got VR and I’ve certainly found this issue, but don’t think it’s a VR specific problem.

Hmm well actually it’s pretty cool in my flat. Normal room temperatures.
I also did not notice any peak in CPU or GPU temperatures.

Hmmmm interessting.
So does that mean you don’t use ATC or VFR map at all then?

In the two or three recent times I’ve had this problem, removing them from the toolbar fixes the performance, and then I’ve been able to add them back without any further trouble. It’s very weird.

… And at least as far as this one goes, it’s not temperature. I’m liquid cooled, and so is my computer (CPU & GPU) :grinning:

Do you mean the toolbar across the top of the screen? That is an odd bit because some have noticed performance gains when they disable menu items in that top tool bar.

Yeah exactly. This issue was a very specific problem that goes way back to launch (see this thread) It was largely fixed in SU3 (I think), but still seems to turn up once in a while.

Now, might have nothing to do with the OP’s issue, but it’s well worth being aware of … if you happen to encounter it, it seems to be easily fixed by taking stuff off of the toolbar (as you say, the pop-up toolbar at the top of the screen).

1 Like

My problem is: When this issue happens, I can’t access any menue or the toolbar at all. The sim still runs at 1 FPS, I can move the cam… but that’s it. Nothing else works. Can’t open the menues, can’t access the toolbar.

So many weird interdependencies and issues that don’t make much sense. Makes me wonder what that code base looks like.

I tried your trick again. It worked.
After roughly 30 minutes of flying, the 1 FPS stutter begun.
I was barely able to move the mouse, but very slowly I was able to remove ATC and VFR-map from the toolbar. It took a few minutes because the performance was so bad, even hovering over the toolbar.
That fixed the problem. As soon as they were removed, the performance was back!

Unbelievable ^^
How does Asobo always manage to seek such annyoing bugs into the sim?

Has this been reported to Zendesk.
I know it’s a black hole… but has it?

1 Like

I believe it has but don’t know for certain. Others discovered this and posted a month or two ago and then I at least forgot about it.

Taking things out of that menu isn’t sticky, though. FS2020 repopulates the menu bar every time you start the sim. If there’s a way to stop that I don’t know it.

Glad this helped. It is certainly much less often now than it was, if not quite actually fixed!

I think it’s likely that the optimization that is apparently coming with SU5 at the end of the month will take care of it. Perhaps I’m just an eternal optimist :sweat_smile:

If it would be actually fixed, I probably would not have this issue in most of my flights :wink:

Maybe they fix it with SU5… but who knows. They might just ignore it like many other bugs that exist since many months.

1 Like