Massive stutter or Memory Leak with latest update

I had the same issue flying into KATL this afternoon. Really bad memory leak and complete pauses and stutter. I installed the latest NVDIA driver and it improved a lot, but I still have some small runway tears.

I have read though that if it’s memory leak problems it only happens after a long flight. I was on my second leg when going to KATL so maybe it is a time running issue.

I had this problem yesterday.

Leg 1 flew FBW A32X FZAA-DGAA

closed flight on landing. Did not exit game. built new flight from Main Menu world map

Leg 2 flew FBW A32X (different livery) KCLT-KBOS

problems noticed on descent as game became so unplayably slow that the AP disengaged continuously due to overcorrection and wild oscillation (due to stutter).

Win 10 Version 21H1 (OS Build 19041.vb_release.191206-1406)
Core i7-10870H
RTX 3080
32 GB RAM

1 Like

this seems to confirm my experience.

I know this might seem kinda out there but try turning off Real-Time Online under General > Aircraft Traffic Type settings if you have it on. I had the same problems as you and it fixed it by turning it off. Let me know if that worked. Asobos last update inserted more AI and thus causing me problems. Any others out there with the same issues?

Mines is already off by default since I use Vatsim so needs to be turned off for that

I really hope the 27th fixes this memory bug. I don’t think I’m going to make it to Winnipeg tonight, committed memory keeps increasing, terrain detail already set to 10. I paused the sim for half an hour to see if it would recover, memory use went up another 6GB while paused…


I have multiplayer on and live weather, no live traffic

Regular committed ram is 16GB on my system (high settings) CTD is imminent once it goes over 50GB :frowning: Does saving mid flight work yet? (IFR flight)

I made it, horrible choppy landing. I didn’t make it to the gates as ATC broke down, no option to acknowledge last transmission and no instructions to get to the gate, nor any taxi ribbon. I turned the engine off and left it there.

Maybe it is time to start looking at getting 32GB if not 64GB cause even I atm use full 32GB of RAM atm when doing MSFS

may be you can also mention the installed mods, so users are aware.

The only thing I have in my community folder is an update to Brantford Airport. It wasn’t in range on that flight. It’s vanilla install, premium deluxe with all world updates, no mods.

The frustrating part is that it seems to be completely random. I did another flight after from Shanghai to Tokyo. Same conditions, committed memory stayed at/under 16 GB all flight. The weather was even more rough than on the bugged flight. After another 3 hour flight, perfectly smooth approach over Tokyo.

There is one thing that might explain it. On the bugged flight I took the drone out to check out another player flying in my vicinity. (He had his legs sticking out the bottom of his Cessna). Perhaps using the drone far away from the plane triggers this bug? Once I noticed memory was up to 30GB in use I didn’t touch the drone anymore and set terrain detail to 10 (normally 100) Memory kept climbing anyway.

thanks for info… hmmm…would be strange if an airport mod will cause that :-/
I only know about issues with slew/time acceleration. But may be you find another cause in the drone. At least each hint can help :slight_smile:

Maybe the drone triggers the same problem as it’s not that different from slew and fast sim rate, using the drone at maximum translation speed. The other player was far enough away that it triggered a complete redraw when returning to my plane.

Another difference was, the ill-fated flight was after a couple shorter flights in a different plane. The flight without issues was the first after a fresh start of the sim.