[May 9, 2023] Expert Series I: ATR 42-600 / 72-600 Update 1.0.8

Use taxi lights. (;

1 Like

I see a lot of posts here regarding throttle setting issues specially with honeycomb Bravo and Xbox gamepad. Now I don’t own the Bravo, so cannot test. But I do own an xbox controller and did a few tests with default throttle bindings in Xbox controller i.e A key for increase throttle and B key for decrease throttle. Trying to control the throttle with just two keys instead of a axis had some “interesting” effect. But regardless, here’s my findings, and just to be clear, i am trying to be helpful and not trying to invalidate anyone’s claim that it’s not working for them, everyone’s setup is different and they may be hitting issues that I am not.

  • For me throttle works as expected with the Xbox gamepad. This includes power output, engine display indication, throttle lever animation, throttle lever and power indication in external view.

  • Some are reporting that throttles cannot be pulled back completely to the idle in flight, i have a question here, which position are you trying to drag the throttle lever to? In flight it’s only supposed to come till the end of the green band marking in the throttle quadrant. That’s where flight idle is. It’s gated by a idle gate which is operated automatically after take off and touchdown. In ground you can drag it down completely, even till reverse. You can do that in flight too, but you are not supposed to. To do it in flight, you have to unlock the idle gate manually.

  • Recorded a video too, but it’s recorded in phone camera and trying to use the gamepad in one hand and the camera in the other hand while trying to fly is let’s just say, had some spotty outcome. Still, the video is the proof thats supposed to be in the pudding. Not sure where to upload, don’t really have a youtube account. If someone can specify any anonymous video uploading service, i can use that.

  • Here are my throttle calibration setup and throttle related bindings.


  • Edit: Turns out I do have a YouTube account I forgot about. Here’s a direct link to the video that I recorded.

4 Likes

Haha whatever,

Yea, same thing for me, GS behavior is disappointing. This really sucks compared to many smaller issues.

1 Like

Thats normal cruise speed under indicated air speed. Atr72 wont go past 270knots TAS.

1 Like

Looks like co-pilot MCDU is essentially still useless, can’t select anything except a few of the initial INIT pages then it gets stuck because FPLN, VNAV, etc still don’t work (yes I updated).

Yes, i noticed that too… having a properly working second mcdu really helps having more data available at a glance…

It doesn’t matter where in the Taxi list is this TO config check. You read that checklist when taxiing, with gust lock on, so pressing the TO config check button shouldn’t check the gust lock position (as was the case before the patch). You disengage the gust lock at a runway holding point or just before entering a runway and after that you read the Before takeoff checklist where you check that the gust lock is off for take-off. FCOM doesn’t suggest that you disengage the gust lock during taxi after performing the TO config check and before reading the Taxi checklist. I don’t know why we’re still discussing this when it was confirmed by two real ATR pilots that it’s wrong now. I’m going to post it in the bugs section.

EDIT: I don’t need to make a post in the bugs section. Already done by @ChannexJames , thanks :wink: Votes would be appreciated:

ATR 42/72 Take-off config warning - Bug Reports / Aircraft & Systems - Microsoft Flight Simulator Forums

3 Likes

Good progress for a 1 week patch

Tried it, lots of good improvements to the lnav vnav etc and holds worked (in a somewhat crude fashion).

Throttle control is better IMHO, you can actually control speed without hopping jn and out of flight idle which I like. They did break the way my ■■■■■■ logitech tq worked with reverse thrust though. You can’t just bind the reverse button detents to decrease thrust any more, which used to just put the levers into full reverse when you moved into the detent. I’m a bit sad about that since using the reverse toggle is fiddly as hell.

Anyone got any ideas how to restore that behaviour at all?

2 Likes

Do you use SPAD? I have some great solutions for all my aircraft, including pmdg 737 which is infamous for binding a proper reverse axis… though i cannot take the credit for inventinting the ideas, those are inspired from the spad tutorial videos in their discord.

It may work with FSUIPC and Axis and Ohs and Mobiflight too if they support similar features, but i don’t know if they do or not.

1 Like

Sorry no spad, though I’ve got hopes I can do something with the bundled logitech software.

I’m thinking recording a macro to toggle reverse on press , repeat the global increase throttle f key while pressed, and then on release toggle throttle again and trigger the throttle cut f key. I’d lose being able to set the throttles into reverse independently but I can’t think if a reason why anyone sane would want to do that…

Can’t do something similar in sim due to the toggle reverse function not being able to be mapped on release and on press to the same button.

I have done it for twin otter sea planes to taxi and turn quickly, not sure if it’s a approved method or not.

Just ramping one engine up a little and sitting on a toe brake works well enough for this one to get ridiculously tight turns

Yeah, not needed in ATR.

That’s a bit annoying, but since we don’t have failures simulated, it’s not that vital.

Ground stance seem to be correct now when fully loaded. Also floating behavior is no longer around.

However with this update. It seems you cant flare at 20feet or lower anymore. It will result in a very hard landing. Cant land the plane with less than 2 degree pitch like the real aircraft. Current workaround is to flare way early but again flaring the aircraft way before 30feet isnt accurate either or doing nearly 5 degree worth of flaring which is not what we should be doing. Delaying the thrust to idle doesnt seem to help either.

1 Like

You didn’t try dragging the levers all the way forward and you didn’t switch to external view when levers were visually all the way forward to see if it says levers 73%

I did all those things, just not in the video… but I’ll check again

Ok, correction:

Dragging levers all the way forward works, with mouse and with gamepad.

But you are right about the engine throttle position indicator in external view, it does not go past 73%, but that indication has no effect on the flight and power output of the engines. The power output or torque in this case is correctly inditlcted in the external view as well.

Definitely, I’d understand for the price if it’s not supposed to work, but then I’d expect it to just sit there and not react to any button pushes at all. However, LSK’s, number keys, letter keys all work and you can even do some of the basic INIT stuff, but then when you get to the point where “return” no longer sends you back to that first INIT menu with weight, flight plan, POS init, etc., you’re stuck looking at whatever page you ended up on. It’s just the other important “category” buttons like the VNAV, FPLN, etc that seem to not do anything. I did open a bug for it last week, just needs more upvotes ATR 72-600 copilot MCDU buttons do not work - Bug Reports / Aircraft & Systems - Microsoft Flight Simulator Forums

1 Like