Megeve airport (LFHM) cause CTD for me

Every time I land at Megeve airport (LFHM) my system crashes to desktop. I first found this trying to finish the France bushtrip, but on further investigation, I have found it happens anytime with multiple different types of aircraft.
I can depart from Megeve ok, but not land. It normally crashes after I have touched down and before I have stopped.
I have renamed my community folder and created a new empty one and I am not running in developer mode.

Would any other fellow pilots be able to confirm if they can land ok and come to a fullstop at Megeve without a CTD. I don’t know if it’s a bug or something (I have no idea what) at my end.

UPDATE: I have also now had a couple of CTD’s when departing Megeve. It doesn’t happen everytime like landing. I have landed and departed at many other airports since and it only seems that Megeve is the problem.


Same here. I can’t finish the bush trip. I have tried this 4 times in the last leg of it. Disabled OC, removed Community contents. No luck.

Yeah me too.
Just out of interest: Do you have the working title avionics mod (I think it’s the G1000 NX) installed?

No,I don’t have any mods installed.
Interestingly enough, a friend can land there but he has not updated any of the content manager stuff, so no new bush trips or world updates etc.
I wonder if it got bugged by one of those?

Just noticed the content manager update for su5 and tried it. still crashing…

Nope as I said I have removed all the contents from the Community folder and everything is vanilla.

I think it is on Asobo’s end, not ours.

Can someone else try to land Megeve and share the results?


Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.

Are you using Developer Mode or made changes in it?

Brief description of the issue:
Land at Megeve airport to complete France bush trip, and CTD when the plane stops (when you’d normally get a congrats message)

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:
Do the France Bush Trip

PC specs for those who want to assist (if not entered in your profile)

Build Version # when you first started experiencing this issue:
SU5 after hotfix (never tried it before then though)

Are you on the Steam or Microsoft Store version?
MS Store

Did you submit this to Zendesk? If so, what is your ticket #?

Completed this yesterday, no Issues for me.

Same problem for me. Impossible to finish the bushtrip.
CTD when my gears touch the ground at Megeve.
Don’t test landing if it’s not the bushtrip.

No other CTD for me.

1 Like

I have raised a ticket with Zendesk about this now. Request #115452.
Now we wait.

Test free flight. Landing Megeve = CTD

I’ve tried to uninstall update world France, clear cache, reinstall => same problem

I want to ask people who has CTD issuue.

  • Did you start the France bush trip BEFORE SU5 released, and arrived Megeve AFTER the SU5 and hotfix?
  • Or did you start the bush trip from the beginning AFTER SU5 released.

Something tells me it could be related to this. But you guys say it also crashes on World map so it may not related to this as well.

As an info, I have started before SU5 and now trying to finish it now. So it crashes. Haven’t tried to land on world map though.

Maybe the sim want a complete re-install. I can’t do it RN as I am at work so if someone try that It would be great.

  1. I did some testing this morning. CTD’s when landing on Megeve. With the standard Asobo scenery AND the payware Megeve from BKangles. BUT i did the same test with the heli A135 and found the weak spot on the landingstrip. CTD’s in the beginning of RWY 15 near the windsock. All other places on this airfield no CTD’s. Sincerely…
  2. Did the same test with the Bell 47G from FlyInside. I landed everywhere, hole lenght of the RWY in both directions, two helipads, parking, etc… No CTD’s.

Thank you for your reply and for testing. I’m starting to firmly believe this is an Asobo problem with one of their more recent updates.
A ticket has been raised, so we’ll have to wait and see I’m afraid.

I have raised a ticket some time ago for a consistent CTD when lining up on the runway which means facing north after starting cold and dark from LFHM.
This does not happen when you start up and running from the runway but it happens when reaching the threshold during landing.

Correct. Could it be aircraft related? With GA ctd"s. With the heli’s A135 and Bell no ctd’s even landing on different places on the RWY facing north and south.

On a related point I find that if the game doesn’t CTD when pressing FLY it will freeze part way through the flight. The odd thing is that the freeze always seems to occur as I’m turning at the first waypoint of an IFR approach.

Thanks for some testing. So we must do full stop before getting close to windsock?

Or it doesn’t matter after touching the runway.

Soo here is the update, I can confirm windsock is the solution. I did testing with DA40 NG which is the bush trip plane. You should approach very slow and target the grass, land first on the grass and stop the plane before reach the windsock. Then there is no CTD. If you pass the windsock then no luck.

At least we have a solution now until an update.

Here is a strange one. I have managed to land 3 times, including completeing the French Bush trip!
I don’t why ,how or even if this is a fix as I belive NicoDijon did this too and it didn’t fix his problems.
The steps I did were :-
1.I went to the Content manager in the profile section and highlighted the World Update IV:France, Belgium, Netherlands & Luxembourg and clicked delete
2. I mildly panicked thinking that I would have deleted the French bustrip so I went to the main menu/activities/bushtrip menu and saw the French bushtrip had indeed gone.
3. I went back to the content manager and selected the World Update IV to re-download.
4. Whilst I waited, I decide to try one more landing at Megeve in a C152. It CTD’d in the normal way just after landing.
5. I restarted MSFS 2020 and let the World Update IV finish downloading. When it was completed, I tried another landing at Megeve in a C152 and it didn’t crash! I taxied around a bit and still no crash.
6. I went back to the bush trip menu and the French bushtrip was back, still at 94% as before the world update deletion.
7. I selected the French Bush trip and clicked continue and took off from Courchevel on the last leg and landed fine at Megeve. Bush trip complete, checked off, bush trip now shows 100% complete
8. I went back in a TBM 930 and landed again, this time very early and taxied up the runway to the parking with no issues.
No idea why this fixed it, but I’m not calling a solution quite yet. I’ll try a few more landing first.
Good luck, hope this helps someone.

UPDATE: I have sucessfully landed multiple time in the Cub. I have slowky taxied up and down the runway and stopped at various point. I have taxied onto the parking and departed multiple times with no crashes or problems. Maybe one of the later updates corrupted something in World Update IV? I’ve really no idea. I’m going to reinstate my community folder and do a bit more testing later. Let me know if this helps anyone please