Message: "Game Update Available in MS Store" But No Updates Available in Store

I can’t play the sim anymore because every time I open MSFS, I get a pop-up message that says “Game Update Available: A new mandatory update is available. Please update MSFS in the Microsoft Store before launching.” When I hit the OK button, MSFS closes automatically and I am unable to play the simulator.

I have checked the updates section in the Microsoft Store at least 2 dozen times over the past few days and MSFS doesn’t appear in the list of apps with available updates. I have tried rebooting my PC. I have tried manually hitting the Microsoft Store “Check Updates” button dozens of times and MSFS still doesn’t appear in the list App updates list.

What’s weird is that one of the 2 dozen times when I tried to open MSFS, the app actually opened normally and I didn’t get the message saying that I must do a mandatory update in the MS Store. When the sim opened to the main menu, it told me that World Updates were available in the Marketplace, so I opened the Marketplace and downloaded and installed all available updates including World Update VI and all previous World Updates that I hadn’t installed previously.

After this one time where I was able to successfully get in MSFS, I close the app and shut down my PC. But the very next time that I tried to launch MSFS, I got the same pop-up message stating that a mandatory update is available in Microsoft Store and just like before, when I checked the updates section in MS store and hit the Check Updates button multiple times, no updates appeared for MSFS.

So at this point, I cannot get into MSFS because it automatically shuts down once I get the mandatory game update available message.



Download and install xbox app

Restart PC

Launch xbox app and sign in.

Recheck for updates in microsoft store app


Can you sticky this thread to the top?


I think it more of a ‘Search is your friend, use Search’ but yeah, pinning would help allow people to ignore that also :unamused::slightly_smiling_face:


I’m having the exact same issue…

Follow TenPatrols advice, and install the XBox app from the MS Store. You don’t have to leave it running to use the sim, but it does need to be installed to get the update to MSFS.

When I had the update downloaded, I configured the app to not run at system start, and it has had no effect on MSFS.

Many thanks to TenPatrol. I had the same issue. It would’ve been nice if Asobo or Microsoft provided written instructions that included language yes this is an XBox app but it’s FOR those of us that enjoy the sim from a PC. It also took me a minute or 2 to find the download arrow in the upper right after downloading the XBox App. But it’s working again.



Another screw up from M$. lol

I cant believe I had to search this in order to update, ■■■ where they thinking?

I am still lost, How do I recheck for updates and install them? I still cannot get the sim to work. I left on a business trip on Tuesday and it has not been able to let me access since I got home yesterday. I cannot get past the Mandatory Update message.

This is crazy. I am not the most tech-savy person but I am not a newbie either and there should be clear instructions for everyone from Microsoft.

I just came across this issue myself. A simple dialog box stating that the XBox app needs to be installed to allow downloads, and a link to the install is all it would take.

I shouldn’t have to go searching for a solution. Come on MS, do a better job.

1 Like

I installed the Xbox app on my computer a few days ago. This morning the option to install the mandatory update appeared as i was starting FS2020. No need to go to the Microsoft store. The installation went smoothly.

Just had same problem on pc, just installed the xbox app. Restarted pc then opened xbox app and the update started automatically. Ive set the xbox app to run on start up now to. So shouldnt have this problem in the future

Thanks man, appreciate it so much, you saved me 4 hours of life by reinstalling the game :hugs:


You’re very welcome :slight_smile:

1 Like

Thanks worked for me but I agree with others. Why do Microsoft make it so difficult. We pay a lot of money and the advice given is extremely poor. Always have to search to fix issues. Should be standard Duty of Care for purchasers to be advised correctly.
Shame on Microsoft with their Billions

1 Like

Known issue on the microsoft store app that is affecting many games including msfs That why for now we need xbox app (in some cases)

Wow! That was a waste of 2 hours! I hadn’t been into the sim (I refuse to call it a game as I use this as a real world pilot tool) had to research how to get the Xbox app, finally get the update and now while I am getting what I hope is the final 3.19GB download i figured I would vent! Why such a challenge! It would be more tolerable if the program was actually usual either as a flight sim and not a game.
I guess this is why most of my time going forward will be with X-plane.

This need to be fixed. I have xbox app installed and still no update. This is total stupidity. if it needs to be updated it can do it throught the game.

For anyone still having issues with this, I’ve found the solution.

Make sure to update MSFS 2020 and Xbox App in the Microsoft Store.

Then, Open the Xbox app, and click on the top left icon (looks like books) for “My Collection”
In the “My Collection” Section, the top right will be an icon that says “Manage Installs”
Click on that and you will have the ability to update your game library.

As you can see from up photo, I have automatic updates selected but they did not automatically update.
It seems that you have to update this game in the Microsoft store AND the xbox app in order for it to allow you to play.


Worked for me! Thank you!!!