Microsoft Disc error

This game is easily one of the WORST I have ever played, and thats even when you actually get into it,
On top of the constant errors I get when I’m actually in the game such as no bandwith, no live weather, no ai traffic, no multiplayer, no marketplace, no terrain loading, constant error messages of servers not connecting etc…i have a new one. When i load up the game it tells me to insert a disc. I pay for the game digitally on the game pass. And yes i have the digital ownership installed.

My account is signed in on the xbox app, the ms store and console companion, all synced up. I have tried to sign out and back in again, i have tried port forwarding, i have tried disabling firewall, i have tried using a vpn, i have tried uninstalling and reinstalling, i have tried signing in as an admin, i have tried calling microsoft who couldnt assist, i have tried disabling ipv6, i have tried ethernet connection, i have tried resetting the apps, i have tried toggling the ingame connectio settings, i have tried resetting the modem, i have tried static ip addresses, i have tried zendesk troubleshooting, i have tried opening the game from different places, i have made sure my xbox pass subscription is still live…

NOTHING WORKS. What do I have to do just to get into the game???

Hello!

Your topic has been moved into the General Discussion & Community Support category.

The Bug Reporting category is for posting suspected or confirmed bugs that other users are able to reproduce without duplicating an existing bug topic. Using the template is required in order to provide valuable information, feedback, and replication steps to our test team.

If you are not sure if your issue is a bug or need further input from the community, please use the General Discussion & Community Support category. If the community can replicate your issue, first search the Bug Reporting category to see if there’s an existing topic. If it already exists, contribute to that report. Duplicate bug reports will be closed.

If you believe it is a new report, then create a new bug topic using the provided topic template.

I was searching for the relevant Zendesk article for this disc error message, which contains quite a few troubleshooting tips and found it here:
https://flightsimulator.zendesk.com/hc/en-us/articles/360015985699--Please-insert-the-Microsoft-Flight-Simulator-Game-Disc-Error-message

It is worth working through each step in turn and see if any of them resolve the issue.

If nothing works then I would recommend filing a ticket for official support here, selecting “I need technical support (Loading issues, Crash, Performance, etc…)” from the drop down list.

I hope you get the issue resolved soon!

Just out of interest, which version of the sim you are you running? You can find this a couple of ways.

If the sim launches, click on your name at the top right. The version number should be shown.
You can press ALT+ENTER to put it in to windowed mode, even when launching, and the version number will be shown in the title bar.

You can also get it from the XBox app, which is the app you should be using, not the XBox Console Companion.

It has another way to get the version. Right click on its tile on the left, and select “Manage”:

image

Then click on “Files”. The version number should be shown here:

image

Hi, thanks for your reply.
It says version 1.32.7.0

Okay, so that’s not the reason why you can’t access the Marketplace.

I would try the steps outlined by Tamalien in that case. It could be a Gaming Services issue.

You are getting that message because it doesn’t think you own the game. If you open the MS Store, then open the Library at the bottom left, you should see two items:

image