Milviz Pilatus PC-6 Porter

Yeah nothing I do seems to be simple :smiley:

So this just gives it 100% reverse thrust?

I get your idea though and will definitely try this tonight! Thanks!

Still I think that detent switch on my Logi TQ is not working right - I can see when I try to assign it that it’s flickering on and off if I move the lever (well, not move but put force on it) left or right whilst it’s down as far as it goes, so it’s erratic whether it detects it or not. That will really confuse it if it’s insta-switching between full reverse and zero throttle quickly.

It certainly feels like there is something to do with the wheel contact. You can’t “pre-prepare” and put it in reverse but with low power before you’re down. I think! I found a way that kind of works for me but it’s clumsy and I definitely will they and improve this tonight thanks to the advice from Alpine :wink:

But better than a toggle, where each flicker will send a command. Wheras with ‘Hold’ once commanded, it will stay that way until it gets the ‘cut’ command, which you could assign to the throttle idle axis value (if using SPAD).

I used to use the toggle command as well and it gave me no end of bother until I tried this set up (credit to FlightsimHanger)

And yes, unless you have a TQ with an axis below the detent, you can only ever get 100% reverse thrust unless using SPAD. But I figure, when I want reverse, I want all of it.

You, of course, should never engage reverse thrust in the air! But yeah, on mega short strips, I would engage reverse in the Kodiak about a second before the wheels touch. Just to eek a little extra stopping distance.

So the warthog has an axis below the detent? That is definitely mappable in SPAD. But not sure about MSFS.

Well, yes. There is a small range that you can activate by lifting the throttle up and back. This would be perfect for reverse thrust and propeller feathering, but alas, according to my knowledge msfs does not see this input. DCS does btw.

My point is, with that (I think) failing switch, this method is also not going to behave well. I might have to open the unit up and see if I can fix (some contact spray or tightening of screw - not sure how it’s held in!) or even replace the switch with something better made.

It’s the second brand new unit I have had that was OK for a few days then just went bad. Haven’t bothered returning for a 3rd and would be too late now from Amazon.

Yeah I just meant a moment before touchdown when I am already gliding in and don’t need power.

I figured that’s what you meant, but it might explain why there might be a condition set in the aircraft model to prevent it. I’ll test shortly.

Also, I always found the toggle command very hit and miss when I used to use that on my old Logitec TQ and concluded it was more to do with MSFS than the device as the button worked fine for everything else. So you might have a double-whammy there if the button contact is bad. And yeah, if so then my method wont be any better really.

See this is the problem I have. Even doing the same movement sometimes doesn’t trigger it. And sometimes not touching it at all whilst the switch is “pressed” will flicker on and off 15 times a second.

Video in here

Dropbox - - Simplify your life

Weird. Just tried this setup, with hold throttle reverse thrust on press and throttle cut on release but it’s not doing anything even if I jiggle the lever like in my video or hold it in a way I can see the button is being registers currently in the control settings screen. The VC lever is not moving or flicking backwards or anything (in BS Caravan). I’m dumbfounded :slight_smile:

Is that on your Bravo?

Having some issues on Xbox Series X with the Milviz Porter. I downloaded it last night for reference. I use the Turtle Beach Velocity 1 yoke. Pre-taxi i’ll go to set my stab trim to green and sure enough at some point after that I’ll get a red TRIM alert on the G1000 and i’ll go check the trim which has been set, and this appears to be a bug, to -6.9 degrees. I cannot set it back using the trim wheel on the Velocity One nor using my controller to adjust it on the actual STAB TRIM switch.

Anyone else have this issue?

EDIT: This seems to be an issue with the AP and possibly it’s interaction with the VelocityOne yoke. The autopilot will randomly turn on which effects the pitch and trim. This also has an effect on the VS. You go into autopilot on a climb and you’re set to -3000 VS so you nose dive. The autopilot does not work with the plane and the VelocityOne yoke is what it seems to me.

OK, figured it out - bad info from me (sorry, use SPAD for all this stuff and a bit rusty).

HOLD THROTTLE REVERSE THRUST is bugged [Edit - not bugged. See below for an explanation of how it works].

The command to bind to the button is: DECREASE THROTTLE - that will take it into full reverse.

I’ve just tested in the Porter and it works fine.

1 Like

Thanks mate I’ll try that!! But I still think my buttons knackered :frowning:

And no it’s not a Bravo, it’s basic USB Logitech one (£50). Might have to find room and invest in a Bravo soon though!

I was about to say it sounds like an autopilot issue. Make sure you have no conflicts - ie more than one button bound to AUTOPILOT MASTER. I’ve also noticed some odd AP behaviour. Still investigating the causes.

If it is your button, try putting the throttle on a different axis -that way you can then use a different button and leave the bugged one for something a lot less time critical, like prop or condtion-lever.

The Bravo is well worth it. Awesome bit of kit. No regrets trading up from my Logitech stuff.

No, i thought about that as well. It’s just a single AP toggle. No issues with this in any other plane. It’s a bug for sure in my opinion. Below is a video of it doing so. Basically if you trigger NAV or AP mode it immediately puts you in full nose down pitch and you cannot readjust it until you get out of NAV or AP mode. Unfortunately this means it is unflyable in AP mode until it’s patched. Hopefully the devs see this! I’ve had some other strange AP behavior in flight as well. Mostly pitch being adjusted and AP going on and off at random. Note in the video below that I am not making any adjustments whatsoever to trim. This is all being done by this bug.


So what I can see is normal behaviour:

When you activate the Autopilot, it takes control of the trim servos - you cannot readjust trim manually, not without pressing and holding the AP/Trim disconnect button on the stick or turning off AP master on the KAP140.

If you turn on the AP on the ground, it will command full-nose down trim because you have a high angle-of-attack.

The solution is not to engage AP on the ground. Indeed, AP should only be engaged when in stable, trimmed, flight. It’s not a 737 where you can pop AP on 200ft off the ground!

1 Like

I would agree with you, however this happens in the air as well. If you engage AP/NAV whilst in level flight it will also nose you down as such.

Well that would not be normal behaviour for sure. Report it on the Blackbird support forums. As noted above, they have been limited in their ability to do pre-testing release on the Xbox.

I also saw you have AP mode indications on the ‘scoreboard’ on top of the G1000 PFD. I don’t get those on my PC version - I have to look at the KAP140 to see what modes are active.

1 Like