Missing update that is required to load planes

Hi,
I have the Premium Deluxe and the SR22 is not available. In the content manager it shows no version number and is looking for “fs-base-propdefs” - required version 0.1.2

How do I get that version? Or force a new update? There are a few planes missing and I am figuring that this is the problem.
Thanks

Seeing a higher game version requirement

also 1.10.10

Hi same on my system after a complete new setup, as I had CTDs every minute and unable to start any flight. So now they ask for 1.10.10 update, where can I download it???

as far as we know the next patch will release tuesday next week. Don’t worry about it. If it’s ready, it will download automatically.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.