Mobile Companion App v1.9 released Aug/30/2021 - updated FBW A32NX v0.6.3 and dev controls and added load KMLs

I’m excited to announce the release of version 1.5 of MSFS Mobile Companion App. This release adds a dedicated landscape mode (split-screen for map and controls) and the option to load your flight plan.

List of new features in v1.5:

  • Added landscape mode (split-screen for map and controls).
  • Added option to load your current flight plan.
  • Switched active and stand-by NAV/COM displays.

A note on the load flight plan feature: Currently, only waypoints of the flight plan are shown on the map. Arrival and departure procedures like DME arcs, glideslope intercepts, etc. are not supported

Where can I get it? You can download the MSFS Mobile Companion App for free on GitHub or flightsim.to. It’s free. No ads, no in-app purchases, nothing.

Important notice for new users: Don’t install the app on your mobile device! Download and run it on your PC. This creates a local web server to which you connect via an IP address. You can connect to the app from your Android, iOS, Windows or Linux devices. To find out more about this app, visit the GitHub project page.

Enjoy the app and let me know your feedback!

1 Like

Thanks for this amazing app! I’m close to converting to your app full time. I’m currently using Liam’s vfrmap with my own changes to leverage Google maps (with my own API key).

One question: when I load my flight plan, I just see a direct hashed line straight to my final destination. I don’t see the mapped out solid pink line as you shared. What did I do wrong?

Also, if I may ask for some features (pretty please):

  1. Any possibility to add a teleport function? Like click a point on the map, a pop up opens to set altitude, etc and then teleport.

  2. And any possibility to add support for other maps where the user has their own API keys? Like Google maps. Like a command line argument or config file to set the API key?

Thanks again!

Thanks for the feedback! See my comments to your questions below:

Flight plan not working properly
This is because the app can’t find your flight plan. Make sure you have the right install path in the settings.txt file. See the PDF guide for tips. If you set up your flight plan manually (GPS or FMS) after starting a flight, then it won’t work. You need to either load a flight plan in the world map menu or make a flight plan in MSFS. Let me know if this helped.

Teleport function
I’ll put this in my requested features list. Technically, such feature is possible. It’s only a matter of making it blend in with the existing UI.

Custom maps
Check out my GitHub project page. You can download the source code and add you own custom maps. I’m using Leaflet. Look for code lines 141-150 in the glass.html and glass_landscape.html files. I know it’s not great to have this double-code. There is definitely some code cleaning to do. :slight_smile: Send me a PM if you need help with this.

Hope this helps!

1 Like

Thanks! I’ll check this out!!! I forgot to add one thing, I’m trying to figure out how to add in custom KML overlays into the map. So for example, if I have a list of POIs that I want to casually fly over without creating a crazy flight plan, I can visually check them in the map via a KML.

If I get it working I’ll definitely share it. But I’ll warn you I haven’t been a developer for 20+ years LOL.

EDIT:

  1. Got the magenta line (flight path working). Not sure what I did wrong yet LOL.

  2. I was able to easily add Google Maps, both generic and satellite view! THANK YOU for the tips!

Going to see if I can port over the teleport stuff (I’ll share it). And then it’ll be perfect for me!

EDIT2: I found the source of my flight plan issues for anyone else who might do this. I start all my “companion apps” from a batch file. Seems to be a path issue where MCA can’t find the settings.txt file. So, workaround, just start MCA directly. If I can find a workaround to keep my bat file I’ll let you all know.

1 Like

Thanks! This looks great! Feel free to share anything you have via GitHub.

Adding POI via KML should be possible. You’ll need to tinker around the code a bit and read the Leaflet documentation, but nothing extra complicated. I don’t consider myself a pro developer and I’ve managed to do this. I do this because I enjoy developing it and I learn a lot while building it. I’m sure you’ll find tons of ways to improve it.

Let me know if you find the cause/workaround for the flight plan issue. It’s a new feature so I can imagine that in some cases it won’t work as it should. I’ve tried to make it both MS Store and Steam compatible, but I can only test it on my PC.

1 Like

I found the resolution. The command/batch file needs to cd into the MCA directory before running the exe. That puts the system in the same directory as the settings.txt.

So like:

cd c:\apps\MSFS_MobileCompanionApp
start MSFS_MCA_v1-5.exe

-- then do whatever else I need to do.

I spent much of the afternoon trying to get the teleport to work. Failed miserably LOL.

And I regret I don’t know how to share via GitHub yet. When I said I developed a long time ago, I wasn’t kidding! LOL!! I’ll figure it out!

EDIT: Sent you a little something… just to say thanks for all your great help!

Thanks a lot for your very generous “actually more than” a little something! I really appreciate this! :slight_smile:

And thanks for the tip regarding the batch file. I’ll put it in the known issues list, just in case someone else might use a batch file for this. Just a quick question - do you put a sleep/timeout function into your batch file? I know that the app will only work when you start it once MSFS has been fully loaded (once you’re in the menu).

I’m also new to GitHub so don’t worry. The best way is to fork my repository, then work/make changes on your fork. Once you have something, you’d like to share you can make a pull request. The good thing about this is, that you can see all the changes and everything is traceable. I only use the webpage UI and drag-and-drop changes, but there are also good console commands.

No problem - it’s the least I can do for such a valuable app!

And yes, I do have a timeout, but it’s to let MCA startup so I don’t get a web page error. Plus I use Edge in kiosk mode to minimize the map taking up too much space. I’m only on one monitoring. So, I start MSFS, then when it’s at the main selection page, I startup my other tool as needed.

cd C:\Users\user\MSFS_MobileCompanionApp
start /min cmd /c "MCA.exe"

timeout /T 4

"C:\Program Files (x86)\Microsoft\Edge\Application\msedge.exe" --app=http://localhost:4000/

That opens a lightweight browser windows for me to use.

1 Like

That’s a great tip to use kiosk mode in order to minimize the app’s footprint.

I use the app exclusively with my budget Lenovo Media Pad 8. The tab is practically useless - too slow for anything, even regular browsing. But it’s good enough for the app.

1 Like

Loving the new landscape split screen. Works perfect on a 10" tablet! Would be great if the split location could be adjustable.

Thanks so much for adding the flight plan! I use simbrief to do flight plans and their app to load it into the sim. One click and now on the app!

Requests: add yaw damper toggle to the AP controls. Tbm 900 has a warning if it’s not enabled (can click the dash but would be great in the app.

Would also be great to have altitude adjustment like vertical speed to adjust 1000ft at a time up down.

Loving the development of this app!

Thanks @mentalinc for the feedback!

Yaw damper will be available in the next version. I’m also planning on improving the AP controls for heading and altitude to make it more user-friendly. I can’t give you an eta, but hopefully within the next 4 weeks.

I’ll see what I can do about the split location being adjustable. I like the idea.

1 Like

PSA: I’ve released a hot fix for MSFS Mobile Companion App (v1.5.1). This version fixes the issue of the flight plan not loading on the Steam version. There is no need to download the latest version for those who purchased MSFS from the MS store.

You can download v1.5.1 as always from flightsim.to or GitHub.

1 Like

Hi. Loving the app but is there any way to stop the pop up box (sending instruction) appearing each time you press a button? I find it a little distracting. Thanks.

Little problem here… with the v1.5 and 1.5.1 impossible for me to use the app… I have this message :

192.168.1.14
 * Serving Flask app "glass_server" (lazy loading)
 * Environment: production
   WARNING: This is a development server. Do not use it in a production deployment.
   Use a production WSGI server instead.
 * Debug mode: off
 Exception in thread Thread-2:
 Traceback (most recent call last):
 File "threading.py", line 932, in _bootstrap_inner
File "threading.py", line 870, in run
File "glass_server.py", line 232, in flask_thread_func
File "flask\app.py", line 990, in run
File "werkzeug\serving.py", line 1052, in run_simple
File "werkzeug\serving.py", line 996, in inner
File "werkzeug\serving.py", line 847, in make_server
File "werkzeug\serving.py", line 740, in __init__
File "socketserver.py", line 452, in __init__
File "http\server.py", line 140, in server_bind
File "socket.py", line 756, in getfqdn
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xe8 in position 4: invalid continuation byte

UTF-8 of windows is not allowed in the commands of the app.
The app run well if I cut off UTF-8 in MS Win10 params… but other apps I use (like notepad++, or some shortcuts of MS store for exemple) don’t like it and are broken !

Will there be a future update off this beautiful app to see UTF-8 problem solved ?

The reason for the pop up is due to a delay for the data coming from the sim to the app (btw there is no delay the other way around). The only way to fix this would be to port it to native C++ which would be too complex. If I find a way to improve the latency, the pop up box will surely be removed. I hope this explains it.

I’ll definitely look into it. If it’s OK, I’d like to know some details about your system and the bug so I can troubleshoot it better:

  • Does this error appear when launching the app?
  • Did this error appear in v1.4?
  • Where in Win10 did you cut off UTF-8?

Thanks!

Many thanks for the explanation. Keep up the good work :grinning:

1 Like

Thanks for support.

  • Yes the error come on each lauch.
  • I tried all versions of the app from 1.0 to 1.5.1 and retrieve the problem on each.
  • I cut off the UTF-8 in the next screenshot…

I precise I was wrong in my initial post… The app have problems if the UTF-8 is UNticked… OK when ticked… but my windows store shortcuts not (so unable to lauch MSFS unless 1/ Lauch MSFS… 2/ Tick UTF-8 on… 3/ Lauch your app).

Thanks for the description. I’ve checked the settings on my two PCs where the app works and both had the UTF-8 option unticked. It’ll be a bit complicated for me to reproduce this error but I’ll look for solutions and will let you know as soon as I have a fix.

Thanks a lot :wink: