Mobo/CPU Update - Do I have to reinstall MSFS?

Ableton was fine. Arturia stuff needed reactivating-no big deal. Izotope stuff is fine also…

I don’t use cabase or pro-tools, so my apologies, can’t make a comment

All the best.

1 Like

I tried that with a clone and everything worked fine - Except MSFS. how do I reinstall?

I upgraded my 256gb SSD. At first it didn’t work (bad SSD). In the process I cloned my boot drive from my 256gb SSD to my HDD. I was able to fly FS2020 from my HDD ok. I upgraded my mobo and the SSD still didn’t work, that’s when I returned it for a replacement. The replacement worked as expected. Now I have added a 1TB SSD and cloned back to it from my HDD and the game won’t start. “Microsoft Flight Simulator can’t open because it is offline. The storage device might be missing or disconnected.”

When I try to reinstall from MS Marketplace it has an error “Code: 0x80070057”.

I have the 5 license Office 365home edition. No pop ups to revalidate windows.

Windows 10 Home has had a few updates that all installed fine.

When looking at Apps on the computer the FS2020 says needs repair. This takes me to the MS Marketplace.

Hi fellow.
Chek this:

Sorry for not posting back timely. I did get up and running again after a windows update had finished.

Hi TBCaotion.

This week i upgraded my pc with a i9 10850 cpu, a z490 h gaming motherboard and new ram. My windows was recently fresh installed and on a dedicated ssd C: drive. My MSFS 2020 is on a dedicated ssd D: drive.All drives were kept as is and installed into the new box keeping the same drive letters.
The day before the upgrade i updated to the latest patch and was able to play the sim.
After restarting with the upgrade and clicking on the icon in the menu, the game won’t start.
When trying to start from microsoft store the message says it can’t connect to the app and says check the internet connection …which is fine.
Store is updated
Time and date and language is correct.
Is there a way to access the folders in the drive where MSFS 2020 was downloaded to to find a .exe start file?

i got the message that i would have to “”re-install to original location” required after update to mobo and cpu. deleted it…
Soooo, how and where do i do that?

Well, I upgraded from an Intel 6700K to an AMD 5600X and had no problem at all, everything just worked as expected.
No update required.