Monitor connecting or disconnecting causes freeze (not USB)

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No

Brief description of the issue:

When a device is connected or dicontected the sim freezes. Except when in a menu.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Discontect or connect an device like a monitor going in sleep mode and comming back ot of it (last cause)

PC specs and/or peripheral set up if relevant:

I7-9700K no OC
RTX3080 No OC
Honeycomb Alpha Yoke
Thrustmaster TWCS Throtle & T-Rudder
2 monitors one is from MSI 1440p 165HZ (main), AOC 1080p 90HZ

If on PC, Fault Bucket ID - Instructions here - Please type in just the Fault Bucket ID # rather than a screenshot for privacy reasons:

none created when this happens

Build Version # when you first started experiencing this issue:

1.26.5.0


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

If on PC, Fault Bucket ID - Instructions here - Please type in just the Fault Bucket ID # rather than a screenshot for privacy reasons:

This is a well known / documented issue, which actually more often then not results in CTD so lucky if just freezing.

Ensuring your power settings are set to maximum and turn off suspend / sleep mode for your USB devices, etc… helps.

the weird thing is is that it was gone and USB devices (that are used by the sim) work now better and is a long freeze. But a device like my monitoras going to sleep and waking them back up Frezzes and dont come back or other device like my yubico key als freezes and even CTD but with no event viewer log.

did you use the sound over the monitor ?

I wonder how can a monitor go in sleep mode if it is used … and the yubico key, this cause a freeze/ctd ??? That sounds strange… :relaxed:

1 Like

Topic title altered to reflect “monitor”, so it does not conflict a bug logged topic regarding disconnecting of USB’s:
https://forums.flightsimulator.com/t/ctd-when-connecting-or-disconnecting-a-usb-device/476528

1 Like

Does your monitor also have a USB connection to the PC?

2 Likes

I wonder how can a monitor go in sleep mode if it is used … and the yubico key, this cause a freeze/ctd ???

This is because windows puts your monitor to sleep when it thinks you are away. sadly it happend while in cruise of this flight. IDK how but it did, funny thing is if I turn of my monitor physically with the power button on the monitor, with MSFS open it doesn’t crash.

Yubico key was a few weeks back not tested again later without being in the menu.

Does your monitor also have a USB connection to the PC?

No

ah… that sound then more an issue with the sleep-mode, but… also strange :rofl:

Normaly windows not bring monitors ( or the system ) into sleep mode, if a game is running. And also not only one of two monitors would be affected then. Are you sure that it was “monitors sleep mode” and not a connection issue ? ( I know, also then msfs should not crash , but may be its then a different kind of system problem :wink: ). You can check your power-plan setting and that your gpu drivers is up2date…

On occasion some monitors (I ran into this once) have allocated USB inputs not used … they had the ability to put one in for only firmware updates but did not. Granted this was back in the days of 720p being wow.

As in a host port? The monitor turning off would be like the PC losing a USB hub.

no it puts both to sleep, not just one.

okay… so we come closer :slight_smile: … And you are sure that not the whole PC goes into hibernation ( which would explain why turn off the monitor not cause a crash ) ? If so , it is clear that MSFS will not survive…

As mentioned, may be check your power-plan and also activate the windows game mode.