Mooney M20R Avionics Power Off

1st cross country with multiple waypoints.
Lost avionics power 2 minutes after takeoff. No GPS visuals, radio freqs, autopilot lights, ATC error msg - no power.
Could not recycle with main switch.
Help any suggestions?


I stopped opening the Sim as an Administrator and haven’t seen this problem again… Hope it works for you…

I moved ground aircraft to zero at the advice of another user. It fixed it for me. I contacted Carenado and they replied they need to see a video and they marked my ticket as “resolved”. Guess they thought I was being untruthful.

Same thing has happened to me a few times now, definately needs a fix

1 Like

Tried suggestions, didn’t work. M20R came to life in new flight just like I left it the last time I closed MSFS - no avionics and Avionics master switch did nothing.

I changed to C152, flew a bit, restarted with M20R and flew for 70 minutes with no problems with avionics powering off!

However, I could not Enter GNS350 to Activate an approach no matter what I did. Enter didn’t work.

Same here, however the engine lost power at the same time but kept running and then restored itself. Circuit breakers do not appear to be modelled so I couldn’t cycle them.
I landed switched off everything, but still no avionics on switching back on.

I find that flying a complex aircraft, such as the TBM or King Air, before flying the Mooney, prevents any avionics failures while flying the Mooney.

I remember back in my FSX days, I had a couple nice payware planes, and the recommendation from the payware companies was always to have a standard plane active in FSX when loading in, and then switch to your payware aircraft. Minimizes bugs, etc. Maybe this is the same precaution needed here as you suggest.

Try to set your cockpit instruments’ refresh rate to High.

I fly the m20r a lot and this has happened to me but only ever when I’m in the vicinity of other players. It started happening after the last MSFS patch release, and I’ve seen it impact other planes too. I really hope it’s fixed after tmrw’s update as it’s really annoying. I’ve also had phantom mixture and lights control. Again, only ever in MP at a location with other players nearby.

Same problem on my side. Bought the Mooney yesterday and I have no Avionics…make no difference it I start cold and dark or ready for take off. So this payware is unusable for me at the moment

I also purchased it yesterday but I don’t have these issues. Do you have any aicraft/system mods installed like the FPSfix or the Garmin mod?

Hm. I flew it over Japan yesterday post patch. Well obviously, because…Japan! :joy: For almost 2 hours and didn’t have any issues. No other mods put back into community by that time btw.

No only Liveries packages and the A320 Mod

I’d update the A320 mod if possible, also try loading up a default plane first and then load the Mooney. The only other thing to try is switching on the two generic aircraft settings in your graphics options.

I’m about to fire up MSFS now, so will load the Mooney first and see if I can replicate your issue.